From ebd73c496706a37c5ddaaae37da74fca52223f24 Mon Sep 17 00:00:00 2001
From: Nicola Sella <nsella@redhat.com>
Date: Mar 02 2021 12:47:08 +0000
Subject: Update to 1.13.0


---

diff --git a/.gitignore b/.gitignore
index 210234e..5549b62 100644
--- a/.gitignore
+++ b/.gitignore
@@ -57,3 +57,4 @@
 /librepo-1.11.3.tar.gz
 /librepo-1.12.0.tar.gz
 /librepo-1.12.1.tar.gz
+/librepo-1.13.0.tar.gz
diff --git a/librepo.spec b/librepo.spec
index 480a43a..a87d46d 100644
--- a/librepo.spec
+++ b/librepo.spec
@@ -1,23 +1,6 @@
-%global libcurl_version 7.28.0
+%global libcurl_version 7.52.0
 
-%define __cmake_in_source_build 1
-
-%if 0%{?rhel} && 0%{?rhel} <= 7
-# Do not build bindings for python3 for RHEL <= 7
-%bcond_with python3
-# python-flask is not in RHEL7
-%bcond_with pythontests
-%else
-%bcond_without python3
-%bcond_without pythontests
-%endif
-
-%if 0%{?rhel} > 7 || 0%{?fedora} > 29
-# Do not build bindings for python2 for RHEL > 7 and Fedora > 29
-%bcond_with python2
-%else
-%bcond_without python2
-%endif
+%undefine __cmake_in_source_build
 
 %if 0%{?rhel}
 %bcond_with zchunk
@@ -28,15 +11,14 @@
 %global dnf_conflict 2.8.8
 
 Name:           librepo
-Version:        1.12.1
-Release:        2%{?dist}
+Version:        1.13.0
+Release:        1%{?dist}
 Summary:        Repodata downloading library
 
 License:        LGPLv2+
 URL:            https://github.com/rpm-software-management/librepo
 Source0:        %{url}/archive/%{version}/%{name}-%{version}.tar.gz
 
-BuildRequires: make
 BuildRequires:  cmake
 BuildRequires:  gcc
 BuildRequires:  check-devel
@@ -64,48 +46,15 @@ Requires:       %{name}%{?_isa} = %{version}-%{release}
 %description devel
 Development files for librepo.
 
-%if %{with python2}
-%package -n python2-%{name}
-Summary:        Python bindings for the librepo library
-%{?python_provide:%python_provide python2-%{name}}
-%if 0%{?rhel} && 0%{?rhel} <= 7
-BuildRequires:  python-sphinx
-%else
-BuildRequires:  python2-sphinx
-%endif
-BuildRequires:  python2-devel
-%if %{with pythontests}
-BuildRequires:  python2-flask
-BuildRequires:  python2-nose
-BuildRequires:  python2-requests
-%if (0%{?rhel} && 0%{?rhel} <= 7)
-BuildRequires:  pyxattr
-BuildRequires:  pygpgme
-%else
-BuildRequires:  python2-pyxattr
-BuildRequires:  python2-gpg
-%endif
-%endif
-# endif with pythontests
-Requires:       %{name}%{?_isa} = %{version}-%{release}
-Conflicts:      python2-dnf < %{dnf_conflict}
-
-%description -n python2-%{name}
-Python 2 bindings for the librepo library.
-%endif
-
-%if %{with python3}
 %package -n python3-%{name}
 Summary:        Python 3 bindings for the librepo library
 %{?python_provide:%python_provide python3-%{name}}
 BuildRequires:  python3-devel
-%if %{with pythontests}
 BuildRequires:  python3-gpg
 BuildRequires:  python3-flask
 BuildRequires:  python3-nose
 BuildRequires:  python3-pyxattr
 BuildRequires:  python3-requests
-%endif
 BuildRequires:  python3-sphinx
 Requires:       %{name}%{?_isa} = %{version}-%{release}
 # Obsoletes Fedora 27 package
@@ -114,56 +63,19 @@ Conflicts:      python3-dnf < %{dnf_conflict}
 
 %description -n python3-%{name}
 Python 3 bindings for the librepo library.
-%endif
 
 %prep
 %autosetup -p1
 
-mkdir build-py2
-mkdir build-py3
-
 %build
-%if %{with python2}
-pushd build-py2
-  %cmake -DPYTHON_DESIRED:FILEPATH=%{__python2} %{!?with_zchunk:-DWITH_ZCHUNK=OFF} -DENABLE_PYTHON_TESTS=%{?with_pythontests:ON}%{!?with_pythontests:OFF} ..
-  %make_build
-popd
-%endif
-
-%if %{with python3}
-pushd build-py3
-  %cmake -DPYTHON_DESIRED:FILEPATH=%{__python3} %{!?with_zchunk:-DWITH_ZCHUNK=OFF} -DENABLE_PYTHON_TESTS=%{?with_pythontests:ON}%{!?with_pythontests:OFF} ..
-  %make_build
-popd
-%endif
+%cmake %{!?with_zchunk:-DWITH_ZCHUNK=OFF}
+%cmake_build
 
 %check
-%if %{with python2}
-pushd build-py2
-  #ctest -VV
-  make ARGS="-V" test
-popd
-%endif
-
-%if %{with python3}
-pushd build-py3
-  #ctest -VV
-  make ARGS="-V" test
-popd
-%endif
+%ctest
 
 %install
-%if %{with python2}
-pushd build-py2
-  %make_install
-popd
-%endif
-
-%if %{with python3}
-pushd build-py3
-  %make_install
-popd
-%endif
+%cmake_install
 
 %if 0%{?rhel} && 0%{?rhel} <= 7
 %post -p /sbin/ldconfig
@@ -182,17 +94,21 @@ popd
 %{_libdir}/pkgconfig/%{name}.pc
 %{_includedir}/%{name}/
 
-%if %{with python2}
-%files -n python2-%{name}
-%{python2_sitearch}/%{name}/
-%endif
-
-%if %{with python3}
 %files -n python3-%{name}
 %{python3_sitearch}/%{name}/
-%endif
 
 %changelog
+* Mon Mar 01 2021 Nicola Sella <nsella@redhat.com> - 1.13.0-1
+- Update to 1.13.0
+- Add support for working with certificates used with proxy
+- Drop Python 2 support
+- Fix: lr_perform() - Avoid 100% CPU usage
+- Add support for pkcs11 certificate and key for repository authorization
+- Fix default value for LRO_SSLVERIFYSTATUS
+- Don't use max_ranges to determine if we expect zchunk callback
+- Prefer HTTP over FTP mirrors when zchunk is enabled
+- Fixed mem leaks and typos
+
 * Tue Jan 26 2021 Fedora Release Engineering <releng@fedoraproject.org> - 1.12.1-2
 - Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
 
diff --git a/sources b/sources
index c603d5b..4b4d161 100644
--- a/sources
+++ b/sources
@@ -1 +1 @@
-SHA512 (librepo-1.12.1.tar.gz) = eff4eaa5206e6cbe13b253d7cc37b5a6085e05c807a56a75ad25f9b4c4035bf564336292bdea35d83d80e2953eeac299b7336f8dc485eed71480abfec6bcbe69
+SHA512 (librepo-1.13.0.tar.gz) = 6e67bbcf3711607f8247bec9343b0a883d1aa75290d6cd539f207ff6df8f341a85b823ac031f1b9f097f23cfb74ab91c843c028bba5b2dc3d856975217af3cc7