From 4ffba63009e12181988a64eefc2a1f0e0935cc19 Mon Sep 17 00:00:00 2001
From: Jaroslav Mracek <jmracek@redhat.com>
Date: Jun 26 2018 08:38:36 +0000
Subject: Update to 1.9.0


Additionally it reverts %ldconfig_scriptlets because it makes a problem on
Centos7/RHEL7

---

diff --git a/.gitignore b/.gitignore
index 10701a4..8b80a23 100644
--- a/.gitignore
+++ b/.gitignore
@@ -43,3 +43,4 @@
 /librepo-1.7.20.tar.gz
 /librepo-1.8.0.tar.gz
 /librepo-1.8.1.tar.gz
+/librepo-1.9.0.tar.gz
diff --git a/librepo.spec b/librepo.spec
index ee4f0ca..385be6d 100644
--- a/librepo.spec
+++ b/librepo.spec
@@ -7,10 +7,11 @@
 %bcond_without python3
 %bcond_without tests
 %endif
+%global dnf_conflict 2.8.8
 
 Name:           librepo
-Version:        1.8.1
-Release:        9%{?dist}
+Version:        1.9.0
+Release:        1%{?dist}
 Summary:        Repodata downloading library
 
 License:        LGPLv2+
@@ -21,11 +22,11 @@ BuildRequires:  cmake
 BuildRequires:  gcc
 BuildRequires:  check-devel
 BuildRequires:  doxygen
-BuildRequires:  expat-devel
 BuildRequires:  glib2-devel >= 2.26.0
 BuildRequires:  gpgme-devel
 BuildRequires:  libattr-devel
 BuildRequires:  libcurl-devel >= 7.19.0
+BuildRequires:  libxml2-devel
 BuildRequires:  openssl-devel
 
 %description
@@ -42,19 +43,25 @@ Development files for librepo.
 %package -n python2-%{name}
 Summary:        Python bindings for the librepo library
 %{?python_provide:%python_provide python2-%{name}}
+%if 0%{?rhel} && 0%{?rhel} <= 7
+BuildRequires:  python-sphinx
+BuildRequires:  pygpgme
+%else
+BuildRequires:  python2-sphinx
 BuildRequires:  python2-pygpgme
-BuildRequires:  python2-devel
-%if %{with tests}
-BuildRequires:  python2-flask
-BuildRequires:  python2-nose
 %endif
-BuildRequires:  python2-sphinx
+BuildRequires:  python2-devel
 %if (0%{?rhel} && 0%{?rhel} <= 7) || (0%{?fedora} && 0%{?fedora} <= 27)
 BuildRequires:  pyxattr
 %else
 BuildRequires:  python2-pyxattr
 %endif
+%if %{with tests}
+BuildRequires:  python2-flask
+BuildRequires:  python2-nose
+%endif
 Requires:       %{name}%{?_isa} = %{version}-%{release}
+Conflicts:      python2-dnf < %{dnf_conflict}
 
 %description -n python2-%{name}
 Python 2 bindings for the librepo library.
@@ -72,7 +79,9 @@ BuildRequires:  python3-nose
 BuildRequires:  python3-sphinx
 BuildRequires:  python3-pyxattr
 Requires:       %{name}%{?_isa} = %{version}-%{release}
+# Obsoletes Fedora 27 package
 Obsoletes:      platform-python-%{name} < %{version}-%{release}
+Conflicts:      python3-dnf < %{dnf_conflict}
 
 %description -n python3-%{name}
 Python 3 bindings for the librepo library.
@@ -121,7 +130,8 @@ pushd build-py3
 popd
 %endif
 
-%ldconfig_scriptlets
+%post -p /sbin/ldconfig
+%postun -p /sbin/ldconfig
 
 %files
 %license COPYING
@@ -142,6 +152,9 @@ popd
 %endif
 
 %changelog
+* Tue Jun 26 2018 Jaroslav Mracek <> - 1.9.0-1
+- Update to 1.9.0
+
 * Mon Jun 18 2018 Miro HronĨok <mhroncok@redhat.com> - 1.8.1-9
 - Rebuilt for Python 3.7
 
diff --git a/sources b/sources
index 0941a5f..4f30a90 100644
--- a/sources
+++ b/sources
@@ -1 +1 @@
-SHA512 (librepo-1.8.1.tar.gz) = 04c82e4e0645e06e135113d5dd0e2b0371c6813b1aa47ab739883aea898fff0266b83b16c75aae266ba3d0390bb06785f21d390e8df99bc05f2f2980cd925a3a
+SHA512 (librepo-1.9.0.tar.gz) = 2c18b41c976a509c86af3565c87ac9f9c988e73b6086fdfe03ce84b430ac1736bb861e68cf6f73bbdb5c1cf6365b86fa581a6088bbc4485b61d428cb30a64061