From 3717051fa086b92d5382f2483c9e08ac05e4954f Mon Sep 17 00:00:00 2001
From: Igor Gnatenko <ignatenkobrain@fedoraproject.org>
Date: Aug 23 2017 12:31:50 +0000
Subject: Update to 1.8.0


Signed-off-by: Igor Gnatenko <ignatenkobrain@fedoraproject.org>

---

diff --git a/.gitignore b/.gitignore
index 913daf6..05eee99 100644
--- a/.gitignore
+++ b/.gitignore
@@ -41,3 +41,4 @@
 /librepo-1.7.18.tar.gz
 /librepo-1.7.19.tar.gz
 /librepo-1.7.20.tar.gz
+/librepo-1.8.0.tar.gz
diff --git a/0001-Fix-rmtree-failure-in-tearDown.patch b/0001-Fix-rmtree-failure-in-tearDown.patch
deleted file mode 100644
index 462182d..0000000
--- a/0001-Fix-rmtree-failure-in-tearDown.patch
+++ /dev/null
@@ -1,85 +0,0 @@
-From 7ee6f0be21c9c841e14e1c1008cf7c3634da0831 Mon Sep 17 00:00:00 2001
-From: Tomas Orsava <torsava@redhat.com>
-Date: Fri, 18 Aug 2017 14:37:16 +0200
-Subject: [PATCH] Fix rmtree failure in tearDown
-
-We need to remove the S.gpg-agent sockets, because when one of the
-sockets gets closed by shutil.rmtree, gpg will try to close the 3
-remaining sockets and may do it before shutil.rmtree deletes them.
-This results in rmtree trying to delete a non existing file and can
-exiting with an error `No such file or directory`.
----
- tests/python/tests/test_yum_repo_downloading.py | 17 ++++++++++++++++-
- tests/python/tests/test_yum_repo_locating.py    | 17 ++++++++++++++++-
- 2 files changed, 32 insertions(+), 2 deletions(-)
-
-diff --git a/tests/python/tests/test_yum_repo_downloading.py b/tests/python/tests/test_yum_repo_downloading.py
-index ad597dc..0049946 100644
---- a/tests/python/tests/test_yum_repo_downloading.py
-+++ b/tests/python/tests/test_yum_repo_downloading.py
-@@ -2,7 +2,7 @@ import sys
- import time
- import gpgme
- import shutil
--import os.path
-+import os
- import tempfile
- import unittest
- 
-@@ -32,6 +32,21 @@ class TestCaseYumRepoDownloading(TestCaseWithFlask):
-             os.environ.pop('GNUPGHOME')
-         else:
-             os.environ['GNUPGHOME'] = self._gnupghome
-+
-+        # We need to remove the S.gpg-agent sockets, because when one of the
-+        # sockets gets closed by shutil.rmtree, gpg will try to close the 3
-+        # remaining sockets and may do it before shutil.rmtree deletes them.
-+        # This results in rmtree trying to delete a non existing file and can
-+        # exiting with an error `No such file or directory`.
-+        try:
-+            gpg_agent_files = ["S.gpg-agent", "S.gpg-agent.browser",
-+                               "S.gpg-agent.extra", "S.gpg-agent.ssh"]
-+            for file in gpg_agent_files:
-+                os.remove(os.path.join(self.tmpdir, "keyring", file))
-+        except OSError:
-+            # GPG deleted the remaining file(s) faster then we did
-+            pass
-+
-         shutil.rmtree(self.tmpdir)
- 
-     def test_download_repo_01(self):
-diff --git a/tests/python/tests/test_yum_repo_locating.py b/tests/python/tests/test_yum_repo_locating.py
-index 8f4bea5..02d6aea 100644
---- a/tests/python/tests/test_yum_repo_locating.py
-+++ b/tests/python/tests/test_yum_repo_locating.py
-@@ -1,4 +1,4 @@
--import os.path
-+import os
- import tempfile
- import shutil
- import unittest
-@@ -34,6 +34,21 @@ class TestCaseYumRepoLocating(TestCase):
-             os.environ.pop('GNUPGHOME')
-         else:
-             os.environ['GNUPGHOME'] = self._gnupghome
-+
-+        # We need to remove the S.gpg-agent sockets, because when one of the
-+        # sockets gets closed by shutil.rmtree, gpg will try to close the 3
-+        # remaining sockets and may do it before shutil.rmtree deletes them.
-+        # This results in rmtree trying to delete a non existing file and can
-+        # exiting with an error `No such file or directory`.
-+        try:
-+            gpg_agent_files = ["S.gpg-agent", "S.gpg-agent.browser",
-+                               "S.gpg-agent.extra", "S.gpg-agent.ssh"]
-+            for file in gpg_agent_files:
-+                os.remove(os.path.join(self.tmpdir, "keyring", file))
-+        except OSError:
-+            # GPG deleted the remaining file(s) faster then we did
-+            pass
-+
-         shutil.rmtree(self.tmpdir)
- 
-     def test_read_mirrorlist(self):
--- 
-2.13.5
-
diff --git a/librepo.spec b/librepo.spec
index 916a8cf..e45c82c 100644
--- a/librepo.spec
+++ b/librepo.spec
@@ -13,15 +13,13 @@
 %endif
 
 Name:           librepo
-Version:        1.7.20
-Release:        9%{?dist}
+Version:        1.8.0
+Release:        1%{?dist}
 Summary:        Repodata downloading library
 
 License:        LGPLv2+
 URL:            https://github.com/rpm-software-management/librepo
-Source0:        %{url}/archive/%{name}-%{version}/%{name}-%{version}.tar.gz
-
-Patch0:         0001-Fix-rmtree-failure-in-tearDown.patch
+Source0:        %{url}/archive/%{version}/%{name}-%{version}.tar.gz
 
 BuildRequires:  cmake
 BuildRequires:  gcc
@@ -92,7 +90,7 @@ Python 3 bindings for the librepo library.
 %endif # with platform_python
 
 %prep
-%autosetup -n %{name}-%{name}-%{version} -p1
+%autosetup -p1
 
 mkdir build build-py3 build-platpy
 
@@ -208,6 +206,9 @@ popd
 %endif # with platform_python
 
 %changelog
+* Wed Aug 23 2017 Igor Gnatenko <ignatenko@redhat.com> - 1.8.0-1
+- Update to 1.8.0
+
 * Fri Aug 18 2017 Tomas Orsava <torsava@redhat.com> - 1.7.20-9
 - Added Patch 0 to fix a tearDown failure in the test suite
 
diff --git a/sources b/sources
index 31da5d1..4bab7dd 100644
--- a/sources
+++ b/sources
@@ -1 +1 @@
-f8889c14981a1f7338531cdad69856ec  librepo-1.7.20.tar.gz
+SHA512 (librepo-1.8.0.tar.gz) = f79438579d5d732b698de5f37275f5e744697a6cbb207217188cad01040a8c45c77e151641128a54028e7527b1f858a705ff278815d528905f1df748f3c34f87