# -*- sh-shell: rpm -*-
#
# Licensed to the Apache Software Foundation (ASF) under one
# or more contributor license agreements. See the NOTICE file
# distributed with this work for additional information
# regarding copyright ownership. The ASF licenses this file
# to you under the Apache License, Version 2.0 (the
# "License"); you may not use this file except in compliance
# with the License. You may obtain a copy of the License at
#
# http://www.apache.org/licenses/LICENSE-2.0
#
# Unless required by applicable law or agreed to in writing,
# software distributed under the License is distributed on an
# "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
# KIND, either express or implied. See the License for the
# specific language governing permissions and limitations
# under the License.
%bcond_without use_flight
%bcond_with use_gandiva
%bcond_with use_mimalloc
%bcond_without use_ninja
# TODO: Enable this. This works on local but is fragile on GitHub Actions and
# Travis CI.
%bcond_with use_s3
%bcond_without have_rapidjson
%bcond_without have_re2
%bcond_without have_utf8proc
Name: libarrow
Version: 7.0.0
Release: 1%{?dist}
Summary: A toolbox for accelerated data interchange and in-memory processing
License: ASL 2.0
URL: https://arrow.apache.org/
Source0: https://dist.apache.org/repos/dist/release/arrow/arrow-%{version}/apache-arrow-%{version}.tar.gz
Patch0001: 0001-cpp-CMakeLists.txt.patch
# Apache ORC (liborc) has numerous compile errors and apparently assumes
# a 64-bit build and runtime environment. This is only consumer of the liborc
# package, and in turn the only consumer of this and liborc is Ceph, which
# is also 64-bit only
ExcludeArch: %{ix86} %{arm}
BuildRequires: bison
BuildRequires: boost-devel
BuildRequires: brotli-devel
BuildRequires: bzip2-devel
BuildRequires: cmake
%if %{with use_ninja}
BuildRequires: ninja-build
%endif
BuildRequires: meson
%if %{with use_s3}
BuildRequires: curl-devel
%endif
BuildRequires: flex
BuildRequires: gcc-c++
BuildRequires: gflags-devel
BuildRequires: glog-devel
BuildRequires: grpc-devel
BuildRequires: grpc-plugins
BuildRequires: libzstd-devel
BuildRequires: lz4-devel
BuildRequires: openssl-devel
BuildRequires: pkgconfig
BuildRequires: python3-devel
BuildRequires: python3-numpy
BuildRequires: xsimd-devel
BuildRequires: abseil-cpp-devel
BuildRequires: c-ares-devel
BuildRequires: thrift-devel
%if %{with have_rapidjson}
BuildRequires: rapidjson-devel
%endif
%if %{with have_re2}
BuildRequires: re2-devel
%endif
BuildRequires: snappy-devel
%if %{with have_utf8proc}
BuildRequires: utf8proc-devel
%endif
BuildRequires: zlib-devel
BuildRequires: liborc-devel
%if %{with use_gandiva}
BuildRequires: llvm-devel
BuildRequires: ncurses-devel
%endif
BuildRequires: gobject-introspection-devel
BuildRequires: gtk-doc
%description
Apache Arrow defines a language-independent columnar memory
format for flat and hierarchical data, organized for efficient
analytic operations on modern hardware like CPUs and GPUs. The
Arrow memory format also supports zero-copy reads for lightning-
fast data access without serialization overhead
%files
%{_libdir}/libarrow.so.*
#--------------------------------------------------------------------
%package doc
Summary: Documentation files for Apache Arrow C++
BuildArch: noarch
%description doc
Documentation files for Apache Arrow C++.
%files doc
%license LICENSE.txt
%doc README.md NOTICE.txt
%exclude %{_docdir}/arrow/
#--------------------------------------------------------------------
%package devel
Summary: Libraries and header files for Apache Arrow C++
Requires: %{name} = %{version}-%{release}
Requires: brotli-devel
Requires: bzip2-devel
Requires: libzstd-devel
Requires: lz4-devel
Requires: openssl-devel
%if %{with have_rapidjson}
Requires: rapidjson-devel
%endif
%if %{with have_re2}
Requires: re2-devel
%endif
Requires: snappy-devel
%if %{with have_utf8proc}
Requires: utf8proc-devel
%endif
Requires: zlib-devel
%description devel
Libraries and header files for Apache Arrow C++.
%files devel
%dir %{_includedir}/arrow
%{_includedir}/arrow/*
%exclude %{_includedir}/arrow/dataset/
%if %{with use_flight}
%exclude %{_includedir}/arrow/flight/
%exclude %{_includedir}/arrow-flight-glib
%endif
%exclude %{_includedir}/arrow/python/
%exclude %{_libdir}/cmake/arrow/*
%dir %{_libdir}/cmake/arrow
%{_libdir}/cmake/arrow/ArrowConfig*.cmake
%{_libdir}/cmake/arrow/ArrowOptions.cmake
%{_libdir}/cmake/arrow/ArrowTargets*.cmake
%{_libdir}/cmake/arrow/FindArrow.cmake
%{_libdir}/cmake/arrow/arrow-config.cmake
%{_libdir}/libarrow.so
%{_libdir}/pkgconfig/arrow-compute.pc
%{_libdir}/pkgconfig/arrow-csv.pc
%{_libdir}/pkgconfig/arrow-filesystem.pc
%{_libdir}/pkgconfig/arrow-json.pc
%{_libdir}/pkgconfig/arrow-orc.pc
%{_libdir}/pkgconfig/arrow.pc
%exclude %{_libdir}/libarrow.a
#--------------------------------------------------------------------
%package dataset-libs
Summary: C++ library to read and write semantic datasets
Requires: %{name} = %{version}-%{release}
Requires: %{name}-doc = %{version}-%{release}
%description dataset-libs
This package contains the libraries for Apache Arrow dataset.
%files dataset-libs
%{_libdir}/libarrow_dataset.so.*
#--------------------------------------------------------------------
%package dataset-devel
Summary: Libraries and header files for Apache Arrow dataset
Requires: %{name}-dataset-libs = %{version}-%{release}
%description dataset-devel
Libraries and header files for Apache Arrow dataset.
%files dataset-devel
%dir %{_includedir}/arrow/dataset
%{_includedir}/arrow/dataset/*
%{_libdir}/cmake/arrow/ArrowDatasetConfig*.cmake
%{_libdir}/cmake/arrow/ArrowDatasetTargets*.cmake
%{_libdir}/cmake/arrow/FindArrowDataset.cmake
%{_libdir}/libarrow_dataset.so
%{_libdir}/pkgconfig/arrow-dataset.pc
%exclude %{_libdir}/libarrow_dataset.a
#--------------------------------------------------------------------
%if %{with use_flight}
%package flight-libs
Summary: C++ library for fast data transport
Requires: %{name} = %{version}-%{release}
Requires: %{name}-doc = %{version}-%{release}
Requires: openssl
%description flight-libs
This package contains the libraries for Apache Arrow Flight.
%files flight-libs
%{_libdir}/libarrow_flight.so.*
%{_libdir}/libarrow-flight-glib.so.*
%{_libdir}/girepository-1.0/ArrowFlight-1.0.typelib
#--------------------------------------------------------------------
%package flight-devel
Summary: Libraries and header files for Apache Arrow Flight
Requires: %{name}-flight-libs = %{version}-%{release}
%description flight-devel
Libraries and header files for Apache Arrow Flight.
%files flight-devel
%dir %{_includedir}/arrow/flight
%{_includedir}/arrow/flight/*
%dir %{_includedir}/arrow-flight-glib
%{_includedir}/arrow-flight-glib/*
%{_libdir}/cmake/arrow/ArrowFlightConfig*.cmake
%{_libdir}/cmake/arrow/ArrowFlightTargets*.cmake
%{_libdir}/cmake/arrow/FindArrowFlight.cmake
%{_libdir}/libarrow_flight.so
%{_libdir}/libarrow-flight-glib.so
%{_libdir}/pkgconfig/arrow-flight.pc
%{_libdir}/pkgconfig/arrow-flight-glib.pc
%exclude %{_libdir}/libarrow_flight.a
%exclude %{_libdir}/libarrow-flight-glib.a
%endif
#--------------------------------------------------------------------
%if %{with use_gandiva}
%package -n gandiva-libs
Summary: C++ library for compiling and evaluating expressions
Requires: %{name} = %{version}-%{release}
Requires: %{name}-doc = %{version}-%{release}
Requires: ncurses-libs
%description -n gandiva-libs
This package contains the libraries for Gandiva.
%files -n gandiva-libs
%{_libdir}/libgandiva.so.*
#--------------------------------------------------------------------
%package -n gandiva-devel
Summary: Libraries and header files for Gandiva
Requires: gandiva-libs = %{version}-%{release}
Requires: llvm-devel
%description -n gandiva-devel
Libraries and header files for Gandiva.
%files -n gandiva-devel
%dir %{_includedir}/gandiva
%{_includedir}/gandiva/*
%{_libdir}/cmake/arrow/GandivaConfig*.cmake
%{_libdir}/cmake/arrow/GandivaTargets*.cmake
%{_libdir}/cmake/arrow/FindGandiva.cmake
%{_libdir}/libgandiva.so
%{_libdir}/pkgconfig/gandiva.pc
%exclude %{_libdir}/libgandiva.a
%endif
#--------------------------------------------------------------------
%package python-libs
Summary: Python integration library for Apache Arrow
Requires: %{name} = %{version}-%{release}
Requires: %{name}-doc = %{version}-%{release}
Requires: python3-numpy
%description python-libs
This package contains the Python integration library for Apache Arrow.
%files python-libs
%{_libdir}/libarrow_python.so.*
#--------------------------------------------------------------------
%package python-devel
Summary: Libraries and header files for Python integration library
Requires: %{name}-devel = %{version}-%{release}
Requires: %{name} = %{version}-%{release}
Requires: %{name}-python-libs = %{version}-%{release}
Requires: python3-devel
%description python-devel
Libraries and header files for Python integration library for Apache Arrow.
%files python-devel
%dir %{_includedir}/arrow/python
%{_includedir}/arrow/python/*
%exclude %{_includedir}/arrow/python/flight.h
%{_libdir}/cmake/arrow/ArrowPythonConfig*.cmake
%{_libdir}/cmake/arrow/ArrowPythonTargets*.cmake
%{_libdir}/cmake/arrow/FindArrowPython.cmake
%{_libdir}/libarrow_python.so
%{_libdir}/pkgconfig/arrow-python.pc
%exclude %{_libdir}/libarrow_python.a
#--------------------------------------------------------------------
%if %{with use_flight}
%package python-flight-libs
Summary: Python integration library for Apache Arrow Flight
Requires: %{name}-flight-libs = %{version}-%{release}
Requires: %{name}-python-libs = %{version}-%{release}
Requires: %{name}-doc = %{version}-%{release}
%description python-flight-libs
This package contains the Python integration library for Apache Arrow Flight.
%files python-flight-libs
%{_libdir}/libarrow_python_flight.so.*
#--------------------------------------------------------------------
%package python-flight-devel
Summary: Libraries and header files for Python integration
Requires: %{name}-flight-devel = %{version}-%{release}
Requires: %{name}-python-devel = %{version}-%{release}
Requires: %{name}-python-flight-libs = %{version}-%{release}
%description python-flight-devel
Libraries and header files for Python integration library for
Apache Arrow Flight.
%files python-flight-devel
%{_includedir}/arrow/python/flight.h
%{_libdir}/cmake/arrow/ArrowPythonFlightConfig*.cmake
%{_libdir}/cmake/arrow/ArrowPythonFlightTargets*.cmake
%{_libdir}/cmake/arrow/FindArrowPythonFlight.cmake
%{_libdir}/libarrow_python_flight.so
%{_libdir}/pkgconfig/arrow-python-flight.pc
%exclude %{_libdir}/libarrow_python_flight.a
%endif
#--------------------------------------------------------------------
%package -n plasma-libs
Summary: Runtime libraries for Plasma in-memory object store
Requires: %{name} = %{version}-%{release}
Requires: %{name}-doc = %{version}-%{release}
%description -n plasma-libs
This package contains the libraries for Plasma in-memory object store.
%files -n plasma-libs
%{_libdir}/libplasma.so.*
#--------------------------------------------------------------------
%package -n plasma-store-server
Summary: Server for Plasma in-memory object store
Requires: plasma-libs = %{version}-%{release}
Requires: %{name}-doc = %{version}-%{release}
%description -n plasma-store-server
This package contains the server for Plasma in-memory object store.
%files -n plasma-store-server
%{_bindir}/plasma-store-server
#--------------------------------------------------------------------
%package -n plasma-libs-devel
Summary: Libraries and header files for Plasma in-memory object store
Requires: plasma-libs = %{version}-%{release}
# plasma-devel a.k.a. kdelibs-devel provides
# conflicts with all versions of plasma-devel %%{_libdir}/libplasma.so
BuildConflicts: plasma-devel
%description -n plasma-libs-devel
Libraries and header files for Plasma in-memory object store.
%files -n plasma-libs-devel
%dir %{_includedir}/plasma
%{_includedir}/plasma/*
%{_libdir}/cmake/arrow/PlasmaConfig*.cmake
%{_libdir}/cmake/arrow/PlasmaTargets*.cmake
%{_libdir}/cmake/arrow/FindPlasma.cmake
%{_libdir}/libplasma.so
%{_libdir}/pkgconfig/plasma*.pc
%exclude %{_libdir}/libplasma.a
#--------------------------------------------------------------------
%package -n parquet-libs
Summary: Runtime libraries for Apache Parquet C++
Requires: boost-program-options
Requires: %{name} = %{version}-%{release}
Requires: %{name}-doc = %{version}-%{release}
Requires: openssl
%description -n parquet-libs
This package contains the libraries for Apache Parquet C++.
%files -n parquet-libs
%{_libdir}/libparquet.so.*
#--------------------------------------------------------------------
%package -n parquet-libs-devel
Summary: Libraries and header files for Apache Parquet C++
Requires: parquet-libs = %{version}-%{release}
Requires: zlib-devel
%description -n parquet-libs-devel
Libraries and header files for Apache Parquet C++.
%files -n parquet-libs-devel
%dir %{_includedir}/parquet
%{_includedir}/parquet/*
%{_libdir}/cmake/arrow/ParquetConfig*.cmake
%{_libdir}/cmake/arrow/ParquetTargets*.cmake
%{_libdir}/cmake/arrow/FindParquet.cmake
%{_libdir}/libparquet.so
%{_libdir}/pkgconfig/parquet*.pc
%exclude %{_libdir}/libparquet.a
#--------------------------------------------------------------------
%package glib-libs
Summary: Runtime libraries for Apache Arrow GLib
Requires: %{name} = %{version}-%{release}
Requires: %{name}-doc = %{version}-%{release}
%description glib-libs
This package contains the libraries for Apache Arrow GLib.
%files glib-libs
%{_libdir}/libarrow-glib.so.*
%{_libdir}/girepository-1.0/Arrow-1.0.typelib
%exclude %{_datadir}/doc/arrow-glib/*
#--------------------------------------------------------------------
%package glib-devel
Summary: Libraries and header files for Apache Arrow GLib
Requires: %{name}-devel = %{version}-%{release}
Requires: %{name}-glib-libs = %{version}-%{release}
Requires: glib2-devel
Requires: gobject-introspection-devel
%description glib-devel
Libraries and header files for Apache Arrow GLib.
%files glib-devel
%dir %{_includedir}/arrow-glib
%{_includedir}/arrow-glib/*
%{_libdir}/libarrow-glib.so
%{_libdir}/pkgconfig/arrow-glib.pc
%{_libdir}/pkgconfig/arrow-orc-glib.pc
%{_datadir}/arrow-glib/example/
%{_datadir}/gir-1.0/Arrow-1.0.gir
%{_datadir}/gir-1.0/ArrowFlight-1.0.gir
%exclude %{_libdir}/libarrow-glib.a
#--------------------------------------------------------------------
%package glib-doc
Summary: Documentation for Apache Arrow GLib
%description glib-doc
Documentation for Apache Arrow GLib.
%files glib-doc
%dir %{_datadir}/gtk-doc/html/arrow-glib
%{_datadir}/gtk-doc/html/arrow-glib/*
%dir %{_datadir}/gtk-doc/html/arrow-flight-glib
%{_datadir}/gtk-doc/html/arrow-flight-glib/*
#--------------------------------------------------------------------
%package dataset-glib-libs
Summary: Runtime libraries for Apache Arrow dataset GLib
Requires: %{name}-dataset-libs = %{version}-%{release}
Requires: %{name}-glib-libs = %{version}-%{release}
Requires: %{name}-doc = %{version}-%{release}
%description dataset-glib-libs
This package contains the libraries for Apache Arrow dataset GLib.
%files dataset-glib-libs
%{_libdir}/libarrow-dataset-glib.so.*
%{_libdir}/girepository-1.0/ArrowDataset-1.0.typelib
#--------------------------------------------------------------------
%package dataset-glib-devel
Summary: Libraries and header files for Apache Arrow dataset GLib
Requires: %{name}-dataset-devel = %{version}-%{release}
Requires: %{name}-glib-devel = %{version}-%{release}
Requires: %{name}-dataset-glib-libs = %{version}-%{release}
%description dataset-glib-devel
Libraries and header files for Apache Arrow dataset GLib.
%files dataset-glib-devel
%dir %{_includedir}/arrow-dataset-glib
%{_includedir}/arrow-dataset-glib/
%{_libdir}/libarrow-dataset-glib.so
%{_libdir}/pkgconfig/arrow-dataset-glib.pc
%{_datadir}/gir-1.0/ArrowDataset-1.0.gir
%exclude %{_libdir}/libarrow-dataset-glib.a
#--------------------------------------------------------------------
%package dataset-glib-doc
Summary: Documentation for Apache Arrow dataset GLib
%description dataset-glib-doc
Documentation for Apache Arrow dataset GLib.
%files dataset-glib-doc
%dir %{_datadir}/gtk-doc/html/arrow-dataset-glib
%{_datadir}/gtk-doc/html/arrow-dataset-glib/*
#--------------------------------------------------------------------
%if %{with use_gandiva}
%package -n gandiva-glib-libs
Summary: Runtime libraries for Gandiva GLib
Requires: gandiva-libs = %{version}-%{release}
Requires: %{name}-glib-libs = %{version}-%{release}
Requires: %{name}-doc = %{version}-%{release}
%description -n gandiva-glib-libs
This package contains the libraries for Gandiva GLib.
%files -n gandiva-glib-libs
%{_libdir}/libgandiva-glib.so.*
%{_libdir}/girepository-1.0/Gandiva-1.0.typelib
#--------------------------------------------------------------------
%package -n gandiva-glib-devel
Summary: Libraries and header files for Gandiva GLib
Requires: gandiva-devel = %{version}-%{release}
Requires: %{name}-glib-devel = %{version}-%{release}
%description -n gandiva-glib-devel
Libraries and header files for Gandiva GLib.
%files -n gandiva-glib-devel
%dir %{_includedir}/gandiva-glib
%{_includedir}/gandiva-glib/*
%{_libdir}/libgandiva-glib.so
%{_libdir}/pkgconfig/gandiva-glib.pc
%{_datadir}/gir-1.0/Gandiva-1.0.gir
%exclude %{_libdir}/libgandiva-glib.a
#--------------------------------------------------------------------
%package -n gandiva-glib-doc
Summary: Documentation for Gandiva GLib
%description -n gandiva-glib-doc
Documentation for Gandiva GLib.
%files -n gandiva-glib-doc
%dir %{_datadir}/gtk-doc/html/gandiva-glib
%{_datadir}/gtk-doc/html/gandiva-glib/*
%endif
#--------------------------------------------------------------------
%package -n plasma-glib-libs
Summary: Runtime libraries for Plasma GLib
Requires: plasma-libs = %{version}-%{release}
Requires: %{name}-glib-libs = %{version}-%{release}
Requires: %{name}-doc = %{version}-%{release}
%description -n plasma-glib-libs
This package contains the libraries for Plasma GLib.
%files -n plasma-glib-libs
%{_libdir}/libplasma-glib.so.*
%{_libdir}/girepository-1.0/Plasma-1.0.typelib
#--------------------------------------------------------------------
%package -n plasma-glib-devel
Summary: Libraries and header files for Plasma GLib
Requires: plasma-devel = %{version}-%{release}
Requires: plasma-glib-libs = %{version}-%{release}
Requires: %{name}-glib-devel = %{version}-%{release}
%description -n plasma-glib-devel
Libraries and header files for Plasma GLib.
%files -n plasma-glib-devel
%dir %{_includedir}/plasma-glib
%{_includedir}/plasma-glib/
%{_libdir}/libplasma-glib.so
%{_libdir}/pkgconfig/plasma-glib.pc
%{_datadir}/gir-1.0/Plasma-1.0.gir
%exclude %{_libdir}/libplasma-glib.a
#--------------------------------------------------------------------
%package -n plasma-glib-doc
Summary: Documentation for Plasma GLib
%description -n plasma-glib-doc
Documentation for Plasma GLib.
%files -n plasma-glib-doc
%dir %{_datadir}/gtk-doc/html/plasma-glib
%{_datadir}/gtk-doc/html/plasma-glib/*
#--------------------------------------------------------------------
%package -n parquet-glib-libs
Summary: Runtime libraries for Apache Parquet GLib
Requires: parquet-libs = %{version}-%{release}
Requires: %{name}-glib-libs = %{version}-%{release}
Requires: %{name}-doc = %{version}-%{release}
%description -n parquet-glib-libs
This package contains the libraries for Apache Parquet GLib.
%files -n parquet-glib-libs
%{_libdir}/libparquet-glib.so.*
%{_libdir}/girepository-1.0/Parquet-1.0.typelib
#--------------------------------------------------------------------
%package -n parquet-glib-devel
Summary: Libraries and header files for Apache Parquet GLib
Requires: parquet-devel = %{version}-%{release}
Requires: parquet-glib-libs = %{version}-%{release}
Requires: %{name}-glib-devel = %{version}-%{release}
%description -n parquet-glib-devel
Libraries and header files for Apache Parquet GLib.
%files -n parquet-glib-devel
%dir %{_includedir}/parquet-glib
%{_includedir}/parquet-glib/*
%{_libdir}/libparquet-glib.so
%{_libdir}/pkgconfig/parquet-glib.pc
%{_datadir}/gir-1.0/Parquet-1.0.gir
%exclude %{_libdir}/libparquet-glib.a
#--------------------------------------------------------------------
%package -n parquet-glib-doc
Summary: Documentation for Apache Parquet GLib
%description -n parquet-glib-doc
Documentation for Apache Parquet GLib.
%files -n parquet-glib-doc
%dir %{_datadir}/gtk-doc/html/parquet-glib
%{_datadir}/gtk-doc/html/parquet-glib/*
#--------------------------------------------------------------------
%prep
%autosetup -p1 -n apache-arrow-%{version}
%build
pushd cpp
%cmake . \
%if %{with use_flight}
-DARROW_FLIGHT=ON \
%endif
%if %{with use_gandiva}
-DARROW_GANDIVA=ON \
%endif
%if %{with use_mimalloc}
-DARROW_MIMALLOC=ON \
%endif
-DARROW_ORC=ON \
-DARROW_PARQUET=ON \
-DARROW_PLASMA=ON \
-DARROW_PYTHON=ON \
-DARROW_JEMALLOC=OFF \
-DGRPC_SOURCE="SYSTEM" \
-Dxsimd_SOURCE="SYSTEM" \
%if %{with use_s3}
-DARROW_S3=ON \
%endif
-DARROW_WITH_BROTLI=ON \
-DARROW_WITH_BZ2=ON \
-DARROW_WITH_LZ4=ON \
-DARROW_WITH_SNAPPY=ON \
-DARROW_WITH_ZLIB=ON \
-DARROW_WITH_ZSTD=ON \
-DARROW_WITH_XSIMD=ON \
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_COLOR_MAKEFILE:BOOL=OFF \
-DARROW_USE_CCACHE=OFF \
-DCMAKE_UNITY_BUILD=ON \
-DPARQUET_REQUIRE_ENCRYPTION=ON \
-DPythonInterp_FIND_VERSION=ON \
-DPythonInterp_FIND_VERSION_MAJOR=3 \
%if %{with use_ninja}
-GNinja
%endif
export VERBOSE=1
export GCC_COLORS=
%cmake_build
# put everything where meson can find it
mkdir -p %{_target_platform}/relwithdebinfo
ln -s ../src %{_target_platform}
cp -p build/relwithdebinfo/lib*.so* %{_target_platform}/relwithdebinfo/
popd
pushd c_glib
%meson \
-Darrow_cpp_build_dir=../cpp/%{_vpath_builddir} \
-Darrow_cpp_build_type=relwithdebinfo \
-Dgtk_doc=true
%meson_build
#--------------------------------------------------------------------
%install
pushd c_glib
%meson_install
popd
pushd cpp
%cmake_install
popd
#--------------------------------------------------------------------
%changelog
* Thu Jan 13 2022 Kaleb S. KEITHLEY <kkeithle [at] redhat.com> - 7.0.0-1
- latest upstream release.