e9e65f
import kernel-3.10.0-123.9.3.el7
@@ -1,6 +1,3 @@
|
|
1
|
-
SOURCES/linux-3.10.0-123.9.
|
1
|
+
SOURCES/linux-3.10.0-123.9.3.el7.tar.xz
|
2
2
|
SOURCES/rheldup3.x509
|
3
3
|
SOURCES/rhelkpatch1.x509
|
4
|
-
SOURCES/centos-kpatch.x509
|
5
|
-
SOURCES/centos-ldup.x509
|
6
|
-
SOURCES/centos.cer
|
@@ -1,6 +1,3 @@
|
|
1
|
-
|
1
|
+
3cdb9a383bd32546384654270aa7b263cd8e462c SOURCES/linux-3.10.0-123.9.3.el7.tar.xz
|
2
2
|
95b9b811c7b0a6c98b2eafc4e7d6d24f2cb63289 SOURCES/rheldup3.x509
|
3
3
|
d90885108d225a234a5a9d054fc80893a5bd54d0 SOURCES/rhelkpatch1.x509
|
4
|
-
5a7d05a8298cf38d43689470e8e43230d8add0f9 SOURCES/centos-kpatch.x509
|
5
|
-
c61172887746663d3bdd9acaa263cbfacf99e8b3 SOURCES/centos-ldup.x509
|
6
|
-
6e9105eb51e55a46761838f289a917611cad8091 SOURCES/centos.cer
|
@@ -9,7 +9,7 @@ RPMVERSION:=3.10.0
|
|
9
9
|
marker is git tag which we base off of for exporting patches
|
10
10
|
MARKER:=v3.10
|
11
11
|
PREBUILD:=
|
12
|
-
BUILD:=123.9.
|
12
|
+
BUILD:=123.9.3
|
13
13
|
DIST:=.el7
|
14
14
|
SPECFILE:=kernel.spec
|
15
15
|
RPM:=$(REDHAT)/rpm
|
@@ -1,11 +0,0 @@
|
|
1
|
-
--- a/arch/x86/boot/main.c 2014-06-04 10:05:04.000000000 -0700
|
2
|
-
+++ b/arch/x86/boot/main.c 2014-07-09 12:54:40.000000000 -0700
|
3
|
-
@@ -146,7 +146,7 @@ void main(void)
|
4
|
-
|
5
|
-
/* Make sure we have all the proper CPU support */
|
6
|
-
if (validate_cpu()) {
|
7
|
-
- puts("This processor is unsupported in RHEL7.\n");
|
8
|
-
+ puts("This processor is unsupported in CentOS 7.\n");
|
9
|
-
die();
|
10
|
-
}
|
11
|
-
|
@@ -1,25 +0,0 @@
|
|
1
|
-
From 69c0d42cfa26515196896dea086857c2caccb6eb Mon Sep 17 00:00:00 2001
|
2
|
-
From: Jim Perrin <jperrin@centos.org>
|
3
|
-
Date: Thu, 19 Jun 2014 10:05:12 -0500
|
4
|
-
Subject: [PATCH] branding patch for rh_taint
|
5
|
-
|
6
|
-
---
|
7
|
-
kernel/rh_taint.c | 2 +-
|
8
|
-
1 file changed, 1 insertion(+), 1 deletion(-)
|
9
|
-
|
10
|
-
diff --git a/kernel/rh_taint.c b/kernel/rh_taint.c
|
11
|
-
index 59a74b0..0708e15 100644
|
12
|
-
--- a/kernel/rh_taint.c
|
13
|
-
+++ b/kernel/rh_taint.c
|
14
|
-
|
15
|
-
void mark_hardware_unsupported(const char *msg)
|
16
|
-
{
|
17
|
-
/* Print one single message */
|
18
|
-
- pr_crit("Warning: %s - this hardware has not undergone testing by Red Hat and might not be certified. Please consult https://hardware.redhat.com for certified hardware.\n", msg);
|
19
|
-
+ pr_crit("Warning: %s - this hardware has not undergone upstream testing. Please consult http://wiki.centos.org/FAQ for more information\n", msg);
|
20
|
-
}
|
21
|
-
EXPORT_SYMBOL(mark_hardware_unsupported);
|
22
|
-
|
23
|
-
--
|
24
|
-
1.8.3.1
|
25
|
-
|
@@ -1,25 +0,0 @@
|
|
1
|
-
From 66185f5c6f881847776702e3a7956c504400f4f2 Mon Sep 17 00:00:00 2001
|
2
|
-
From: Jim Perrin <jperrin@centos.org>
|
3
|
-
Date: Thu, 19 Jun 2014 09:53:13 -0500
|
4
|
-
Subject: [PATCH] branding patch for single-cpu systems
|
5
|
-
|
6
|
-
---
|
7
|
-
arch/x86/kernel/setup.c | 2 +-
|
8
|
-
1 file changed, 1 insertion(+), 1 deletion(-)
|
9
|
-
|
10
|
-
diff --git a/arch/x86/kernel/setup.c b/arch/x86/kernel/setup.c
|
11
|
-
index b289118..9d25982 100644
|
12
|
-
--- a/arch/x86/kernel/setup.c
|
13
|
-
+++ b/arch/x86/kernel/setup.c
|
14
|
-
@@ -846,7 +846,7 @@ static void rh_check_supported(void)
|
15
|
-
if (((boot_cpu_data.x86_max_cores * smp_num_siblings) == 1) &&
|
16
|
-
!x86_hyper && !cpu_has_hypervisor && !is_kdump_kernel()) {
|
17
|
-
pr_crit("Detected single cpu native boot.\n");
|
18
|
-
- pr_crit("Important: In Red Hat Enterprise Linux 7, single threaded, single CPU 64-bit physical systems are unsupported by Red Hat. Please contact your Red Hat support representative for a list of certified and supported systems.");
|
19
|
-
+ pr_crit("Important: In CentOS 7, single threaded, single CPU 64-bit physical systems are unsupported. Please see http://wiki.centos.org/FAQ for more information");
|
20
|
-
}
|
21
|
-
|
22
|
-
/* The RHEL7 kernel does not support this hardware. The kernel will
|
23
|
-
--
|
24
|
-
1.8.3.1
|
25
|
-
|
@@ -5,9 +5,9 @@ prompt = no
|
|
5
5
|
x509_extensions = myexts
|
6
6
|
|
7
7
|
[ req_distinguished_name ]
|
8
|
-
O =
|
9
|
-
CN =
|
10
|
-
emailAddress =
|
8
|
+
O = Red Hat
|
9
|
+
CN = Red Hat Enterprise Linux kernel signing key
|
10
|
+
emailAddress = secalert@redhat.com
|
11
11
|
|
12
12
|
[ myexts ]
|
13
13
|
basicConstraints=critical,CA:FALSE
|
@@ -11,7 +11,7 @@ Summary: The Linux kernel
|
|
11
11
|
%global released_kernel 1
|
12
12
|
|
13
13
|
%define rpmversion 3.10.0
|
14
|
-
%define pkgrelease 123.9.
|
14
|
+
%define pkgrelease 123.9.3.el7
|
15
15
|
|
16
16
|
%define pkg_release %{pkgrelease}%{?buildid}
|
17
17
|
|
@@ -338,10 +338,10 @@ Source10: sign-modules
|
|
338
338
|
%define modsign_cmd %{SOURCE10}
|
339
339
|
Source11: x509.genkey
|
340
340
|
Source12: extra_certificates
|
341
|
-
Source13:
|
341
|
+
Source13: securebootca.cer
|
342
342
|
Source14: secureboot.cer
|
343
|
-
Source15:
|
344
|
-
Source16:
|
343
|
+
Source15: rheldup3.x509
|
344
|
+
Source16: rhelkpatch1.x509
|
345
345
|
|
346
346
|
Source18: check-kabi
|
347
347
|
|
@@ -369,9 +369,6 @@ Source2001: cpupower.config
|
|
369
369
|
|
370
370
|
# empty final patch to facilitate testing of kernel patches
|
371
371
|
Patch999999: linux-kernel-test.patch
|
372
|
-
Patch1000: debrand-single-cpu.patch
|
373
|
-
Patch1001: debrand-rh_taint.patch
|
374
|
-
Patch1002: debrand-rh-i686-cpu.patch
|
375
372
|
|
376
373
|
BuildRoot: %{_tmppath}/kernel-%{KVRA}-root
|
377
374
|
|
@@ -524,11 +521,11 @@ This package provides debug information for package kernel-tools.
|
|
524
521
|
%endif # with_tools
|
525
522
|
|
526
523
|
%package -n kernel-abi-whitelists
|
527
|
-
Summary: The
|
524
|
+
Summary: The Red Hat Enterprise Linux kernel ABI symbol whitelists
|
528
525
|
Group: System Environment/Kernel
|
529
526
|
AutoReqProv: no
|
530
527
|
%description -n kernel-abi-whitelists
|
531
|
-
The kABI package contains information pertaining to the
|
528
|
+
The kABI package contains information pertaining to the Red Hat Enterprise
|
532
529
|
Linux kernel ABI, including lists of kernel symbols that are needed by
|
533
530
|
external Linux kernel modules, and a yum plugin to aid enforcement.
|
534
531
|
|
@@ -671,12 +668,6 @@ cd linux-%{KVRA}
|
|
671
668
|
# Drop some necessary files from the source dir into the buildroot
|
672
669
|
cp $RPM_SOURCE_DIR/kernel-%{version}-*.config .
|
673
670
|
|
674
|
-
# CentOS Branding Modification
|
675
|
-
ApplyOptionalPatch debrand-rh_taint.patch
|
676
|
-
ApplyOptionalPatch debrand-single-cpu.patch
|
677
|
-
ApplyOptionalPatch debrand-rh-i686-cpu.patch
|
678
|
-
# End of CentOS Modification
|
679
|
-
|
680
671
|
ApplyOptionalPatch linux-kernel-test.patch
|
681
672
|
|
682
673
|
# Any further pre-build tree manipulations happen here.
|
@@ -828,7 +819,7 @@ BuildKernel() {
|
|
828
819
|
fi
|
829
820
|
# EFI SecureBoot signing, x86_64-only
|
830
821
|
%ifarch x86_64
|
831
|
-
%pesign -s -i $KernelImage -o $KernelImage.signed -a %{SOURCE13} -c %{
|
822
|
+
%pesign -s -i $KernelImage -o $KernelImage.signed -a %{SOURCE13} -c %{SOURCE14} -n redhatsecureboot301
|
832
823
|
mv $KernelImage.signed $KernelImage
|
833
824
|
%endif
|
834
825
|
$CopyKernel $KernelImage $RPM_BUILD_ROOT/%{image_install_path}/$InstallName-$KernelVer
|
@@ -1483,8 +1474,8 @@ fi
|
|
1483
1474
|
%kernel_variant_files %{with_kdump} kdump
|
1484
1475
|
|
1485
1476
|
%changelog
|
1486
|
-
*
|
1487
|
-
-
|
1477
|
+
* Wed Oct 29 2014 Phillip Lougher <plougher@redhat.com> [3.10.0-123.9.3.el7]
|
1478
|
+
- [block] blkcg: fix use-after-free in __blkg_release_rcu() by making blkcg_gq refcnt an atomic_t (Vivek Goyal) [1158313 1118436]
|
1488
1479
|
|
1489
1480
|
* Wed Sep 24 2014 Phillip Lougher <plougher@redhat.com> [3.10.0-123.9.2.el7]
|
1490
1481
|
- [virt] kvm: fix PIT timer race condition (Petr Matousek) [1144879 1144880] {CVE-2014-3611}
|