785440 import jakarta-activation2-2.1.1-2.module+el8.8.0+18042+89a504d5

Merged and Committed by centosrcm 2 years ago
    import jakarta-activation2-2.1.1-2.module+el8.8.0+18042+89a504d5
    
        
file added
+1
.gitignore ADDED
@@ -0,0 +1 @@
1
+ SOURCES/jaf-2.1.1.tar.gz
.jakarta-activation2.metadata ADDED
@@ -0,0 +1 @@
1
+ b41d525d1476addca256d81c228977c8b475bf59 SOURCES/jaf-2.1.1.tar.gz
SPECS/jakarta-activation2.spec ADDED
@@ -0,0 +1,67 @@
1
+ Name: jakarta-activation2
2
+ Version: 2.1.1
3
+ Release: 2%{?dist}
4
+ Summary: Jakarta Activation API
5
+ # the whole project is licensed under (EPL-2.0 or BSD)
6
+ # the source code additionally can be licensed under GPLv2 with exceptions
7
+ # we only ship built source code
8
+ License: EPL-2.0 or BSD or GPLv2 with exceptions
9
+ URL: https://jakartaee.github.io/jaf-api/
10
+ BuildArch: noarch
11
+
12
+ Source0: https://github.com/eclipse-ee4j/jaf/archive/%{version}/jaf-%{version}.tar.gz
13
+
14
+ BuildRequires: maven-local
15
+ BuildRequires: mvn(org.apache.felix:maven-bundle-plugin)
16
+ BuildRequires: mvn(org.codehaus.mojo:build-helper-maven-plugin)
17
+
18
+ %description
19
+ Jakarta Activation lets you take advantage of standard services to:
20
+ determine the type of an arbitrary piece of data; encapsulate access to
21
+ it; discover the operations available on it; and instantiate the
22
+ appropriate bean to perform the operation(s).
23
+
24
+ %package javadoc
25
+ Summary: Javadoc for %{name}
26
+
27
+ %description javadoc
28
+ This package contains javadoc for %{name}.
29
+
30
+ %prep
31
+ %setup -q -n jaf-api-%{version}
32
+
33
+ pushd api
34
+ %pom_remove_parent
35
+
36
+ # remove custom doclet configuration
37
+ %pom_remove_plugin :maven-javadoc-plugin
38
+
39
+ %pom_remove_plugin -r :buildnumber-maven-plugin
40
+ %pom_remove_plugin -r :maven-enforcer-plugin
41
+
42
+ %mvn_compat_version jakarta*: 2 %{version} 2.1.0 2.0.1 2.0.0
43
+ popd
44
+
45
+ %build
46
+ pushd api
47
+ %mvn_build
48
+ popd
49
+
50
+ %install
51
+ pushd api
52
+ %mvn_install
53
+ popd
54
+
55
+ %files -f api/.mfiles
56
+ %doc README.md
57
+ %license LICENSE.md NOTICE.md
58
+
59
+ %files javadoc -f api/.mfiles-javadoc
60
+ %license LICENSE.md NOTICE.md
61
+
62
+ %changelog
63
+ * Tue Jan 31 2023 Marian Koncek <mkoncek@redhat.com> - 2.1.1-2
64
+ - Add major compat version
65
+
66
+ * Tue Jan 17 2023 Marian Koncek <mkoncek@redhat.com> - 2.1.1-1
67
+ - Initial build