275c1a import inkscape-0.92.2-2.el7

Merged and Committed by centosrcm 5 years ago
    import inkscape-0.92.2-2.el7
    
        
file added
+1
.gitignore ADDED
@@ -0,0 +1 @@
1
+ SOURCES/inkscape-0.92.2.tar.bz2
file added
+1
.inkscape.metadata ADDED
@@ -0,0 +1 @@
1
+ c620d7aac594a0f839f2f7840d57e26f00991d16 SOURCES/inkscape-0.92.2.tar.bz2
file added
+753
SPECS/inkscape.spec ADDED
@@ -0,0 +1,753 @@
1
+ Name: inkscape
2
+ Version: 0.92.2
3
+ Release: 2%{?dist}
4
+ Summary: Vector-based drawing program using SVG
5
+
6
+ Group: Applications/Productivity
7
+ License: GPLv2+
8
+ URL: http://inkscape.sourceforge.net/
9
+ Source0: http://downloads.sourceforge.net/inkscape/%{name}-%{version}.tar.bz2
10
+
11
+ BuildRequires: atk-devel
12
+ BuildRequires: desktop-file-utils
13
+ BuildRequires: freetype-devel
14
+ BuildRequires: gc-devel >= 6.4
15
+ BuildRequires: gettext
16
+ BuildRequires: gtkmm24-devel >= 2.8.0
17
+ BuildRequires: gtkspell-devel
18
+ BuildRequires: libpng-devel >= 1.2
19
+ BuildRequires: libxml2-devel >= 2.6.11
20
+ BuildRequires: libxslt-devel >= 1.0.15
21
+ BuildRequires: pango-devel
22
+ BuildRequires: pkgconfig
23
+ BuildRequires: lcms2-devel
24
+ BuildRequires: cairo-devel
25
+ BuildRequires: dos2unix
26
+ BuildRequires: python-devel
27
+ BuildRequires: poppler-glib-devel
28
+ BuildRequires: boost-devel
29
+ BuildRequires: gsl-devel
30
+ BuildRequires: libwpg-devel >= 0.3.0
31
+ BuildRequires: ImageMagick-c++-devel
32
+ BuildRequires: perl(XML::Parser)
33
+ BuildRequires: perl(ExtUtils::Embed)
34
+ BuildRequires: intltool
35
+ BuildRequires: popt-devel
36
+ # We detect new poppler in inkscape-0.48.2-poppler_020.patch
37
+ BuildRequires: automake
38
+ BuildRequires: cmake
39
+
40
+ # Disable all for now. TODO: Be smarter
41
+ %if 0
42
+ Requires: dia
43
+ Requires: pstoedit
44
+ Requires: ghostscript
45
+ Requires: perl(Image::Magick)
46
+ Requires: tex(latex)
47
+ Requires: tex(dvips)
48
+ Requires: transfig
49
+ Requires: gimp
50
+ Requires: numpy
51
+ Requires: python-lxml
52
+ # TODO: Deal with these (autoreqs, disabled now):
53
+ # perl(Cwd)
54
+ # perl(Exporter)
55
+ # perl(File::Basename)
56
+ # perl(Getopt::Long)
57
+ # perl(Getopt::Std)
58
+ # perl(MIME::Base64)
59
+ # perl(Pod::Usage)
60
+ # perl(SVG)
61
+ # perl(SVG::Parser)
62
+ # perl(XML::XQL)
63
+ # perl(XML::XQL::DOM)
64
+ # perl(strict)
65
+ # perl(vars)
66
+ # perl(warnings)
67
+ %endif
68
+ Requires: python-lxml
69
+ Requires: numpy
70
+ %if ! 0%{?rhel}
71
+ Requires: uniconvertor
72
+ %endif
73
+
74
+ # the package requires libperl.so, so it also has to require this:
75
+ Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
76
+
77
+ # Filter out perl requires and provides
78
+ # XXX: For now _all_
79
+ %global __perl_provides %{nil}
80
+ %global __perl_requires %{nil}
81
+
82
+ %description
83
+ Inkscape is a vector graphics editor, with capabilities similar to
84
+ Illustrator, CorelDraw, or Xara X, using the W3C standard Scalable Vector
85
+ Graphics (SVG) file format. It is therefore a very useful tool for web
86
+ designers and as an interchange format for desktop publishing.
87
+
88
+ Inkscape supports many advanced SVG features (markers, clones, alpha
89
+ blending, etc.) and great care is taken in designing a streamlined
90
+ interface. It is very easy to edit nodes, perform complex path operations,
91
+ trace bitmaps and much more.
92
+
93
+
94
+ %package view
95
+ Summary: Viewing program for SVG files
96
+ Group: Applications/Productivity
97
+ # the package requires libperl.so, so it also has to require this:
98
+ Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
99
+ Requires: inkscape = %{version}-%{release}
100
+
101
+ %description view
102
+ Viewer for files in W3C standard Scalable Vector Graphics (SVG) file
103
+ format.
104
+
105
+
106
+ %package docs
107
+ Summary: Documentation for Inkscape
108
+ Group: Documentation
109
+ Requires: inkscape
110
+
111
+ %description docs
112
+ Tutorial and examples for Inkscape, a graphics editor for vector
113
+ graphics in W3C standard Scalable Vector Graphics (SVG) file format.
114
+
115
+
116
+ %prep
117
+ %setup -q
118
+
119
+ # https://bugs.launchpad.net/inkscape/+bug/314381
120
+ # A couple of files have executable bits set,
121
+ # despite not being executable
122
+ find . -name '*.cpp' | xargs chmod -x
123
+ find . -name '*.h' | xargs chmod -x
124
+ find share/extensions -name '*.py' | xargs chmod -x
125
+
126
+ # Fix end of line encodings
127
+ dos2unix -k -q share/extensions/*.py
128
+
129
+
130
+ %build
131
+ # --disable-strict-build is needed due to gtkmm using a deprecated glibmm
132
+ # method: https://lists.fedoraproject.org/pipermail/devel/2015-July/212652.html
133
+ # If upstream gtkmm fixes https://bugzilla.gnome.org/show_bug.cgi?id=752797
134
+ # this can be removed.
135
+ export RPM_OPT_FLAGS="$RPM_OPT_FLAGS -std=c++11 -fno-strict-overflow"
136
+ export CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"
137
+ export CXXFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"
138
+
139
+ cmake -DCMAKE_INSTALL_PREFIX:PATH=/usr -DWITH_GNOME_VFS:BOOL=OFF .
140
+
141
+ make %{?_smp_mflags}
142
+
143
+
144
+ %install
145
+ rm -rf $RPM_BUILD_ROOT
146
+ make install VERBOSE=1 DESTDIR=$RPM_BUILD_ROOT
147
+ sed -i 's/Drawing Shortcut Group/X-Drawing Shortcut Group/g' $RPM_BUILD_ROOT%{_datadir}/applications/%{name}.desktop
148
+ find $RPM_BUILD_ROOT -type f -name 'lib*.a' | xargs rm -f
149
+
150
+ desktop-file-install --vendor="%{?desktop_vendor}" --delete-original \
151
+ --dir $RPM_BUILD_ROOT%{_datadir}/applications \
152
+ $RPM_BUILD_ROOT%{_datadir}/applications/%{name}.desktop
153
+
154
+ # No skencil anymore
155
+ rm -f $RPM_BUILD_ROOT%{_datadir}/%{name}/extensions/sk2svg.sh
156
+
157
+ %find_lang %{name}
158
+
159
+
160
+ %check
161
+ # XXX: Tests fail, ignore it for now
162
+ make -k check || :
163
+
164
+
165
+ %clean
166
+ rm -rf $RPM_BUILD_ROOT
167
+
168
+ %post
169
+ /bin/touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
170
+
171
+ %posttrans
172
+ /usr/bin/gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
173
+ /usr/bin/update-desktop-database -q &> /dev/null ||:
174
+
175
+ %postun
176
+ if [ $1 -eq 0 ] ; then
177
+ /bin/touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
178
+ /usr/bin/gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
179
+ /usr/bin/update-desktop-database -q &> /dev/null ||:
180
+ fi
181
+
182
+
183
+ %files -f %{name}.lang
184
+ %defattr(-,root,root,-)
185
+ %{_bindir}/inkscape
186
+ %dir %{_datadir}/inkscape
187
+ %{_datadir}/inkscape/attributes
188
+ %{_datadir}/inkscape/branding
189
+ %{_datadir}/inkscape/symbols
190
+ %{_datadir}/inkscape/extensions
191
+ %{_datadir}/inkscape/filters
192
+ %{_datadir}/inkscape/fonts
193
+ %{_datadir}/inkscape/gradients
194
+ %{_datadir}/inkscape/icons
195
+ %{_datadir}/inkscape/keys
196
+ %{_datadir}/inkscape/markers
197
+ %{_datadir}/inkscape/palettes
198
+ %{_datadir}/inkscape/patterns
199
+ %{_datadir}/inkscape/screens
200
+ %{_datadir}/inkscape/templates
201
+ %{_datadir}/inkscape/ui
202
+ %{_datadir}/applications/*inkscape.desktop
203
+ %{_datadir}/icons/hicolor/*/*/inkscape*
204
+ %dir %{_prefix}/lib/inkscape
205
+ %{_prefix}/lib/inkscape/lib*.so
206
+ %{_mandir}/*/*gz
207
+ %exclude %{_mandir}/man1/inkview.1*
208
+ %doc AUTHORS COPYING ChangeLog NEWS README
209
+
210
+
211
+ %files view
212
+ %defattr(-,root,root,-)
213
+ %{_bindir}/inkview
214
+ %{_mandir}/man1/inkview.1*
215
+ %doc AUTHORS COPYING ChangeLog NEWS README
216
+
217
+
218
+ %files docs
219
+ %defattr(-,root,root,-)
220
+ %dir %{_datadir}/inkscape
221
+ %{_datadir}/inkscape/tutorials
222
+ %{_datadir}/inkscape/examples
223
+
224
+
225
+ %changelog
226
+ * Thu Aug 24 2017 Jan Horak <jhorak@redhat.com> - 0.92.2-2
227
+ - Rebase to version 0.92.2
228
+
229
+ * Fri Apr 1 2016 Jan Horak <jhorak@redhat.com> - 0.91-2
230
+ - Rebase to version 0.91
231
+
232
+ * Tue Jul 21 2015 Jan Horak <jhorak@redhat.com> - 0.48.4-15
233
+ - Building without gnome-vfs
234
+
235
+ * Thu May 7 2015 Jan Horak <jhorak@redhat.com> - 0.48.4-13
236
+ - Added patch to support newer poppler
237
+
238
+ * Thu Apr 30 2015 Jan Horak <jhorak@redhat.com> - 0.48.4-11
239
+ - Fix for libwpg rebase
240
+
241
+ * Fri Feb 28 2014 Jan Horak <jhorak@redhat.com> - 0.48.4-10
242
+ - Get rid of SpSVG extension - rhbz#1023508
243
+
244
+ * Fri Jan 24 2014 Daniel Mach <dmach@redhat.com> - 0.48.4-9
245
+ - Mass rebuild 2014-01-24
246
+
247
+ * Fri Dec 27 2013 Daniel Mach <dmach@redhat.com> - 0.48.4-8
248
+ - Mass rebuild 2013-12-27
249
+
250
+ * Tue Sep 24 2013 Jan Horak <jhorak@redhat.com> - 0.48.4-7
251
+ - Added -fno-strict-aliasing to build flags
252
+
253
+ * Thu Sep 12 2013 Jan Horak <jhorak@redhat.com> - 0.48.4-6
254
+ - Rebuild with lcms2
255
+
256
+ * Tue Jun 25 2013 Marek Kasik <mkasik@redhat.com> - 0.48.4-5.1
257
+ - Rebuild (poppler-0.22.5)
258
+
259
+ * Wed May 08 2013 Colin Walters <walters@verbum.org> - 0.48.4-5
260
+ - Drop uniconverter dep; we are not supporting wmf export in RHEL
261
+ apparently.
262
+
263
+ * Fri Feb 15 2013 Jon Ciesla <limburgher@gmail.com> - 0.48.4-4
264
+ - Fix FTBFS.
265
+
266
+ * Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.48.4-3
267
+ - Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
268
+
269
+ * Fri Jan 18 2013 Marek Kasik <mkasik@redhat.com> - 0.48.4-2
270
+ - Rebuild (poppler-0.22.0)
271
+
272
+ * Thu Dec 06 2012 Jon Ciesla <limburgher@gmail.com> - 0.48.3.1-4
273
+ - 0.48.4, fix XXE security flaw.
274
+ - Correct man page ownership.
275
+
276
+ * Thu Dec 06 2012 Jon Ciesla <limburgher@gmail.com> - 0.48.3.1-4
277
+ - Fix directory ownership, BZ 873817.
278
+ - Fix previous changelog version.
279
+
280
+ * Mon Nov 19 2012 Nils Philippsen <nils@redhat.com> - 0.48.3.1-3
281
+ - update sourceforge download URL
282
+
283
+ * Thu Nov 01 2012 Jon Ciesla <limburgher@gmail.com> - 0.48.3.1-2
284
+ - Allow loading large XML, BZ 871012.
285
+
286
+ * Fri Oct 05 2012 Jon Ciesla <limburgher@gmail.com> - 0.48.3.1-1
287
+ - Lastest upstream.
288
+
289
+ * Thu Oct 04 2012 Jon Ciesla <limburgher@gmail.com> - 0.48.2-13
290
+ - Added dep on uniconvertor, BZ 796424.
291
+
292
+ * Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.48.2-12
293
+ - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
294
+
295
+ * Mon Jul 09 2012 Petr Pisar <ppisar@redhat.com> - 0.48.2-11
296
+ - Perl 5.16 rebuild
297
+
298
+ * Mon Jul 2 2012 Marek Kasik <mkasik@redhat.com> - 0.48.2-10
299
+ - Rebuild (poppler-0.20.1)
300
+
301
+ * Wed Jun 27 2012 Petr Pisar <ppisar@redhat.com> - 0.48.2-9
302
+ - Perl 5.16 rebuild
303
+
304
+ * Sat Jun 23 2012 Rex Dieter <rdieter@fedoraproject.org>
305
+ - 0.48.2-8
306
+ - fix icon/desktop-file scriptlets (#739375)
307
+ - drop .desktop vendor (f18+)
308
+ - inkscape doesn't build with poppler-0.20.0 (#822413)
309
+
310
+ * Fri Jun 15 2012 Petr Pisar <ppisar@redhat.com> - 0.48.2-7
311
+ - Perl 5.16 rebuild
312
+
313
+ * Mon Jun 11 2012 Adel Gadllah <adel.gadllah@gmail.com> - 0.48.2-6
314
+ - Rebuild for new poppler
315
+
316
+ * Wed Apr 11 2012 Peter Robinson <pbrobinson@fedoraproject.org> - 0.48.2-5
317
+ - Rebuild for ImageMagik
318
+
319
+ * Thu Mar 8 2012 Daniel Drake <dsd@laptop.org> - 0.48.2-4
320
+ - Fix build with GCC 4.7
321
+
322
+ * Tue Feb 28 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.48.2-3
323
+ - Rebuilt for c++ ABI breakage
324
+
325
+ * Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.48.2-2
326
+ - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
327
+
328
+ * Tue Nov 15 2011 German Ruiz <germanrs@fedoraproject.org> - 0.48.2-1
329
+ - New upstream version
330
+ - Fix glib include compile problem
331
+ - Fix compilation against libpng-1.5
332
+
333
+ * Fri Oct 28 2011 Rex Dieter <rdieter@fedoraproject.org> - 0.48.1-10
334
+ - rebuild(poppler)
335
+
336
+ * Fri Sep 30 2011 Marek Kasik <mkasik@redhat.com> - 0.48.1-9
337
+ - Rebuild (poppler-0.18.0)
338
+
339
+ * Mon Sep 19 2011 Marek Kasik <mkasik@redhat.com> - 0.48.1-8
340
+ - Rebuild (poppler-0.17.3)
341
+
342
+ * Thu Jul 21 2011 Petr Sabata <contyk@redhat.com> - 0.48.1-7
343
+ - Perl mass rebuild
344
+
345
+ * Tue Jul 19 2011 Petr Sabata <contyk@redhat.com> - 0.48.1-6
346
+ - Perl mass rebuild
347
+
348
+ * Fri Jul 15 2011 Marek Kasik <mkasik@redhat.com> - 0.48.1-5
349
+ - Rebuild (poppler-0.17.0)
350
+
351
+ * Sun Mar 13 2011 Marek Kasik <mkasik@redhat.com> - 0.48.1-4
352
+ - Rebuild (poppler-0.16.3)
353
+
354
+ * Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.48.1-3
355
+ - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
356
+
357
+ * Wed Feb 09 2011 Lubomir Rintel <lkundrak@v3.sk> - 0.48.1-2
358
+ - Re-enable GVFS for OCAL
359
+
360
+ * Mon Feb 07 2011 Lubomir Rintel <lkundrak@v3.sk> - 0.48.1-1
361
+ - Bump release
362
+
363
+ * Fri Feb 04 2011 Lubomir Rintel <lkundrak@v3.sk> - 0.48.0-10
364
+ - Drop gnome-vfs requirement
365
+ - Fix Rawhide build
366
+
367
+ * Sat Jan 01 2011 Rex Dieter <rdieter@fedoraproject.org> - 0.48.0-9
368
+ - rebuild (poppler)
369
+
370
+ * Wed Dec 15 2010 Rex Dieter <rdieter@fedoraproject.org> - 0.48.0-8
371
+ - rebuild (poppler)
372
+
373
+ * Wed Dec 08 2010 Caolán McNamara <caolanm@redhat.com> - 0.48.0-7
374
+ - rebuilt (libwpd)
375
+
376
+ * Sun Nov 14 2010 Lubomir Rintel <lkundrak@v3.sk> - 0.48.0-6
377
+ - rebuilt (poppler)
378
+
379
+ * Tue Oct 05 2010 Nils Philippsen <nils@redhat.com> - 0.48.0-5
380
+ - Rebuild for poppler update
381
+
382
+ * Wed Sep 29 2010 jkeating - 0.48.0-4
383
+ - Rebuilt for gcc bug 634757
384
+
385
+ * Wed Sep 29 2010 Dan Horák <dan[at]danny.cz> - 0.48.0-3
386
+ - drop the s390(x) ExcludeArch
387
+
388
+ * Mon Sep 20 2010 Tom "spot" Callaway <tcallawa@redhat.com> - 0.48.0-2
389
+ - rebuild for new ImageMagick
390
+
391
+ * Wed Aug 25 2010 Lubomir Rintel <lkundrak@v3.sk> - 0.48.0-1
392
+ - New upstream release
393
+ - Drop el5 support
394
+
395
+ * Thu Aug 19 2010 Rex Dieter <rdieter@fedoraproject.org> - 0.48-0.5.20100505bzr
396
+ - rebuild (poppler)
397
+
398
+ * Tue Jul 27 2010 David Malcolm <dmalcolm@redhat.com> - 0.48-0.4.20100505bzr
399
+ - Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
400
+
401
+ * Tue Jun 01 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.48-0.3.20100505bzr
402
+ - Mass rebuild with perl-5.12.0
403
+
404
+ * Wed May 05 2010 Lubomir Rintel <lkundrak@v3.sk> - 0.48-0.2.20100505bzr
405
+ - Move to later snapshot
406
+ - Drop uniconvertor patch
407
+
408
+ * Tue Apr 06 2010 Caolán McNamara <caolanm@redhat.com> - 0.48-0.2.20100318bzr
409
+ - Resolves: rhbz#565106 fix inkscape-0.47-x11.patch to not clobber INKSCAPE_LIBS
410
+
411
+ * Thu Mar 18 2010 Lubomir Rintel <lkundrak@v3.sk> - 0.48-0.1.20100318bzr
412
+ - Update to latest bazaar snapshot
413
+
414
+ * Thu Feb 18 2010 Lubomir Rintel <lkundrak@v3.sk> - 0.47-7
415
+ - Fix build
416
+
417
+ * Wed Jan 20 2010 Stepan Kasal <skasal@redhat.com> - 0.47-6
418
+ - ExcludeArch: s390 s390x
419
+
420
+ * Fri Jan 15 2010 Stepan Kasal <skasal@redhat.com> - 0.47-5
421
+ - require perl(:MODULE_COMPAT_5.10.x) because the package requires libperl.so
422
+ - the same for inkscape-view
423
+
424
+ * Fri Jan 8 2010 Owen Taylor <otaylor@redhat.com> - 0.47-4
425
+ - Remove loudmouth BuildRequires; there is no current usage of loudmouth in the code
426
+
427
+ * Sun Dec 06 2009 Lubomir Rintel <lkundrak@v3.sk> - 0.47-2
428
+ - Fix Rawhide build.
429
+
430
+ * Wed Nov 25 2009 Lubomir Rintel <lkundrak@v3.sk> - 0.47-1
431
+ - Stable release
432
+
433
+ * Mon Nov 23 2009 Adam Jackson <ajax@redhat.com> 0.47-0.18.pre4.20091101svn
434
+ - Fix RHEL6 build.
435
+
436
+ * Mon Sep 07 2009 Lubomir Rintel <lkundrak@v3.sk> - 0.47-0.17.pre4.20091101svn
437
+ - Icon for main window (#532325)
438
+
439
+ * Mon Sep 07 2009 Lubomir Rintel <lkundrak@v3.sk> - 0.47-0.16.pre4.20091101svn
440
+ - Move to a later snapshot
441
+ - python-lxml and numpy seem to be rather popular, add them as hard deps
442
+
443
+ * Mon Sep 07 2009 Lubomir Rintel <lkundrak@v3.sk> - 0.47-0.16.pre3.20091017svn
444
+ - Move to a later snapshot
445
+
446
+ * Mon Sep 07 2009 Lubomir Rintel <lkundrak@v3.sk> - 0.47-0.16.pre3.20090925svn
447
+ - Move to a later snapshot
448
+ - Drop debugging compiler flags, enable optimizations again
449
+ - Make it build on everything since EL5 again
450
+
451
+ * Mon Sep 07 2009 Lubomir Rintel <lkundrak@v3.sk> - 0.47-0.16.pre2.20090907svn
452
+ - Move inkview man page to -view subpackage (#515358)
453
+ - Add license, etc. to main package
454
+
455
+ * Mon Sep 07 2009 Lubomir Rintel <lkundrak@v3.sk> - 0.47-0.15.pre2.20090907svn
456
+ - Update to a post-pre2 snapshot
457
+
458
+ * Mon Aug 10 2009 Lubomir Rintel <lkundrak@v3.sk> - 0.47-0.15.pre1.20090629svn
459
+ - Update to a post-pre1 snapshot
460
+ - Drop upstreamed CRC32 fix
461
+
462
+ * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.47-0.14.pre0.20090629svn
463
+ - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
464
+
465
+ * Mon Jun 29 2009 Lubomir Rintel <lkundrak@v3.sk> - 0.47-0.13.pre0.20090629svn
466
+ - Update to a newer snapshot
467
+
468
+ * Tue Jun 16 2009 Lubomir Rintel <lkundrak@v3.sk> - 0.47-0.12.pre0.20090616svn
469
+ - Update to post-pre0 snapshot
470
+
471
+ * Tue Jun 02 2009 Lubomir Rintel <lkundrak@v3.sk> - 0.47-0.11.20090602svn
472
+ - More recent snapshot
473
+ - Upstream removed rasterized icons again
474
+
475
+ * Sat May 23 2009 Lubomir Rintel <lkundrak@v3.sk> - 0.47-0.10.20090518svn
476
+ - Rebuild for new poppler
477
+
478
+ * Mon May 18 2009 Lubomir Rintel <lkundrak@v3.sk> - 0.47-0.9.20090518svn
479
+ - Update past upstream Beta release
480
+
481
+ * Mon May 18 2009 Lubomir Rintel <lkundrak@v3.sk> - 0.47-0.8.20090508svn
482
+ - Fix ODG export
483
+
484
+ * Fri May 08 2009 Lubomir Rintel <lkundrak@v3.sk> - 0.47-0.7.20090508svn
485
+ - Update to a post-alpha snapshot
486
+ - Upstream applied our GCC 4.4 patch
487
+
488
+ * Fri Apr 10 2009 Lubomir Rintel <lkundrak@v3.sk> - 0.47-0.6.20090410svn
489
+ - Update to newer snapshot
490
+ - Fix doc/incview reversed subpackage content
491
+
492
+ * Wed Mar 04 2009 Lubomir Rintel <lkundrak@v3.sk> - 0.47-0.6.20090301svn
493
+ - Rebuild for new ImageMagick
494
+
495
+ * Wed Mar 04 2009 Lubomir Rintel <lkundrak@v3.sk> - 0.47-0.5.20090301svn
496
+ - Split documentation and inkview into subpackages
497
+
498
+ * Mon Mar 02 2009 Lubomir Rintel <lkundrak@v3.sk> - 0.47-0.4.20090301svn
499
+ - Bump to later SVN snapshot to fix inkscape/+bug/331864
500
+ - Fix a startup crash when compiled with GCC 4.4
501
+ - It even runs now! :)
502
+
503
+ * Fri Feb 27 2009 Lubomir Rintel <lkundrak@v3.sk> - 0.47-0.4.20090227svn
504
+ - Enable the test suite
505
+
506
+ * Fri Feb 27 2009 Lubomir Rintel <lkundrak@v3.sk> - 0.47-0.3.20090227svn
507
+ - Past midnight! :)
508
+ - More recent snapshot, our gcc44 fixes now upstream
509
+ - One more gcc44 fix, it even compiles now
510
+ - We install icons now, update icon cache
511
+ - Disable inkboard, for it won't currently compile
512
+
513
+ * Thu Feb 26 2009 Lubomir Rintel <lkundrak@v3.sk> - 0.47-0.3.20090226svn
514
+ - Later snapshot
515
+ - Compile with GCC 4.4
516
+
517
+ * Tue Jan 06 2009 Lubomir Rintel <lkundrak@v3.sk> - 0.47-0.3.20090105svn
518
+ - Update to newer SVN
519
+ - Drop upstreamed patches
520
+ - Enable WordPerfect Graphics support
521
+ - Enable embedded Perl scripting
522
+ - Enable Imagemagick support
523
+ - Disable OpenSSL due to licensing issues
524
+
525
+ * Thu Aug 14 2008 Lubomir Rintel <lkundrak@v3.sk> - 0.47-0.3.20080814svn
526
+ - Update to today's SVN snapshot
527
+ - Drop the upstreamed poppler patch
528
+
529
+ * Wed Aug 13 2008 Lubomir Rintel <lkundrak@v3.sk> - 0.47-0.2.20080705svn
530
+ - Rediff patches for zero fuzz
531
+ - Use uniconvertor to handle CDR and WMF (#458845)
532
+
533
+ * Wed Jul 09 2008 Lubomir Rintel <lkundrak@v3.sk> - 0.47-0.1.20080705svn
534
+ - Subversion snapshot
535
+
536
+ * Wed Jul 09 2008 Lubomir Rintel <lkundrak@v3.sk> - 0.46-4
537
+ - Fix compile issues with newer gtk and poppler
538
+
539
+ * Thu Jun 26 2008 Lubomir Rintel <lkundrak@v3.sk> - 0.46-3
540
+ - Remove useless old hack, that triggered an assert after gtkfilechooser switched to gio
541
+
542
+ * Fri Apr 11 2008 Lubomir Kundrak <lkundrak@redhat.com> - 0.46-2.1
543
+ - More buildrequires more flexible, so that this builds on RHEL
544
+
545
+ * Sat Apr 05 2008 Lubomir Kundrak <lkundrak@redhat.com> - 0.46-2
546
+ - Fix LaTeX rendering, #441017
547
+
548
+ * Tue Mar 25 2008 Lubomir Kundrak <lkundrak@redhat.com> - 0.46-1
549
+ - 0.46 released
550
+
551
+ * Sun Mar 23 2008 Lubomir Kundrak <lkundrak@redhat.com> - 0.46-0.3.pre3
552
+ - Rebuild for newer Poppler
553
+
554
+ * Wed Mar 12 2008 Lubomir Kundrak <lkundrak@redhat.com> - 0.46-0.2.pre3
555
+ - Probably last prerelease?
556
+
557
+ * Fri Feb 22 2008 Lubomir Kundrak <lkundrak@redhat.com> - 0.46-0.2.pre2
558
+ - Panel icon sizes
559
+
560
+ * Sun Feb 17 2008 Lubomir Kundrak <lkundrak@redhat.com> - 0.46-0.1.pre2
561
+ - 0.46pre2
562
+ - Dropping upstreamed patches
563
+
564
+ * Sat Feb 16 2008 Lubomir Kundrak <lkundrak@redhat.com> - 0.45.1+0.46pre1-5
565
+ - Attempt to fix the font selector (#432892)
566
+
567
+ * Thu Feb 14 2008 Lubomir Kundrak <lkundrak@redhat.com> - 0.45.1+0.46pre1-4
568
+ - Tolerate recoverable errors in OCAL feeds
569
+ - Fix OCAL insecure temporary file usage (#432807)
570
+
571
+ * Wed Feb 13 2008 Lubomir Kundrak <lkundrak@redhat.com> - 0.45.1+0.46pre1-3
572
+ - Fix crash when adding text objects (#432220)
573
+
574
+ * Thu Feb 07 2008 Lubomir Kundrak <lkundrak@redhat.com> - 0.45.1+0.46pre1-2
575
+ - Build with gcc-4.3
576
+
577
+ * Wed Feb 06 2008 Lubomir Kundrak <lkundrak@redhat.com> - 0.45.1+0.46pre1-1
578
+ - 0.46 prerelease
579
+ - Minor cosmetic changes to satisfy the QA script
580
+ - Dependency on Boost
581
+ - Inkboard is not optional
582
+ - Merge from Denis Leroy's svn16571 snapshot:
583
+ - Require specific gtkmm24-devel versions
584
+ - enable-poppler-cairo
585
+ - No longer BuildRequire libsigc++20-devel
586
+
587
+ * Wed Dec 5 2007 Denis Leroy <denis@poolshark.org> - 0.45.1-5
588
+ - Rebuild with new openssl
589
+
590
+ * Sun Dec 02 2007 Lubomir Kundrak <lkundrak@redhat.com> - 0.45.1-4
591
+ - Added missing dependencies for modules (#301881)
592
+
593
+ * Sun Dec 02 2007 Lubomir Kundrak <lkundrak@redhat.com> - 0.45.1-3
594
+ - Satisfy desktop-file-validate, so that Rawhide build won't break
595
+
596
+ * Sat Dec 01 2007 Lubomir Kundrak <lkundrak@redhat.com> - 0.45.1-2
597
+ - Use GTK print dialog
598
+ - Added compressed SVG association (#245413)
599
+ - popt headers went into popt-devel, post Fedora 7
600
+ - Fix macro usage in changelog
601
+
602
+ * Wed Mar 21 2007 Denis Leroy <denis@poolshark.org> - 0.45.1-1
603
+ - Update to bugfix release 0.45.1
604
+ - Added R to ImageMagick-perl (#231563)
605
+
606
+ * Wed Feb 7 2007 Denis Leroy <denis@poolshark.org> - 0.45-1
607
+ - Update to 0.45
608
+ - Enabled inkboard, perl and python extensions
609
+ - Added patch for correct python autodetection
610
+ - LaTex patch integrated upstreamed, removed
611
+ - Some rpmlint cleanups
612
+
613
+ * Wed Dec 6 2006 Denis Leroy <denis@poolshark.org> - 0.44.1-2
614
+ - Added patches to fix LaTex import (#217699)
615
+ - Added patch to base postscript import on pstoedit plot-svg
616
+
617
+ * Thu Sep 7 2006 Denis Leroy <denis@poolshark.org> - 0.44.1-1
618
+ - Update to 0.44.1
619
+ - Removed png export patch, integrated upstream
620
+ - Some updated BRs
621
+
622
+ * Mon Aug 28 2006 Denis Leroy <denis@poolshark.org> - 0.44-6
623
+ - FE6 Rebuild
624
+
625
+ * Tue Aug 22 2006 Denis Leroy <denis@poolshark.org> - 0.44-5
626
+ - Removed skencil Require (bug 203229)
627
+
628
+ * Thu Aug 10 2006 Denis Leroy <denis@poolshark.org> - 0.44-4
629
+ - Added patch to fix png dpi export problem (#168406)
630
+
631
+ * Wed Aug 9 2006 Denis Leroy <denis@poolshark.org> - 0.44-3
632
+ - Bumping up release to fix upgrade path
633
+
634
+ * Wed Jun 28 2006 Denis Leroy <denis@poolshark.org> - 0.44-2
635
+ - Update to 0.44
636
+ - Removed obsolete patches
637
+ - Disabled experimental perl and python extensions
638
+ - Added pstoedit, skencil, gtkspell and LittleCms support
639
+ - Inkboard feature disabled pending further security tests
640
+
641
+ * Tue Feb 28 2006 Denis Leroy <denis@poolshark.org> - 0.43-3
642
+ - Rebuild
643
+
644
+ * Mon Jan 16 2006 Denis Leroy <denis@poolshark.org> - 0.43-2
645
+ - Updated GC patch, bug 171791
646
+
647
+ * Sat Dec 17 2005 Denis Leroy <denis@poolshark.org> - 0.43-1
648
+ - Update to 0.43
649
+ - Added 2 patches to fix g++ 4.1 compilation issues
650
+ - Enabled new jabber/loudmouth-based inkboard feature
651
+
652
+ * Mon Sep 26 2005 Denis Leroy <denis@poolshark.org> - 0.42.2-2
653
+ - rebuilt with newer glibmm
654
+
655
+ * Thu Sep 1 2005 Michael Schwendt <mschwendt[AT]users.sf.net> - 0.42.2-1
656
+ - update to 0.42.2
657
+
658
+ * Thu Aug 18 2005 Michael Schwendt <mschwendt[AT]users.sf.net> - 0.42-3
659
+ - rebuilt
660
+ - add patch to repair link-check of GC >= 6.5 (needs pthread and dl)
661
+
662
+ * Fri Jul 29 2005 Michael Schwendt <mschwendt[AT]users.sf.net> - 0.42-2
663
+ - Extend ngettext/dgettext patch for x86_64 build.
664
+
665
+ * Tue Jul 26 2005 Michael Schwendt <mschwendt[AT]users.sf.net> - 0.42-1
666
+ - update to 0.42 (also fixes #160326)
667
+ - BR gnome-vfs2-devel
668
+ - no files left in %%_libdir/inkscape
669
+ - include French manual page
670
+ - GCC4 patch obsolete, 64-bit patch obsolete, dgettext patch split off
671
+
672
+ * Tue May 31 2005 Michael Schwendt <mschwendt[AT]users.sf.net> - 0.41-7
673
+ - append another 64-bit related patch (dgettext configure check failed)
674
+
675
+ * Tue May 31 2005 Michael Schwendt <mschwendt[AT]users.sf.net> - 0.41-6
676
+ - remove explicit aclocal/autoconf calls in %%build as they create a
677
+ bad Makefile for FC4/i386, which causes build to fail (#156228),
678
+ and no comment explains where they were added/needed
679
+
680
+ * Tue May 31 2005 Michael Schwendt <mschwendt[AT]users.sf.net> - 0.41-5
681
+ - bump and rebuild as 0.41-4 failed in build system setup
682
+
683
+ * Wed May 25 2005 Jeremy Katz <katzj@redhat.com> - 0.41-4
684
+ - add patch for gcc4 problems (ignacio, #156228)
685
+ - fix build on 64bit boxes. sizeof(int) != sizeof(void*)
686
+
687
+ * Sun May 22 2005 Jeremy Katz <katzj@redhat.com> - 0.41-3
688
+ - rebuild on all arches
689
+
690
+ * Thu Apr 07 2005 Michael Schwendt <mschwendt[AT]users.sf.net>
691
+ - rebuilt
692
+
693
+ * Wed Feb 09 2005 Phillip Compton <pcompton[AT]proteinmedia.com> - 0.41-1
694
+ - 0.41.
695
+ - enable python.
696
+
697
+ * Sat Dec 04 2004 Phillip Compton <pcompton[AT]proteinmedia.com> - 0.40-1
698
+ - 0.40.
699
+
700
+ * Tue Nov 16 2004 Phillip Compton <pcompton[AT]proteinmedia.com> - 0.40-0.pre3
701
+ - 0.40pre3.
702
+
703
+ * Thu Nov 11 2004 Phillip Compton <pcompton[AT]proteinmedia.com> - 0.39-0.fdr.2
704
+ - post/postun for new mime system.
705
+ - Dropped redundant BR XFree86-devel.
706
+
707
+ * Sun Aug 29 2004 Phillip Compton <pcompton[AT]proteinmedia.com> - 0:0.39-0.fdr.1
708
+ - 0.39.
709
+
710
+ * Sat Apr 10 2004 P Linnell <scribusdocs at atlantictechsolutions.com> 0:0.38.1-0.fdr.1
711
+ - respin real fix for Provides/Requires for perl(SpSVG)
712
+
713
+ * Fri Apr 9 2004 P Linnell <scribusdocs at atlantictechsolutions.com> 0:0.38.1-0.fdr.0
714
+ - respin with updated tarball with fix for postscript printing
715
+
716
+ * Thu Apr 8 2004 P Linnell <scribusdocs at atlantictechsolutions.com> 0:0.38-0.fdr.2
717
+ - respin to fix provides
718
+
719
+ * Thu Apr 8 2004 P Linnell <scribusdocs at atlantictechsolutions.com> 0:0.38.0.fdr.1
720
+ - version upgrade with many improvements and bug fixes
721
+
722
+ * Fri Mar 19 2004 P Linnell <scribusdocs at atlantictechsolutions.com> 0:0.37.0.fdr.7
723
+ - repsin - sourceforge does not allow reloading files with same name
724
+ * Tue Mar 16 2004 P Linnell <scribusdocs at atlantictechsolutions.com> 0:0.37.0.fdr.6
725
+ - fix typo in provides
726
+ * Tue Mar 16 2004 P Linnell <scribusdocs at atlantictechsolutions.com> 0:0.37.0.fdr.5
727
+ - add %%{release} to provides perl(SpSVG) = %%{epoch}:%%{version}:%%{release} only
728
+ * Tue Mar 16 2004 P Linnell <scribusdocs at atlantictechsolutions.com> 0:0.37.0.fdr.4
729
+ - add %%{release} to provides
730
+ * Sun Mar 14 2004 P Linnell <scribusdocs at atlantictechsolutions.com> 0:0.37.0.fdr.3
731
+ - add arch dependent flags
732
+ * Thu Mar 11 2004 P Linnell <scribusdocs at atlantictechsolutions.com> 0:0.37.0.fdr.2
733
+ - add libsigc++-devel instead of add libsigc++ - duh
734
+ - add BuildRequires: perl-XML-Parser
735
+ - fix package name to follow package naming guidelines
736
+ * Mon Mar 1 2004 P Linnell <scribusdocs at atlantictechsolutions.com> 0:0.37.1.fdr.1
737
+ - disable static libs
738
+ - enable inkjar
739
+ * Tue Feb 10 2004 P Linnell <scribusdocs at atlantictechsolutions.com> 0:0.37.0.fdr.1
740
+ - pgp'd tarball from inkscape.org
741
+ - clean out the cvs tweaks in spec file
742
+ - enable gnome-print
743
+ - add the new tutorial files
744
+ - make sure .mo file gets packaged
745
+ - add provides: perlSVG
746
+ - submit to Fedora QA
747
+ * Sat Feb 7 2004 P Linnell <scribusdocs at atlantictechsolutions.com>
748
+ - rebuild of current cvs
749
+ - tweaks to build cvs instead of dist tarball
750
+ - add inkview
751
+ * Sat Dec 20 2003 P Linnell <scribusdocs at atlantictechsolutions.com>
752
+ - First crack at Fedora/RH spec file
753
+ - nuke gnome print - it won't work (bug is filed already)