a542ae import fribidi-1.0.4-9.el8

Authored and Committed by centosrcm 2 years ago
    import fribidi-1.0.4-9.el8
    
        
SOURCES/fribidi-CVE-2022-25308.patch ADDED
@@ -0,0 +1,48 @@
1
+ From ad3a19e6372b1e667128ed1ea2f49919884587e1 Mon Sep 17 00:00:00 2001
2
+ From: Akira TAGOH <akira@tagoh.org>
3
+ Date: Thu, 17 Feb 2022 17:30:12 +0900
4
+ Subject: [PATCH 1/4] Fix the stack buffer overflow issue
5
+
6
+ strlen() could returns 0. Without a conditional check for len,
7
+ accessing S_ pointer with len - 1 may causes a stack buffer overflow.
8
+
9
+ AddressSanitizer reports this like:
10
+ ==1219243==ERROR: AddressSanitizer: stack-buffer-overflow on address 0x7ffdce043c1f at pc 0x000000403547 bp 0x7ffdce0
11
+ 43b30 sp 0x7ffdce043b28
12
+ READ of size 1 at 0x7ffdce043c1f thread T0
13
+ #0 0x403546 in main ../bin/fribidi-main.c:393
14
+ #1 0x7f226804e58f in __libc_start_call_main (/lib64/libc.so.6+0x2d58f)
15
+ #2 0x7f226804e648 in __libc_start_main_impl (/lib64/libc.so.6+0x2d648)
16
+ #3 0x4036f4 in _start (/tmp/fribidi/build/bin/fribidi+0x4036f4)
17
+
18
+ Address 0x7ffdce043c1f is located in stack of thread T0 at offset 63 in frame
19
+ #0 0x4022bf in main ../bin/fribidi-main.c:193
20
+
21
+ This frame has 5 object(s):
22
+ [32, 36) 'option_index' (line 233)
23
+ [48, 52) 'base' (line 386)
24
+ [64, 65064) 'S_' (line 375) <== Memory access at offset 63 underflows this variable
25
+ [65328, 130328) 'outstring' (line 385)
26
+ [130592, 390592) 'logical' (line 384)
27
+
28
+ This fixes https://github.com/fribidi/fribidi/issues/181
29
+ ---
30
+ bin/fribidi-main.c | 2 +-
31
+ 1 file changed, 1 insertion(+), 1 deletion(-)
32
+
33
+ diff --git a/bin/fribidi-main.c b/bin/fribidi-main.c
34
+ index 3cf9fe1..3ae4fb6 100644
35
+ --- a/bin/fribidi-main.c
36
+ +++ b/bin/fribidi-main.c
37
+ @@ -390,7 +390,7 @@ FRIBIDI_END_IGNORE_DEPRECATIONS
38
+ S_[sizeof (S_) - 1] = 0;
39
+ len = strlen (S_);
40
+ /* chop */
41
+ - if (S_[len - 1] == '\n')
42
+ + if (len > 0 && S_[len - 1] == '\n')
43
+ {
44
+ len--;
45
+ S_[len] = '\0';
46
+ --
47
+ 2.35.1
48
+
SOURCES/fribidi-CVE-2022-25309.patch ADDED
@@ -0,0 +1,30 @@
1
+ From f22593b82b5d1668d1997dbccd10a9c31ffea3b3 Mon Sep 17 00:00:00 2001
2
+ From: Dov Grobgeld <dov.grobgeld@gmail.com>
3
+ Date: Fri, 25 Mar 2022 09:09:49 +0300
4
+ Subject: [PATCH 2/4] Protected against garbage in the CapRTL encoder
5
+
6
+ ---
7
+ lib/fribidi-char-sets-cap-rtl.c | 7 ++++++-
8
+ 1 file changed, 6 insertions(+), 1 deletion(-)
9
+
10
+ diff --git a/lib/fribidi-char-sets-cap-rtl.c b/lib/fribidi-char-sets-cap-rtl.c
11
+ index b0c0e4a..f74e010 100644
12
+ --- a/lib/fribidi-char-sets-cap-rtl.c
13
+ +++ b/lib/fribidi-char-sets-cap-rtl.c
14
+ @@ -232,7 +232,12 @@ fribidi_cap_rtl_to_unicode (
15
+ }
16
+ }
17
+ else
18
+ - us[j++] = caprtl_to_unicode[(int) s[i]];
19
+ + {
20
+ + if ((int)s[i] < 0)
21
+ + us[j++] = '?';
22
+ + else
23
+ + us[j++] = caprtl_to_unicode[(int) s[i]];
24
+ + }
25
+ }
26
+
27
+ return j;
28
+ --
29
+ 2.35.1
30
+
SOURCES/fribidi-CVE-2022-25310.patch ADDED
@@ -0,0 +1,12 @@
1
+ diff -pruN fribidi-1.0.4/lib/fribidi-deprecated.c fribidi-1.0.4.orig/lib/fribidi-deprecated.c
2
+ --- fribidi-1.0.4.orig/lib/fribidi-deprecated.c 2022-04-14 17:00:47.432555374 +0900
3
+ +++ fribidi-1.0.4/lib/fribidi-deprecated.c 2018-03-01 16:37:02.000000000 +0900
4
+ @@ -121,7 +121,7 @@ fribidi_remove_bidi_marks (
5
+ fribidi_boolean status = false;
6
+
7
+ if UNLIKELY
8
+ - (len == 0)
9
+ + (len == 0 || str == NULL)
10
+ {
11
+ status = true;
12
+ goto out;
file modified
+11 -4
SPECS/fribidi.spec CHANGED
@@ -1,14 +1,17 @@
1
1
Summary: Library implementing the Unicode Bidirectional Algorithm
2
2
Name: fribidi
3
3
Version: 1.0.4
4
- Release: 8%{?dist}
4
+ Release: 9%{?dist}
5
5
URL: https://github.com/fribidi/fribidi/
6
6
Source: https://github.com//%{name}/%{name}/releases/download/v%{version}/%{name}-%{version}.tar.bz2
7
7
License: LGPLv2+ and UCD
8
- BuildRequires: gcc
8
+ BuildRequires: gcc make
9
9
BuildRequires: automake autoconf libtool
10
10
Patch0: %{name}-drop-bundled-gnulib.patch
11
11
Patch1: %{name}-CVE-2019-18397.patch
12
+ Patch2: %{name}-CVE-2022-25308.patch
13
+ Patch3: %{name}-CVE-2022-25309.patch
14
+ Patch4: %{name}-CVE-2022-25310.patch
12
15
13
16
%description
14
17
A library to handle bidirectional scripts (for example Hebrew, Arabic),
@@ -40,7 +43,7 @@ export CFLAGS="$CFLAGS -DPAGE_SIZE=4096"
40
43
export CFLAGS="$RPM_OPT_FLAGS -DPAGE_SIZE=4096"
41
44
%endif
42
45
%endif
43
- %configure --disable-static --disable-docs
46
+ %configure --disable-static
44
47
make %{?_smp_mflags}
45
48
46
49
%check
@@ -65,11 +68,15 @@ rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
65
68
%{_mandir}/man3/*.gz
66
69
67
70
%changelog
71
+ * Thu Apr 14 2022 Akira TAGOH <tagoh@redhat.com> - 1.0.4-9
72
+ - Fix security issues CVE-2022-25308, CVE-2022-25309, CVE-2022-25310.
73
+ Resolves: rhbz#2050085, rhbz#2050068, rhbz#2050062
74
+ - Drop --disable-docs from %%configure. no such options available.
75
+
68
76
* Tue Dec 17 2019 Tomas Pelka <tpelka@redhat.com> - 1.0.4-8
69
77
- bump version and rebuild to avoid version conflict with 8.1.0.z
70
78
Resolves: rhbz#1781227
71
79
72
-
73
80
* Fri Dec 13 2019 Akira TAGOH <tagoh@redhat.com> - 1.0.4-7
74
81
- Security fix for CVE-2019-18397
75
82
Resolves: rhbz#1781227