3aa095 Explicitly compile the scripts using py_byte_compile

Authored and Committed by Paolo Bonzini 6 years ago
1 file changed. 5 lines added. 1 lines removed.
    Explicitly compile the scripts using py_byte_compile
    
        
file modified
+5 -1
edk2.spec CHANGED
@@ -35,7 +35,7 @@
35
35
36
36
Name: edk2
37
37
Version: %{edk2_date}git%{edk2_githash}
38
- Release: 2%{dist}
38
+ Release: 3%{dist}
39
39
Summary: EFI Development Kit II
40
40
41
41
Group: Applications/Emulators
@@ -391,6 +391,7 @@ install BaseTools/Scripts/GccBase.lds \
391
391
%{buildroot}%{_datadir}/%{name}/Scripts
392
392
393
393
cp -R BaseTools/Source/Python %{buildroot}%{_datadir}/%{name}/Python
394
+ %py_byte_compile %{__python2} %{buildroot}%{_datadir}/%{name}/Python
394
395
for i in build BPDG Ecc GenDepex GenFds GenPatchPcdTable PatchPcdValue TargetTool Trim UPT; do
395
396
echo '#!/bin/sh
396
397
export PYTHONPATH=%{_datadir}/%{name}/Python
@@ -527,6 +528,9 @@ install qemu-ovmf-secureboot-%{qosb_version}/ovmf-vars-generator %{buildroot}%{_
527
528
528
529
529
530
%changelog
531
+ * Wed Sep 12 2018 Paolo Bonzini <pbonzini@redhat.com> - 20180815gitcb5f4f45ce-3
532
+ - Explicitly compile the scripts using py_byte_compile
533
+
530
534
* Fri Aug 31 2018 Cole Robinson <crobinso@redhat.com> - 20180815gitcb5f4f45ce-2
531
535
- Fix passing through RPM build flags (bz 1540244)
532
536