69c2b8 import dpdk-21.11.2-1.el9_1

Authored and Committed by centosrcm 2 years ago
    import dpdk-21.11.2-1.el9_1
    
        
file modified
+1 -1
.dpdk.metadata CHANGED
@@ -1,2 +1,2 @@
1
- 17331a86759beba4b6635ed530ce23b0b73c0744 SOURCES/dpdk-21.11.tar.xz
1
+ d36c9e0949cb80d890273365f0d2b627d7f6f21b SOURCES/dpdk-21.11.2.tar.xz
2
2
3cc45b133677fbff08e89e65a2120be52ebb27a5 SOURCES/pyelftools-0.27.tar.gz
file modified
+1 -1
.gitignore CHANGED
@@ -1,2 +1,2 @@
1
- SOURCES/dpdk-21.11.tar.xz
1
+ SOURCES/dpdk-21.11.2.tar.xz
2
2
SOURCES/pyelftools-0.27.tar.gz
SOURCES/0001-vhost-fix-virtqueue-use-after-free-on-NUMA-reallocat.patch ADDED
@@ -0,0 +1,34 @@
1
+ From 8010a15523e896ca2f2436432602210cab793f87 Mon Sep 17 00:00:00 2001
2
+ From: David Marchand <david.marchand@redhat.com>
3
+ Date: Mon, 25 Jul 2022 22:32:03 +0200
4
+ Subject: [PATCH] vhost: fix virtqueue use after free on NUMA reallocation
5
+
6
+ [ upstream commit 0b2a2ca35037d6a5168f0832c11d9858b8ae946a ]
7
+
8
+ translate_ring_addresses (via numa_realloc) may change a virtio device and
9
+ virtio queue.
10
+ The virtqueue object must be refreshed before accessing the lock.
11
+
12
+ Fixes: 04c27cb673b9 ("vhost: fix unsafe vring addresses modifications")
13
+
14
+ Signed-off-by: David Marchand <david.marchand@redhat.com>
15
+ Reviewed-by: Maxime Coquelin <maxime.coquelin@redhat.com>
16
+ ---
17
+ lib/vhost/vhost_user.c | 1 +
18
+ 1 file changed, 1 insertion(+)
19
+
20
+ diff --git a/lib/vhost/vhost_user.c b/lib/vhost/vhost_user.c
21
+ index df780fd7d6..2b45e35d4a 100644
22
+ --- a/lib/vhost/vhost_user.c
23
+ +++ b/lib/vhost/vhost_user.c
24
+ @@ -2575,6 +2575,7 @@ vhost_user_iotlb_msg(struct virtio_net **pdev, struct VhostUserMsg *msg,
25
+ if (is_vring_iotlb(dev, vq, imsg)) {
26
+ rte_spinlock_lock(&vq->access_lock);
27
+ *pdev = dev = translate_ring_addresses(dev, i);
28
+ + vq = dev->virtqueue[i];
29
+ rte_spinlock_unlock(&vq->access_lock);
30
+ }
31
+ }
32
+ --
33
+ 2.37.3
34
+
file modified
+11 -4
SPECS/dpdk.spec CHANGED
@@ -8,10 +8,10 @@
8
8
#% define date 20191128
9
9
#% define shortcommit0 %(c=%{commit0}; echo ${c:0:7})
10
10
11
- %define ver 21.11
11
+ %define ver 21.11.2
12
12
%define rel 1
13
13
14
- %define srcname dpdk
14
+ %define srcname dpdk%(awk -F. '{ if (NF > 2) print "-stable" }' <<<%{version})
15
15
16
16
%define pyelftoolsver 0.27
17
17
@@ -31,8 +31,7 @@ Source: http://fast.dpdk.org/rel/dpdk-%{ver}.tar.xz
31
31
# Only needed for creating snapshot tarballs, not used in build itself
32
32
Source100: dpdk-snapshot.sh
33
33
34
- # Patches only in dpdk package
34
+ Patch1: 0001-vhost-fix-virtqueue-use-after-free-on-NUMA-reallocat.patch
35
-
36
35
37
36
Summary: Set of libraries and drivers for fast packet processing
38
37
@@ -274,6 +273,14 @@ rm -rf %{docdir}/html/.doctrees
274
273
%endif
275
274
276
275
%changelog
276
+ * Mon Sep 12 2022 Timothy Redaelli <tredaelli@redhat.com> - 21.11.2-1
277
+ - Rebase to 21.11.2 (#2126159)
278
+ - Includes fixes for CVE-2022-2132 (#2107173) and CVE-2022-28199 (#2123616)
279
+
280
+ * Wed Jul 13 2022 Timothy Redaelli <tredaelli@redhat.com> - 21.11.1-1
281
+ - Rebase to 21.11.1 (#2106856)
282
+ - Includes fix for CVE-2021-3839 (#2026642)
283
+
277
284
* Tue Nov 23 2021 David Marchand <david.marchand@redhat.com> - 21.11-1
278
285
- Rebase to 21.11 (#2030616)
279
286