1bf060 update to 9.9.3

Authored and Committed by Tomas Hozza 11 years ago
    update to 9.9.3
    
    - install dns/update.h header
    
    Signed-off-by: Tomas Hozza <thozza@redhat.com>
    
        
file modified
+1 -0
.gitignore CHANGED
@@ -33,3 +33,4 @@ bind-9.7.2b1.tar.gz
33
33
/bind-9.9.3rc1.tar.gz
34
34
/config-11.tar.bz2
35
35
/bind-9.9.3rc2.tar.gz
36
+ /bind-9.9.3.tar.gz
bind-9.9-sdb-zone2sqlite-table-name.patch DELETED
@@ -1,51 +0,0 @@
1
- From 75f51e2f14d9fce2001aa91ad444e327321a19c3 Mon Sep 17 00:00:00 2001
2
- From: Tomas Hozza <thozza@redhat.com>
3
- Date: Thu, 2 May 2013 15:05:51 +0200
4
- Subject: [PATCH] Table name should be quoted when used in SQL commands
5
-
6
- Table name should be quoted when dropping/creating/inserting in
7
- some table. Currently zone2sqlite is unable to handle table
8
- names starting with ".", "-", number, etc.
9
-
10
- This can be solved by using "%Q" instead of "%q" in sqlite3_mprintf()
11
- calls when inserting table name.
12
-
13
- Signed-off-by: Tomas Hozza <thozza@redhat.com>
14
- ---
15
- contrib/sdb/sqlite/zone2sqlite.c | 6 +++---
16
- 1 file changed, 3 insertions(+), 3 deletions(-)
17
-
18
- diff --git a/contrib/sdb/sqlite/zone2sqlite.c b/contrib/sdb/sqlite/zone2sqlite.c
19
- index b583d2b..7b9260a 100644
20
- --- a/contrib/sdb/sqlite/zone2sqlite.c
21
- +++ b/contrib/sdb/sqlite/zone2sqlite.c
22
- @@ -129,7 +129,7 @@ addrdata(dns_name_t *name, dns_ttl_t ttl, dns_rdata_t *rdata)
23
- dataarray[isc_buffer_usedlength(&b)] = 0;
24
-
25
- sql = sqlite3_mprintf(
26
- - "INSERT INTO %q (NAME, TTL, RDTYPE, RDATA)"
27
- + "INSERT INTO %Q (NAME, TTL, RDTYPE, RDATA)"
28
- " VALUES ('%q', %d, '%q', '%q') ",
29
- dbi.table,
30
- namearray, ttl, typearray, dataarray);
31
- @@ -208,7 +208,7 @@ main(int argc, char *argv[])
32
- closeandexit(1);
33
- }
34
-
35
- - sql = sqlite3_mprintf("DROP TABLE %q ", dbi.table);
36
- + sql = sqlite3_mprintf("DROP TABLE %Q ", dbi.table);
37
- printf("%s\n", sql);
38
- res = sqlite3_exec(dbi.db, sql, NULL, NULL, &errmsg);
39
- sqlite3_free(sql);
40
- @@ -231,7 +231,7 @@ main(int argc, char *argv[])
41
- #endif
42
-
43
- sql = sqlite3_mprintf(
44
- - "CREATE TABLE %q "
45
- + "CREATE TABLE %Q "
46
- "(NAME TEXT, TTL INTEGER, RDTYPE TEXT, RDATA TEXT) ",
47
- dbi.table);
48
- printf("%s\n", sql);
49
- --
50
- 1.8.1.4
51
-
bind-9.9.3-include-update-h.patch ADDED
@@ -0,0 +1,12 @@
1
+ diff -up bind-9.9.3/lib/dns/include/dns/Makefile.in.update bind-9.9.3/lib/dns/include/dns/Makefile.in
2
+ --- bind-9.9.3/lib/dns/include/dns/Makefile.in.update 2013-06-03 09:29:41.049197873 +0200
3
+ +++ bind-9.9.3/lib/dns/include/dns/Makefile.in 2013-06-03 09:30:09.229213170 +0200
4
+ @@ -30,7 +30,7 @@ HEADERS = acl.h adb.h byaddr.h cache.h c
5
+ rdata.h rdataclass.h rdatalist.h rdataset.h rdatasetiter.h \
6
+ rdataslab.h rdatatype.h request.h resolver.h result.h \
7
+ rootns.h rpz.h sdb.h sdlz.h secalg.h secproto.h soa.h ssu.h \
8
+ - tcpmsg.h time.h tkey.h tsig.h ttl.h types.h \
9
+ + tcpmsg.h time.h tkey.h tsig.h ttl.h types.h update.h\
10
+ validator.h version.h view.h xfrin.h zone.h zonekey.h zt.h \
11
+ forward.h rrl.h
12
+
file modified
+11 -7
bind.spec CHANGED
@@ -3,9 +3,9 @@
3
3
#
4
4
5
5
#%%global PATCHVER P2
6
- %global PREVER rc2
7
- %global VERSION %{version}%{PREVER}
8
- #%%global VERSION %{version}
6
+ #%%global PREVER rc2
7
+ #%%global VERSION %{version}%{PREVER}
8
+ %global VERSION %{version}
9
9
#%%global VERSION %{version}-%{PATCHVER}
10
10
11
11
%{?!SDB: %global SDB 1}
@@ -26,7 +26,7 @@ Summary: The Berkeley Internet Name Domain (BIND) DNS (Domain Name System) serv
26
26
Name: bind
27
27
License: ISC
28
28
Version: 9.9.3
29
- Release: 0.7.%{PREVER}%{?dist}
29
+ Release: 1%{?PREVER}%{?dist}
30
30
Epoch: 32
31
31
Url: http://www.isc.org/products/BIND/
32
32
Buildroot:%{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
@@ -81,13 +81,13 @@ Patch133:bind99-rh640538.patch
81
81
Patch134:bind97-rh669163.patch
82
82
Patch136:rl-9.9.3rc2.patch
83
83
Patch137:bind99-rrl.patch
84
+ # Install dns/update.h header for bind-dyndb-ldap plugin
85
+ Patch138:bind-9.9.3-include-update-h.patch
84
86
85
87
# SDB patches
86
88
Patch11: bind-9.3.2b2-sdbsrc.patch
87
89
Patch12: bind-9.5-sdb.patch
88
90
Patch62: bind-9.5-sdb-sqlite-bld.patch
89
- # ISC-Bugs #33375
90
- Patch139:bind-9.9-sdb-zone2sqlite-table-name.patch
91
91
92
92
# needs inpection
93
93
Patch17: bind-9.3.2b1-fix_sdb_ldap.patch
@@ -281,6 +281,7 @@ popd
281
281
%patch131 -p1 -b .multlib-conflict
282
282
%patch136 -p1 -b .rl
283
283
%patch137 -p1 -b .rrl
284
+ %patch138 -p1 -b .update
284
285
285
286
%if %{SDB}
286
287
%patch101 -p1 -b .old-api
@@ -292,7 +293,6 @@ cp -fp contrib/sdb/ldap/ldapdb.[ch] bin/named-sdb
292
293
# SDB postgreSQL
293
294
cp -fp contrib/sdb/pgsql/pgsqldb.[ch] bin/named-sdb
294
295
# SDB sqlite
295
- %patch139 -p1 -b .table_name
296
296
cp -fp contrib/sdb/sqlite/sqlitedb.[ch] bin/named-sdb
297
297
# SDB Berkeley DB - needs to be ported to DB4!
298
298
#cp -fp contrib/sdb/bdb/bdb.[ch] bin/named_sdb
@@ -779,6 +779,10 @@ rm -rf ${RPM_BUILD_ROOT}
779
779
%endif
780
780
781
781
%changelog
782
+ * Mon Jun 03 2013 Tomas Hozza <thozza@redhat.com> 32:9.9.3-1
783
+ - update to 9.9.3
784
+ - install dns/update.h header
785
+
782
786
* Fri May 17 2013 Tomas Hozza <thozza@redhat.com> 32:9.9.3-0.7.rc2
783
787
- Fix segfault in host/nslookup (#878139)
784
788
file modified
+1 -1
sources CHANGED
@@ -1,2 +1,2 @@
1
- dfd6306f79a435944bb2be6f09445708 bind-9.9.3rc2.tar.gz
1
+ 7baa8359f0773e04f63d7e694db1909c bind-9.9.3.tar.gz
2
2
d64062a182bf71dbcae7b2e2fe2cd55b config-11.tar.bz2