Blame SOURCES/bash42-042

287226
			     BASH PATCH REPORT
287226
			     =================
287226
287226
Bash-Release:	4.2
287226
Patch-ID:	bash42-042
287226
287226
Bug-Reported-by:	Adam Pippin <adam@gp-inc.ca>
287226
Bug-Reference-ID:	<CAPYbNHr6ucZFOoWsRdUJj6KP3Ju0j1bkESa_cmb7iU+kZwdVpg@mail.gmail.com>
287226
Bug-Reference-URL:	http://lists.gnu.org/archive/html/bug-bash/2012-11/msg00087.html
287226
287226
Bug-Description:
287226
287226
Compilation failed after specifying the  `--enable-minimal-config' option to
287226
configure (more specifically, specifying `--disable-alias').
287226
287226
Patch (apply with `patch -p0'):
287226
287226
*** ../bash-4.2-patched/parse.y	2012-07-08 21:53:33.000000000 -0400
287226
--- parse.y	2012-10-14 20:20:34.000000000 -0400
287226
***************
287226
*** 2394,2397 ****
287226
--- 2392,2396 ----
287226
  	   to consume the quoted newline and move to the next character in
287226
  	   the expansion. */
287226
+ #if defined (ALIAS)
287226
  	if (expanding_alias () && shell_input_line[shell_input_line_index+1] == '\0')
287226
  	  {
287226
***************
287226
*** 2404,2408 ****
287226
  	    goto next_alias_char;	/* and get next character */
287226
  	  }
287226
! 	else	    
287226
  	  goto restart_read;
287226
      }
287226
--- 2403,2408 ----
287226
  	    goto next_alias_char;	/* and get next character */
287226
  	  }
287226
! 	else
287226
! #endif 
287226
  	  goto restart_read;
287226
      }
287226
287226
*** ../bash-4.2-patched/patchlevel.h	Sat Jun 12 20:14:48 2010
287226
--- patchlevel.h	Thu Feb 24 21:41:34 2011
287226
***************
287226
*** 26,30 ****
287226
     looks for to find the patch level (for the sccs version string). */
287226
  
287226
! #define PATCHLEVEL 41
287226
  
287226
  #endif /* _PATCHLEVEL_H_ */
287226
--- 26,30 ----
287226
     looks for to find the patch level (for the sccs version string). */
287226
  
287226
! #define PATCHLEVEL 42
287226
  
287226
  #endif /* _PATCHLEVEL_H_ */