263faa
%global _hardened_build 1
263faa
263faa
%{?!WITH_MONO:          %global WITH_MONO 1}
263faa
%{?!WITH_COMPAT_DNSSD:  %global WITH_COMPAT_DNSSD 1}
263faa
%{?!WITH_COMPAT_HOWL:   %global WITH_COMPAT_HOWL  1}
263faa
%ifarch sparc64 s390
263faa
%define WITH_MONO 0
263faa
%endif
263faa
%if 0%{?rhel}
263faa
%define WITH_MONO 0
263faa
%endif
263faa
263faa
Name:             avahi
263faa
Version:          0.6.31
263faa
Release:          19%{?dist}
263faa
Summary:          Local network service discovery
263faa
License:          LGPLv2+
263faa
URL:              http://avahi.org
263faa
Requires:         dbus
263faa
Requires:         expat
263faa
Requires:         libdaemon >= 0.11
263faa
Requires(post):   initscripts
263faa
Requires(post):   ldconfig
263faa
Requires(pre):    shadow-utils
263faa
Requires(pre):    coreutils
263faa
Requires(pre):    /usr/bin/getent
263faa
Requires(pre):    /usr/sbin/groupadd
263faa
Requires:         %{name}-libs = %{version}-%{release}
263faa
BuildRequires:    automake
263faa
BuildRequires:    autoconf
263faa
BuildRequires:    libtool
263faa
BuildRequires:    dbus-devel >= 0.90
263faa
BuildRequires:    dbus-glib-devel >= 0.70
263faa
BuildRequires:    dbus-python
263faa
BuildRequires:    libxml2-python
263faa
BuildRequires:    gtk2-devel
263faa
BuildRequires:    gtk3-devel >= 2.99.0
263faa
#BuildRequires:    gobject-introspection-devel
263faa
BuildRequires:    qt3-devel
263faa
BuildRequires:    qt4-devel
263faa
BuildRequires:    libglade2-devel
263faa
BuildRequires:    libdaemon-devel >= 0.11
263faa
BuildRequires:    glib2-devel
263faa
BuildRequires:    libcap-devel
263faa
BuildRequires:    expat-devel
263faa
BuildRequires:    python
263faa
BuildRequires:    gdbm-devel
263faa
BuildRequires:    pygtk2
263faa
BuildRequires:    intltool
263faa
BuildRequires:    perl-XML-Parser
263faa
%if %{WITH_MONO}
263faa
BuildRequires:    mono-devel >= 1.1.13
263faa
BuildRequires:    monodoc-devel
263faa
%endif
263faa
BuildRequires:    systemd
263faa
Requires:         systemd
263faa
Requires(post):   systemd
263faa
Requires(preun):  systemd
263faa
Requires(postun): systemd
263faa
Requires(post):   systemd-sysv
263faa
263faa
Source0:          http://avahi.org/download/%{name}-%{version}.tar.gz
263faa
Patch0000:        avahi-0.6.30-mono-libdir.patch
263faa
Patch0001:        0001-man-correct-short-option-to-print-version-string.patch
263faa
Patch0002:        0002-man-add-description-for-t-option.patch
263faa
Patch0003:        0003-dbus-don-t-crash-if-we-can-t-determine-alternative-s.patch
263faa
Patch0004:        0004-avahi-core-reserve-space-for-record-data-when-size-e.patch
263faa
Patch0005:        0005-Remove-prefix-home-lennart-tmp-avahi-from-references.patch
263faa
Patch0006:        0006-Silently-ignore-invalid-DNS-packets.patch
263faa
Patch0007:        0007-avahi-daemon-don-t-add-0pointer.de-and-zeroconf.org-.patch
263faa
Patch0008:        0008-avahi_server_set_browse_domains-check-the-provided-d.patch
263faa
Patch0009:        0009-Fix-not-publishing-entries-if-a-probing-interface-is.patch
263faa
Patch0010:        0010-avahi-ui-Replace-usage-of-deprecated-GTK-Stock-Items.patch
263faa
Patch0011:        0011-avahi-ui-replace-gtk_vbox_new-with-gtk_box_new-for-G.patch
263faa
Patch0012:        0012-avahi-ui-Cannot-use-g_object_unref-to-free-GdkCursor.patch
263faa
Patch0013:        0013-avahi-ui-Remove-deprecated-usage-of-gtk_widget_push_.patch
263faa
263faa
# due to FTBFS caused by Gtk changes introduced in RHEL-7.2
263faa
Patch1000:        avahi-0.6.31-no-deprecations.patch
263faa
263faa
%description
263faa
Avahi is a system which facilitates service discovery on
263faa
a local network -- this means that you can plug your laptop or
263faa
computer into a network and instantly be able to view other people who
263faa
you can chat with, find printers to print to or find files being
263faa
shared. This kind of technology is already found in MacOS X (branded
263faa
'Rendezvous', 'Bonjour' and sometimes 'ZeroConf') and is very
263faa
convenient.
263faa
263faa
%package tools
263faa
Summary:          Command line tools for mDNS browsing and publishing
263faa
Requires:         %{name} = %{version}-%{release}
263faa
Requires:         %{name}-libs = %{version}-%{release}
263faa
263faa
%description tools
263faa
Command line tools that use avahi to browse and publish mDNS services.
263faa
263faa
%package ui-tools
263faa
Summary:          UI tools for mDNS browsing
263faa
Requires:         %{name} = %{version}-%{release}
263faa
Requires:         %{name}-libs = %{version}-%{release}
263faa
Requires:         %{name}-glib = %{version}-%{release}
263faa
Requires:         %{name}-ui-gtk3 = %{version}-%{release}
263faa
Requires:         vnc
263faa
Requires:         openssh-clients
263faa
Requires:         pygtk2
263faa
Requires:         pygtk2-libglade
263faa
Requires:         gdbm
263faa
Requires:         python
263faa
Requires:         dbus-python
263faa
263faa
%description ui-tools
263faa
Graphical user interface tools that use Avahi to browse for mDNS services.
263faa
263faa
%package glib
263faa
Summary:          Glib libraries for avahi
263faa
Conflicts:        %{name} < %{version}-%{release}
263faa
Conflicts:        %{name} > %{version}-%{release}
263faa
Requires:         %{name}-libs = %{version}-%{release}
263faa
263faa
%description glib
263faa
Libraries for easy use of avahi from glib applications.
263faa
263faa
%package glib-devel
263faa
Summary:          Libraries and header files for avahi glib development
263faa
Requires:         %{name}-libs = %{version}-%{release}
263faa
Requires:         %{name}-devel = %{version}-%{release}
263faa
Requires:         %{name}-glib = %{version}-%{release}
263faa
Requires:         glib2-devel
263faa
263faa
%description glib-devel
263faa
The avahi-devel package contains the header files and libraries
263faa
necessary for developing programs using avahi with glib.
263faa
263faa
%package gobject
263faa
Summary:          GObject wrapper library for Avahi
263faa
Conflicts:        %{name} < %{version}-%{release}
263faa
Conflicts:        %{name} > %{version}-%{release}
263faa
Requires:         %{name}-libs = %{version}-%{release}
263faa
Requires:         %{name}-glib = %{version}-%{release}
263faa
263faa
%description gobject
263faa
This library contains a GObject wrapper for the Avahi API
263faa
263faa
%package gobject-devel
263faa
Summary:          Libraries and header files for Avahi GObject development
263faa
Requires:         %{name}-libs = %{version}-%{release}
263faa
Requires:         %{name}-devel = %{version}-%{release}
263faa
Requires:         %{name}-glib = %{version}-%{release}
263faa
Requires:         %{name}-glib-devel = %{version}-%{release}
263faa
Requires:         %{name}-gobject = %{version}-%{release}
263faa
263faa
%description gobject-devel
263faa
The avahi-gobject-devel package contains the header files and libraries
263faa
necessary for developing programs using avahi-gobject.
263faa
263faa
%package ui
263faa
Summary:          Gtk user interface library for Avahi (Gtk+ 2 version)
263faa
Conflicts:        %{name} < %{version}-%{release}
263faa
Conflicts:        %{name} > %{version}-%{release}
263faa
Requires:         %{name}-libs = %{version}-%{release}
263faa
Requires:         %{name}-glib = %{version}-%{release}
263faa
Requires:         gtk2
263faa
263faa
%description ui
263faa
This library contains a Gtk 2.x widget for browsing services.
263faa
263faa
%package ui-gtk3
263faa
Summary:          Gtk user interface library for Avahi (Gtk+ 3 version)
263faa
Conflicts:        %{name} < %{version}-%{release}
263faa
Conflicts:        %{name} > %{version}-%{release}
263faa
Requires:         %{name}-libs = %{version}-%{release}
263faa
Requires:         %{name}-glib = %{version}-%{release}
263faa
Requires:         gtk3
263faa
263faa
%description ui-gtk3
263faa
This library contains a Gtk 3.x widget for browsing services.
263faa
263faa
%package ui-devel
263faa
Summary:          Libraries and header files for Avahi UI development
263faa
Requires:         %{name}-libs = %{version}-%{release}
263faa
Requires:         %{name}-devel = %{version}-%{release}
263faa
Requires:         %{name}-glib = %{version}-%{release}
263faa
Requires:         %{name}-glib-devel = %{version}-%{release}
263faa
Requires:         %{name}-ui = %{version}-%{release}
263faa
Requires:         %{name}-ui-gtk3 = %{version}-%{release}
263faa
263faa
%description ui-devel
263faa
The avahi-ui-devel package contains the header files and libraries
263faa
necessary for developing programs using avahi-ui.
263faa
263faa
%package qt3
263faa
Summary:          Qt3 libraries for avahi
263faa
Conflicts:        %{name} < %{version}-%{release}
263faa
Conflicts:        %{name} > %{version}-%{release}
263faa
Requires:         %{name}-libs = %{version}-%{release}
263faa
263faa
%description qt3
263faa
Libraries for easy use of avahi from Qt3 applications.
263faa
263faa
%package qt3-devel
263faa
Summary:          Libraries and header files for avahi Qt3 development
263faa
Requires:         %{name}-libs = %{version}-%{release}
263faa
Requires:         %{name}-devel = %{version}-%{release}
263faa
Requires:         %{name}-qt3 = %{version}-%{release}
263faa
Requires:         qt3-devel
263faa
263faa
%description qt3-devel
263faa
The avahi-qt3-devel package contains the header files and libraries
263faa
necessary for developing programs using avahi with Qt3.
263faa
263faa
%package qt4
263faa
Summary:          Qt4 libraries for avahi
263faa
Conflicts:        %{name} < %{version}-%{release}
263faa
Conflicts:        %{name} > %{version}-%{release}
263faa
Requires:         %{name}-libs = %{version}-%{release}
263faa
263faa
%description qt4
263faa
Libraries for easy use of avahi from Qt4 applications.
263faa
263faa
%package qt4-devel
263faa
Summary:          Libraries and header files for avahi Qt4 development
263faa
Requires:         %{name}-libs = %{version}-%{release}
263faa
Requires:         %{name}-devel = %{version}-%{release}
263faa
Requires:         %{name}-qt4 = %{version}-%{release}
263faa
Requires:         qt4-devel
263faa
263faa
%description qt4-devel
263faa
Th avahi-qt4-devel package contains the header files and libraries
263faa
necessary for developing programs using avahi with Qt4.
263faa
263faa
%if %{WITH_MONO}
263faa
%package sharp
263faa
Summary:          Mono language bindings for avahi mono development
263faa
Requires:         mono-core >= 1.1.13
263faa
Conflicts:        %{name} < %{version}-%{release}
263faa
Conflicts:        %{name} > %{version}-%{release}
263faa
Requires:         %{name}-libs = %{version}-%{release}
263faa
263faa
%description sharp
263faa
The avahi-sharp package contains the files needed to develop
263faa
mono programs that use avahi.
263faa
263faa
%package ui-sharp
263faa
Summary:          Mono language bindings for avahi-ui
263faa
Conflicts:        %{name} < %{version}-%{release}
263faa
Conflicts:        %{name} > %{version}-%{release}
263faa
Requires:         %{name}-libs = %{version}-%{release}
263faa
Requires:         %{name}-ui = %{version}-%{release}
263faa
Requires:         %{name}-sharp = %{version}-%{release}
263faa
Requires:         mono-core >= 1.1.13
263faa
Requires:         gtk-sharp2
263faa
BuildRequires:    gtk-sharp2-devel
263faa
263faa
%description ui-sharp
263faa
The avahi-sharp package contains the files needed to run
263faa
Mono programs that use avahi-ui.
263faa
263faa
%package ui-sharp-devel
263faa
Summary:          Mono language bindings for developing with avahi-ui
263faa
Requires:         %{name}-libs = %{version}-%{release}
263faa
Requires:         %{name}-ui-sharp = %{version}-%{release}
263faa
263faa
%description ui-sharp-devel
263faa
The avahi-sharp-ui-devel package contains the files needed to develop
263faa
Mono programs that use avahi-ui.
263faa
%endif
263faa
263faa
%package libs
263faa
Summary:          Libraries for avahi run-time use
263faa
263faa
%description libs
263faa
The avahi-libs package contains the libraries needed
263faa
to run programs that use avahi.
263faa
263faa
%package devel
263faa
Summary:          Libraries and header files for avahi development
263faa
Requires:         %{name}-libs = %{version}-%{release}
263faa
Requires:         pkgconfig
263faa
263faa
%description devel
263faa
The avahi-devel package contains the header files and libraries
263faa
necessary for developing programs using avahi.
263faa
263faa
%if %{WITH_COMPAT_HOWL}
263faa
%package compat-howl
263faa
Summary:          Libraries for howl compatibility
263faa
Conflicts:        %{name} < %{version}-%{release}
263faa
Conflicts:        %{name} > %{version}-%{release}
263faa
Requires:         %{name}-libs = %{version}-%{release}
263faa
Obsoletes:        howl-libs
263faa
Provides:         howl-libs
263faa
263faa
%description compat-howl
263faa
Libraries that are compatible with those provided by the howl package.
263faa
263faa
%package compat-howl-devel
263faa
Summary:          Header files for development with the howl compatibility libraries
263faa
Requires:         %{name}-libs = %{version}-%{release}
263faa
Requires:         %{name}-devel = %{version}-%{release}
263faa
Requires:         %{name}-compat-howl = %{version}-%{release}
263faa
Obsoletes:        howl-devel
263faa
Provides:         howl-devel
263faa
263faa
%description compat-howl-devel
263faa
Header files for development with the howl compatibility libraries.
263faa
%endif
263faa
263faa
%if %{WITH_COMPAT_DNSSD}
263faa
%package compat-libdns_sd
263faa
Summary:          Libraries for Apple Bonjour mDNSResponder compatibility
263faa
Conflicts:        %{name} < %{version}-%{release}
263faa
Conflicts:        %{name} > %{version}-%{release}
263faa
Requires:         %{name}-libs = %{version}-%{release}
263faa
263faa
%description compat-libdns_sd
263faa
Libraries for Apple Bonjour mDNSResponder compatibility.
263faa
263faa
%package compat-libdns_sd-devel
263faa
Summary:          Header files for the Apple Bonjour mDNSResponder compatibility libraries
263faa
Requires:         %{name}-libs = %{version}-%{release}
263faa
Requires:         %{name}-devel = %{version}-%{release}
263faa
Requires:         %{name}-compat-libdns_sd = %{version}-%{release}
263faa
263faa
%description compat-libdns_sd-devel
263faa
Header files for development with the Apple Bonjour mDNSResponder compatibility
263faa
libraries.
263faa
%endif
263faa
263faa
%package autoipd
263faa
Summary:          Link-local IPv4 address automatic configuration daemon (IPv4LL)
263faa
Requires(pre):    shadow-utils
263faa
Conflicts:        %{name} < %{version}-%{release}
263faa
Conflicts:        %{name} > %{version}-%{release}
263faa
Requires:         %{name}-libs = %{version}-%{release}
263faa
263faa
%description autoipd
263faa
avahi-autoipd implements IPv4LL, "Dynamic Configuration of IPv4
263faa
Link-Local Addresses"  (IETF RFC3927), a protocol for automatic IP address
263faa
configuration from the link-local 169.254.0.0/16 range without the need for a
263faa
central server. It is primarily intended to be used in ad-hoc networks which
263faa
lack a DHCP server.
263faa
263faa
%package dnsconfd
263faa
Summary:          Configure local unicast DNS settings based on information published in mDNS
263faa
Requires:         %{name} = %{version}-%{release}
263faa
Requires:         %{name}-libs = %{version}-%{release}
263faa
263faa
%description dnsconfd
263faa
avahi-dnsconfd connects to a running avahi-daemon and runs the script
263faa
/etc/avahi/dnsconfd.action for each unicast DNS server that is announced on the
263faa
local LAN. This is useful for configuring unicast DNS servers in a DHCP-like
263faa
fashion with mDNS.
263faa
263faa
%prep
263faa
%autosetup -S git
263faa
263faa
%build
263faa
autoreconf -fi
263faa
%configure \
263faa
        --with-distro=fedora \
263faa
        --disable-monodoc \
263faa
        --with-avahi-user=avahi \
263faa
        --with-avahi-group=avahi \
263faa
        --with-avahi-priv-access-group=avahi \
263faa
        --with-autoipd-user=avahi-autoipd \
263faa
        --with-autoipd-group=avahi-autoipd \
263faa
        --with-systemdsystemunitdir=/usr/lib/systemd/system \
263faa
        --enable-introspection=no \
263faa
%if %{WITH_COMPAT_DNSSD}
263faa
        --enable-compat-libdns_sd \
263faa
%endif
263faa
%if %{WITH_COMPAT_HOWL}
263faa
        --enable-compat-howl \
263faa
%endif
263faa
%if ! %{WITH_MONO}
263faa
        --disable-mono \
263faa
%endif
263faa
;
263faa
/usr/bin/make %{?_smp_mflags}
263faa
263faa
%install
263faa
%make_install
263faa
/usr/bin/find %{buildroot} \( -name '*.a' -o -name '*.la' \) -exec rm {} \;
263faa
263faa
# remove example
263faa
/usr/bin/rm -f %{buildroot}%{_sysconfdir}/avahi/services/ssh.service
263faa
/usr/bin/rm -f %{buildroot}%{_sysconfdir}/avahi/services/sftp-ssh.service
263faa
263faa
# remove avahi-discover-standalone
263faa
rm -f $RPM_BUILD_ROOT%{_bindir}/avahi-discover-standalone
263faa
263faa
# create /var/run/avahi-daemon to ensure correct selinux policy for it:
263faa
/usr/bin/mkdir -p %{buildroot}%{_localstatedir}/run/avahi-daemon
263faa
/usr/bin/mkdir -p %{buildroot}%{_localstatedir}/lib/avahi-autoipd
263faa
263faa
# remove the documentation directory - let % doc handle it:
263faa
/usr/bin/rm -rf %{buildroot}%{_datadir}/%{name}-%{version}
263faa
263faa
# Make /etc/avahi/etc/localtime owned by avahi:
263faa
/usr/bin/mkdir -p %{buildroot}/etc/avahi/etc
263faa
/usr/bin/touch %{buildroot}/etc/avahi/etc/localtime
263faa
263faa
# fix bug 197414 - add missing symlinks for avahi-compat-howl and avahi-compat-dns-sd
263faa
%if %{WITH_COMPAT_HOWL}
263faa
/usr/bin/ln -s avahi-compat-howl.pc  %{buildroot}/%{_libdir}/pkgconfig/howl.pc
263faa
%endif
263faa
%if %{WITH_COMPAT_DNSSD}
263faa
/usr/bin/ln -s avahi-compat-libdns_sd.pc %{buildroot}/%{_libdir}/pkgconfig/libdns_sd.pc
263faa
/usr/bin/ln -s avahi-compat-libdns_sd/dns_sd.h %{buildroot}/%{_includedir}/
263faa
%endif
263faa
263faa
/usr/bin/rm -f %{buildroot}%{_sysconfdir}/rc.d/init.d/avahi-daemon
263faa
/usr/bin/rm -f %{buildroot}%{_sysconfdir}/rc.d/init.d/avahi-dnsconfd
263faa
263faa
%find_lang %{name}
263faa
263faa
%pre
263faa
/usr/bin/getent group avahi >/dev/null 2>&1 || /usr/sbin/groupadd \
263faa
        -r \
263faa
        -g 70 \
263faa
        avahi >/dev/null 2>&1 || :
263faa
/usr/bin/getent passwd avahi >/dev/null 2>&1 || /usr/sbin/useradd \
263faa
        -r -l \
263faa
        -u 70 \
263faa
        -g avahi \
263faa
        -d %{_localstatedir}/run/avahi-daemon \
263faa
        -s /sbin/nologin \
263faa
        -c "Avahi mDNS/DNS-SD Stack" \
263faa
        avahi >/dev/null 2>&1 || :
263faa
263faa
%post
263faa
/sbin/ldconfig >/dev/null 2>&1 || :
263faa
/usr/bin/dbus-send --system --type=method_call --dest=org.freedesktop.DBus / org.freedesktop.DBus.ReloadConfig >/dev/null 2>&1 || :
263faa
if [ "$1" -eq 1 -a -s /etc/localtime ]; then
263faa
        /usr/bin/cp -cfp /etc/localtime /etc/avahi/etc/localtime >/dev/null 2>&1 || :
263faa
fi
263faa
%systemd_post avahi-daemon.socket avahi-daemon.service
263faa
263faa
%preun
263faa
%systemd_preun avahi-daemon.socket avahi-daemon.service
263faa
263faa
%postun
263faa
/sbin/ldconfig >/dev/null 2>&1 || :
263faa
%systemd_postun_with_restart avahi-daemon.socket avahi-daemon.service
263faa
263faa
%triggerun -- avahi < 0.6.28-1
263faa
/usr/bin/systemd-sysv-convert --save avahi-daemon >/dev/null 2>&1 || :
263faa
/usr/bin/systemctl --no-reload enable avahi-daemon.service >/dev/null 2>&1 || :
263faa
/usr/bin/systemctl try-restart avahi-daemon.service >/dev/null 2>&1 || :
263faa
263faa
%pre autoipd
263faa
/usr/bin/getent group avahi-autoipd >/dev/null 2>&1 || /usr/sbin/groupadd \
263faa
        -r \
263faa
        -g 170 \
263faa
        avahi-autoipd >/dev/null 2>&1 || :
263faa
/usr/bin/getent passwd avahi-autoipd >/dev/null 2>&1 || /usr/sbin/useradd \
263faa
        -r -l \
263faa
        -u 170 \
263faa
        -g avahi-autoipd \
263faa
        -d %{_localstatedir}/lib/avahi-autoipd \
263faa
        -s /sbin/nologin \
263faa
        -c "Avahi IPv4LL Stack" \
263faa
        avahi-autoipd >/dev/null 2>&1 || :
263faa
:;
263faa
263faa
%post dnsconfd
263faa
%systemd_post avahi-dnsconfd.service
263faa
263faa
%preun dnsconfd
263faa
%systemd_preun avahi-dnsconfd.service
263faa
263faa
%postun dnsconfd
263faa
%systemd_postun_with_restart avahi-dnsconfd.service
263faa
263faa
%triggerun dnsconfd -- avahi-dnsconfd < 0.6.28-1
263faa
/usr/bin/systemd-sysv-convert --save avahi-dnsconfd >/dev/null 2>&1 || :
263faa
/usr/bin/systemctl --no-reload enable avahi-dnsconfd.service >/dev/null 2>&1 || :
263faa
/usr/bin/systemctl try-restart avahi-dnsconfd.service >/dev/null 2>&1 || :
263faa
263faa
%post glib -p /sbin/ldconfig
263faa
%postun glib -p /sbin/ldconfig
263faa
263faa
%post compat-howl -p /sbin/ldconfig
263faa
%postun compat-howl -p /sbin/ldconfig
263faa
263faa
%post compat-libdns_sd -p /sbin/ldconfig
263faa
%postun compat-libdns_sd -p /sbin/ldconfig
263faa
263faa
%post libs -p /sbin/ldconfig
263faa
%postun libs -p /sbin/ldconfig
263faa
263faa
%post qt3 -p /sbin/ldconfig
263faa
%postun qt3 -p /sbin/ldconfig
263faa
263faa
%post qt4 -p /sbin/ldconfig
263faa
%postun qt4 -p /sbin/ldconfig
263faa
263faa
%post ui -p /sbin/ldconfig
263faa
%postun ui -p /sbin/ldconfig
263faa
263faa
%post ui-gtk3 -p /sbin/ldconfig
263faa
%postun ui-gtk3 -p /sbin/ldconfig
263faa
263faa
%post gobject -p /sbin/ldconfig
263faa
%postun gobject -p /sbin/ldconfig
263faa
263faa
%files -f %{name}.lang
263faa
%doc docs/* avahi-daemon/example.service avahi-daemon/sftp-ssh.service avahi-daemon/ssh.service
263faa
%dir %{_sysconfdir}/avahi
263faa
%dir %{_sysconfdir}/avahi/etc
263faa
%ghost %{_sysconfdir}/avahi/etc/localtime
263faa
%config(noreplace) %{_sysconfdir}/avahi/hosts
263faa
%dir %{_sysconfdir}/avahi/services
263faa
%ghost %dir %{_localstatedir}/run/avahi-daemon
263faa
%config(noreplace) %{_sysconfdir}/avahi/avahi-daemon.conf
263faa
%config(noreplace) %{_sysconfdir}/dbus-1/system.d/avahi-dbus.conf
263faa
%{_sbindir}/avahi-daemon
263faa
%dir %{_datadir}/avahi
263faa
%{_datadir}/avahi/*.dtd
263faa
%{_datadir}/avahi/service-types
263faa
%dir %{_libdir}/avahi
263faa
%{_libdir}/avahi/service-types.db
263faa
%{_datadir}/dbus-1/interfaces/*.xml
263faa
%{_mandir}/man5/*
263faa
%{_mandir}/man8/avahi-daemon.*
263faa
%{_unitdir}/avahi-daemon.service
263faa
%{_unitdir}/avahi-daemon.socket
263faa
%{_datadir}/dbus-1/system-services/org.freedesktop.Avahi.service
263faa
%{_libdir}/libavahi-core.so.*
263faa
263faa
%files autoipd
263faa
%{_sbindir}/avahi-autoipd
263faa
%config(noreplace) %{_sysconfdir}/avahi/avahi-autoipd.action
263faa
%attr(1770,avahi-autoipd,avahi-autoipd) %dir %{_localstatedir}/lib/avahi-autoipd/
263faa
%{_mandir}/man8/avahi-autoipd.*
263faa
263faa
%files dnsconfd
263faa
%config(noreplace) %{_sysconfdir}/avahi/avahi-dnsconfd.action
263faa
%{_sbindir}/avahi-dnsconfd
263faa
%{_mandir}/man8/avahi-dnsconfd.*
263faa
%{_unitdir}/avahi-dnsconfd.service
263faa
263faa
%files tools
263faa
%{_bindir}/*
263faa
%{_mandir}/man1/*
263faa
%exclude %{_bindir}/b*
263faa
%exclude %{_bindir}/avahi-discover*
263faa
%exclude %{_bindir}/avahi-bookmarks
263faa
%exclude %{_mandir}/man1/b*
263faa
%exclude %{_mandir}/man1/avahi-discover*
263faa
%exclude %{_mandir}/man1/avahi-bookmarks*
263faa
263faa
%files ui-tools
263faa
%{_bindir}/b*
263faa
%{_bindir}/avahi-discover
263faa
# avahi-bookmarks is not really a UI tool, but I won't create a seperate package for it...
263faa
%{_bindir}/avahi-bookmarks
263faa
%{_mandir}/man1/b*
263faa
%{_mandir}/man1/avahi-discover*
263faa
%{_mandir}/man1/avahi-bookmarks*
263faa
%{_datadir}/applications/b*.desktop
263faa
%{_datadir}/applications/avahi-discover.desktop
263faa
# These are .py files only, so they don't go in lib64
263faa
%{_prefix}/lib/python?.?/site-packages/*
263faa
%{_datadir}/avahi/interfaces/
263faa
263faa
%files devel
263faa
%{_libdir}/libavahi-common.so
263faa
%{_libdir}/libavahi-core.so
263faa
%{_libdir}/libavahi-client.so
263faa
%{_includedir}/avahi-client
263faa
%{_includedir}/avahi-common
263faa
%{_includedir}/avahi-core
263faa
%{_libdir}/pkgconfig/avahi-core.pc
263faa
%{_libdir}/pkgconfig/avahi-client.pc
263faa
263faa
%files libs
263faa
%{_libdir}/libavahi-common.so.*
263faa
%{_libdir}/libavahi-client.so.*
263faa
263faa
%files glib
263faa
%{_libdir}/libavahi-glib.so.*
263faa
263faa
%files glib-devel
263faa
%{_libdir}/libavahi-glib.so
263faa
%{_includedir}/avahi-glib
263faa
%{_libdir}/pkgconfig/avahi-glib.pc
263faa
263faa
%files gobject
263faa
%{_libdir}/libavahi-gobject.so.*
263faa
#%{_libdir}/girepository-1.0/Avahi-0.6.typelib
263faa
#%{_libdir}/girepository-1.0/AvahiCore-0.6.typelib
263faa
263faa
%files gobject-devel
263faa
%{_libdir}/libavahi-gobject.so
263faa
%{_includedir}/avahi-gobject
263faa
%{_libdir}/pkgconfig/avahi-gobject.pc
263faa
#%{_datadir}/gir-1.0/Avahi-0.6.gir
263faa
#%{_datadir}/gir-1.0/AvahiCore-0.6.gir
263faa
263faa
%files ui
263faa
%{_libdir}/libavahi-ui.so.*
263faa
263faa
%files ui-gtk3
263faa
%{_libdir}/libavahi-ui-gtk3.so.*
263faa
263faa
%files ui-devel
263faa
%{_libdir}/libavahi-ui.so
263faa
%{_libdir}/libavahi-ui-gtk3.so
263faa
%{_includedir}/avahi-ui
263faa
%{_libdir}/pkgconfig/avahi-ui.pc
263faa
%{_libdir}/pkgconfig/avahi-ui-gtk3.pc
263faa
263faa
%files qt3
263faa
%{_libdir}/libavahi-qt3.so.*
263faa
263faa
%files qt3-devel
263faa
%{_libdir}/libavahi-qt3.so
263faa
%{_includedir}/avahi-qt3/
263faa
%{_libdir}/pkgconfig/avahi-qt3.pc
263faa
263faa
%files qt4
263faa
%{_libdir}/libavahi-qt4.so.*
263faa
263faa
%files qt4-devel
263faa
%{_libdir}/libavahi-qt4.so
263faa
%{_includedir}/avahi-qt4/
263faa
%{_libdir}/pkgconfig/avahi-qt4.pc
263faa
263faa
%if %{WITH_MONO}
263faa
%files sharp
263faa
%{_prefix}/lib/mono/avahi-sharp
263faa
%{_prefix}/lib/mono/gac/avahi-sharp
263faa
%{_libdir}/pkgconfig/avahi-sharp.pc
263faa
263faa
%files ui-sharp
263faa
%{_prefix}/lib/mono/avahi-ui-sharp
263faa
%{_prefix}/lib/mono/gac/avahi-ui-sharp
263faa
263faa
%files ui-sharp-devel
263faa
%{_libdir}/pkgconfig/avahi-ui-sharp.pc
263faa
%endif
263faa
263faa
%if %{WITH_COMPAT_HOWL}
263faa
%files compat-howl
263faa
%{_libdir}/libhowl.so.*
263faa
263faa
%files compat-howl-devel
263faa
%{_libdir}/libhowl.so
263faa
%{_includedir}/avahi-compat-howl
263faa
%{_libdir}/pkgconfig/avahi-compat-howl.pc
263faa
%{_libdir}/pkgconfig/howl.pc
263faa
%endif
263faa
263faa
%if %{WITH_COMPAT_DNSSD}
263faa
%files compat-libdns_sd
263faa
%{_libdir}/libdns_sd.so.*
263faa
263faa
%files compat-libdns_sd-devel
263faa
%{_libdir}/libdns_sd.so
263faa
%{_includedir}/avahi-compat-libdns_sd
263faa
%{_includedir}/dns_sd.h
263faa
%{_libdir}/pkgconfig/avahi-compat-libdns_sd.pc
263faa
%{_libdir}/pkgconfig/libdns_sd.pc
263faa
%endif
263faa
263faa
%changelog
263faa
* Thu Nov 09 2017 Michal Sekletar <msekleta@redhat.com> - 0.6.31-19
263faa
- exclude avahi-discover from avahi-tools package (#1421229)
263faa
263faa
* Tue Nov 07 2017 Michal Sekletar <msekleta@redhat.com> - 0.6.31-18
263faa
- create home directory for avahi-autoipd user (#1416287)
263faa
- get rid of the dangling symlink to avahi-discover in debuginfo package (#1421229)
263faa
263faa
* Mon Jul 04 2016 Michal Sekletar <msekleta@redhat.com> - 0.6.31-17
263faa
- fix crash due to use of deprecated Gtk3 API (#1263720)
263faa
- don't add 0pointer.de and zeroconf.org to default browse list (#1340837)
263faa
- fix not publishing entries if a probing interface is removed (#1222646)
263faa
263faa
* Thu Dec 17 2015 Michal Sekletar <msekleta@redhat.com> - 0.6.31-16
263faa
- silently ignore non-valid DNS response packets (#1290890)
263faa
263faa
* Tue Apr 21 2015 Michal Sekletar <msekleta@redhat.com> - 0.6.31-15
263faa
- enable hardened build (#1092506)
263faa
- fix short option for --version, document -t option of avahi-autoipd (#948583)
263faa
- fix crashes in D-Bus methods GetAlternativeHostName and GetAlternativeServiceName (#1003688)
263faa
- fix bug when avahi-daemon ended up in a tight loop (#1081801)
263faa
- remove prefix /home/lennart/tmp/avahi from references in man pages (#1120233)
263faa
263faa
* Mon Dec  8 2014 Michal Sekletar <msekleta@redhat.com> - 0.6.31-14
263faa
- remove dependency on the main package from avahi-libs (#1170681)
263faa
263faa
* Fri Jan 24 2014 Daniel Mach <dmach@redhat.com> - 0.6.31-13
263faa
- Mass rebuild 2014-01-24
263faa
263faa
* Fri Dec 27 2013 Daniel Mach <dmach@redhat.com> - 0.6.31-12
263faa
- Mass rebuild 2013-12-27
263faa
263faa
* Sat Feb 02 2013 Kalev Lember <kalevlember@gmail.com> - 0.6.31-11
263faa
- Correct a typo in inter-subpackage deps
263faa
263faa
* Fri Feb  1 2013 Matthias Clasen <mclasen@redhat.com> - 0.6.31-10
263faa
- Tighten inter-subpackage deps
263faa
263faa
* Fri Jan 18 2013 Adam Tkac <atkac redhat com> - 0.6.31-9
263faa
- rebuild due to "jpeg8-ABI" feature drop
263faa
263faa
* Fri Dec 21 2012 Adam Tkac <atkac redhat com> - 0.6.31-8
263faa
- fix path to ldconfig
263faa
263faa
* Fri Dec 21 2012 Adam Tkac <atkac redhat com> - 0.6.31-7
263faa
- rebuild against new libjpeg
263faa
263faa
* Tue Aug  7 2012 Lennart Poettering <lpoetter@redhat.com> - 0.6.31-6
263faa
- Use new systemd macros
263faa
- Other modernizations
263faa
263faa
* Mon Aug 6 2012 Stef Walter <stefw@redhat.com> - 0.6.31-5
263faa
- Don't ship ssh service by default file since openssh-server isn't
263faa
  running by default, and shouldn't be advertised without user
263faa
  confirmation.
263faa
263faa
* Wed Jul 18 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.31-4
263faa
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
263faa
263faa
* Mon May 21 2012 Peter Robinson <pbrobinson@fedoraproject.org> - 0.6.31-3
263faa
- Merge F-17 into master
263faa
- ARM has mono
263faa
263faa
* Tue Feb 14 2012 Lennart Poettering <lpoetter@redhat.com> - 0.6.31-2
263faa
- Fix tarball
263faa
263faa
* Tue Feb 14 2012 Lennart Poettering <lpoetter@redhat.com> - 0.6.31-1
263faa
- New upstream release
263faa
263faa
* Thu Jan 12 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.30-7
263faa
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
263faa
263faa
* Tue Nov 29 2011 Christian Krause <chkr@fedoraproject.org> - 0.6.30-6
263faa
- Change paths for mono assemblies according to updated packaging
263faa
  guidelines (http://fedoraproject.org/wiki/Packaging:Mono)
263faa
263faa
* Mon Nov 14 2011 Adam Jackson <ajax@redhat.com> 0.6.30-5
263faa
- Rebuild to break bogus libpng dep
263faa
263faa
* Mon Aug 22 2011 Lennart Poettering <lpoetter@redhat.com> - 0.6.30-4
263faa
- Remove sysv init script (#714649)
263faa
263faa
* Thu May  5 2011 Bill Nottingham <notting@redhat.com> - 0.6.30-3
263faa
- fix versioning on triggers
263faa
263faa
* Tue May  3 2011 Lennart Poettering <lpoetter@redhat.com> - 0.6.30-2
263faa
- Enable Avahi by default
263faa
- https://bugzilla.redhat.com/show_bug.cgi?id=647831
263faa
263faa
* Mon Apr  4 2011 Lennart Poettering <lpoetter@redhat.com> - 0.6.30-1
263faa
- New upstream release
263faa
263faa
* Wed Mar  9 2011 Lennart Poettering <lpoetter@redhat.com> - 0.6.29-1
263faa
- New upstream release
263faa
- Fixes CVE-2011-1002 among other things
263faa
263faa
* Thu Feb 10 2011 Matthias Clasen <mclasen@redhat.com> - 0.6.28-9
263faa
- Rebuild against new gtk
263faa
263faa
* Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.28-8
263faa
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
263faa
263faa
* Wed Feb 2 2011 Matthias Clasen <mclasen@redhat.com> - 0.6.28-7
263faa
- Rebuild against new gtk
263faa
263faa
* Fri Jan  7 2011 Matthias Clasen <mclasen@redhat.com> - 0.6.28-6
263faa
- Rebuild against new gtk
263faa
263faa
* Fri Dec  3 2010 Matthias Clasen <mclasen@redhat.com> - 0.6.28-5
263faa
- Rebuild against new gtk
263faa
263faa
* Wed Nov 24 2010 Dan HorĂ¡k <dan[at]danny.cz> - 0.6.28-4
263faa
- Updated the archs without mono
263faa
263faa
* Tue Nov  2 2010 Matthias Clasen <mclasen@redhat.com> - 0.6.28-3
263faa
- Rebuild against newer gtk3
263faa
263faa
* Wed Oct 27 2010 paul <paul@all-the-johnsons.co.uk> - 0.6.28-2
263faa
- rebuilt
263faa
263faa
* Tue Oct  5 2010 Lennart Poettering <lpoetter@redhat.com> - 0.6.28-1
263faa
- New upstream release
263faa
263faa
* Wed Aug  4 2010 Lennart Poettering <lpoetter@redhat.com> - 0.6.27-3
263faa
- convert from systemd-install to systemctl enable
263faa
263faa
* Wed Jul 21 2010 David Malcolm <dmalcolm@redhat.com> - 0.6.27-2
263faa
- Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
263faa
263faa
* Tue Jul 13 2010 Lennart Poettering <lpoetter@redhat.com> 0.6.27-1
263faa
- New upstream release
263faa
263faa
* Tue Jun 29 2010 Lennart Poettering <lpoetter@redhat.com> 0.6.26-4
263faa
- On request of Colin Walters, disable introspection again for now.
263faa
263faa
* Tue Jun 29 2010 Lennart Poettering <lpoetter@redhat.com> 0.6.26-3
263faa
- Fix systemd unit installation
263faa
263faa
* Tue Jun 29 2010 Lennart Poettering <lpoetter@redhat.com> 0.6.26-2
263faa
- Add missing dependencies
263faa
263faa
* Tue Jun 29 2010 Lennart Poettering <lpoetter@redhat.com> 0.6.26-1
263faa
- New upstream release
263faa
263faa
* Mon Apr 19 2010 Bastien Nocera <bnocera@redhat.com> 0.6.25-7
263faa
- Split avahi libraries in -libs
263faa
263faa
* Mon Jan 25 2010 Lennart Poettering <lpoetter@redhat.com> - 0.6.25-6
263faa
- Move avahi-discover from avahi-tools to avahi-ui-tools
263faa
- https://bugzilla.redhat.com/show_bug.cgi?id=513768
263faa
263faa
* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.25-5
263faa
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
263faa
263faa
* Wed Jun 17 2009 Karsten Hopp <karsten@redhat.com> 0.6.25-4
263faa
- Build *-sharp & *-ui-sharp for s390x
263faa
263faa
* Thu Jun 11 2009 Matthias Clasen <mclasen@redhat.com> - 0.6.25-4
263faa
- Use %%find_lang
263faa
263faa
* Tue May 26 2009 Michael Schwendt <mschwendt@fedoraproject.org> - 0.6.25-3
263faa
- Create avahi-ui-sharp-devel package for pkgconfig dep-chain (#477308).
263faa
263faa
* Mon May 25 2009 Xavier Lamien <laxathom@fedoraproject.org> - 0.6.25-2
263faa
- Build arch ppc64 for *-sharp & *-ui-sharp.
263faa
263faa
* Mon Apr 13 2009 Lennart Poettering <lpoetter@redhat.com> - 0.6.25-1
263faa
- New upstream release
263faa
263faa
* Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.24-2
263faa
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
263faa
263faa
* Fri Dec 12 2008 Lennart Poettering <lpoetter@redhat.com> - 0.6.24-1
263faa
- New upstream release
263faa
263faa
* Wed Dec  3 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 0.6.22-13
263faa
- Fix libtool errors
263faa
263faa
* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 0.6.22-12
263faa
- Rebuild for Python 2.6
263faa
263faa
* Wed Jun 04 2008 Rex Dieter <rdieter@fedoraproject.org> - 0.6.22-11
263faa
- qt4 bindings (#446904)
263faa
- devel: BR: pkgconfig
263faa
- nuke rpaths
263faa
263faa
* Thu Mar 27 2008 Lennart Poettering <lpoetter@redhat.com> - 0.6.22-10
263faa
- Add release part to package dependencies (Closed #311601)
263faa
263faa
* Mon Mar 10 2008 Christopher Aillon <caillon@redhat.com> - 0.6.22-9
263faa
- The qt3 subpackage should (Build)Require: qt3
263faa
263faa
* Mon Mar 03 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> - 0.6.22-8
263faa
- updated (completed) German translation by Fabian Affolter (#427090)
263faa
263faa
* Thu Feb 21 2008 Adam Tkac <atkac redhat com> - 0.6.22-7
263faa
- really rebuild against new libcap
263faa
263faa
* Sun Feb 17 2008 Adam Tkac <atkac redhat com> - 0.6.22-6
263faa
- rebuild against new libcap
263faa
263faa
* Sat Feb 09 2008 Dennis Gilmore <dennis@ausil.us> - 0.6.22-5
263faa
- sparc64 does not have mono
263faa
263faa
* Tue Dec 18 2007 Lubomir Kundrak <lkundrak@redhat.com> - 0.6.22-4
263faa
- Make bvnc call vncviewer instead of xvncviewer
263faa
- Let ui-tools depend on necessary packages
263faa
263faa
* Mon Dec 17 2007 Lennart Poettering <lpoetter@redhat.com> - 0.6.22-3
263faa
- Add missing intltool dependency
263faa
263faa
* Mon Dec 17 2007 Lennart Poettering <lpoetter@redhat.com> - 0.6.22-2
263faa
- Fix mistag
263faa
263faa
* Mon Dec 17 2007 Lennart Poettering <lpoetter@redhat.com> - 0.6.22-1
263faa
- resolves #274731, #425491: New upstream version
263faa
263faa
* Tue Sep 25 2007 Lennart Poettering <lpoetter@redhat.com> - 0.6.21-6
263faa
- resolves #279301: fix segfault when no domains are configured in resolv.conf (pulled from upstream SVN r1525)
263faa
263faa
* Thu Sep 6 2007 Lennart Poettering <lpoetter@redhat.com> - 0.6.21-5
263faa
- resolves #249044: Update init script to use runlevel 96
263faa
- resolves #251700: Fix assertion in libdns_sd-compat
263faa
263faa
* Thu Sep 6 2007 Lennart Poettering <lpoetter@redhat.com> - 0.6.21-4
263faa
- Ship ssh static service file by default, don't ship ssh-sftp by default
263faa
- resolves: #269741: split off avahi-ui-tools package
263faa
- resolves: #253734: add missing dependency on avahi-glib-devel to avahi-ui-devel
263faa
263faa
* Tue Aug 28 2007 Martin Bacovsky <mbacovsk@redhat.com> - 0.6.21-3
263faa
- resolves: #246875: Initscript Review
263faa
263faa
* Sun Aug 12 2007 Lennart Poettering <lpoetter@redhat.com> - 0.6.21-2
263faa
- Fix avahi-browse --help output
263faa
263faa
* Sun Aug 12 2007 Lennart Poettering <lpoetter@redhat.com> - 0.6.21-1
263faa
- New upstream release
263faa
263faa
* Thu Aug 9 2007 Lennart Poettering <lpoetter@redhat.com> - 0.6.20-7
263faa
- Fix tagging borkage
263faa
263faa
* Thu Aug 9 2007 Lennart Poettering <lpoetter@redhat.com> - 0.6.20-6
263faa
- fix avahi-autoipd corrupt packet bug
263faa
- drop dependency on python for the main package
263faa
263faa
* Wed Jul 11 2007 Lennart Poettering <lpoetter@redhat.com> - 0.6.20-5
263faa
- add two patches which are important to get RR updating work properly.
263faa
  Will be part of upstream 0.6.21
263faa
263faa
* Thu Jul  5 2007 Dan Williams <dcbw@redhat.com> - 0.6.20-4
263faa
- Add Requires(pre): shadow-utils for avahi-autoipd package
263faa
263faa
* Mon Jun 25 2007 Bill Nottingham <notting@redhat.com> - 0.6.20-3
263faa
- fix %%endif typo
263faa
263faa
* Mon Jun 25 2007 Lennart Poettering <lpoetter@redhat.com> - 0.6.20-2
263faa
- add gtk-sharp2-devel to build deps
263faa
263faa
* Fri Jun 22 2007 Lennart Poettering <lpoetter@redhat.com> - 0.6.20-1
263faa
- upgrade to new upstream 0.6.20
263faa
- fix a few rpmlint warnings
263faa
- create avahi-autoipd user
263faa
- no longer create avahi user with a static uid, move to dynamic uids
263faa
- drop a couple of patches merged upstream
263faa
- Provide "howl" and "howl-devel"
263faa
- Split off avahi-autoipd and avahi-dnsconfd
263faa
- Introduce avahi-ui packages for the first time
263faa
- Reload D-Bus config after installation using dbus-send
263faa
- add a couple of missing ldconfig invocations
263faa
263faa
* Mon Mar 12 2007 Martin Bacovsky <mbacovsk@redhat.com> - 0.6.17-1
263faa
- upgrade to new upstream 0.6.17
263faa
- redundant patches removal
263faa
- removed auto* stuff from specfile since that was no longer needed
263faa
- Resolves: #232205: 'service {avahi-dnsconfd,avahi-daemon} status'
263faa
  returns 0 when the service is stopped
263faa
263faa
* Fri Feb  2 2007 Christopher Aillon <cailloN@redhat.com> - 0.6.16-3
263faa
- Remove bogus mono-libdir patches
263faa
263faa
* Tue Jan 23 2007 Jeremy Katz <katzj@redhat.com> - 0.6.16-2
263faa
- nuke bogus avahi-sharp -> avahi-devel dep
263faa
263faa
* Mon Jan 22 2007 Martin Bacovsky <mbacovsk@redhat.com> - 0.6.16-1.fc7
263faa
- Resolves: #221763: CVE-2006-6870 Maliciously crafted packed can DoS avahi daemon
263faa
- upgrade to new upstream
263faa
- patch revision
263faa
- Resolves: #218140: avahi configuration file wants a non-existent group
263faa
263faa
* Wed Dec  6 2006 Jeremy Katz <katzj@redhat.com> - 0.6.15-4
263faa
- rebuild against python 2.5
263faa
263faa
* Mon Nov 27 2006 Martin Bacovsky <mbacovsk@redhat.com> - 0.6.15-3
263faa
- automake-1.10 required for building
263faa
263faa
* Mon Nov 27 2006 Martin Bacovsky <mbacovsk@redhat.com> - 0.6.15-2
263faa
- automake-1.9 required for building
263faa
263faa
* Thu Nov 24 2006 Martin Bacovsky <mbacovsk@redhat.com> - 0.6.15-1
263faa
- Upgrade to 0.6.15
263faa
- patches revision
263faa
263faa
* Mon Sep 18 2006 Martin Stransky <stransky@redhat.com> - 0.6.11-6
263faa
- added patch from #206445 - ia64: unaligned access errors seen
263faa
  during startup of avahi-daemon
263faa
- removed unused patches
263faa
263faa
* Thu Sep 7 2006 Dan Walsh <dwalsh@redhat.com> - 0.6.11-5
263faa
- Maintain the security context on the localtime file
263faa
263faa
* Wed Aug 23 2006 Martin Stransky <stransky@redhat.com> - 0.6.11-4
263faa
- fix for #204710 - /etc/init.d/avahi-dnsconfd missing line
263faa
  continuation slash (\) in description
263faa
263faa
* Wed Aug 23 2006 Martin Stransky <stransky@redhat.com> - 0.6.11-3
263faa
- added fix for #200767 - avahi-dnsconfd Segmentation fault
263faa
  with invalid command line argument
263faa
- added dist tag
263faa
263faa
* Tue Jul 18 2006 John (J5) Palmieri <johnp@redhat.com> - 0.6.11-2.fc6
263faa
- add BR for dbus-glib-devel
263faa
- fix deprecated functions
263faa
263faa
* Mon Jul 17 2006 Jason Vas Dias <jvdias@redhat.com> - 0.6.11-1.fc6
263faa
- Upgrade to upstream version 0.6.11
263faa
- fix bug 195674: set 'use-ipv6=yes' in avahi-daemon.conf
263faa
- fix bug 197414: avahi-compat-howl and avahi-compat-dns-sd symlinks
263faa
- fix bug 198282: avahi-compat-{howl-devel,dns-sd-devel} Requires:
263faa
263faa
* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com>
263faa
- rebuild
263faa
263faa
* Tue Jun 13 2006 Jason Vas Dias <jvdias@redhat.com> - 0.6.10-3.FC6
263faa
- rebuild for broken mono deps
263faa
263faa
* Tue Jun 06 2006 Jason Vas Dias <jvdias@redhat.com> - 0.6.10-2.FC6
263faa
- fix bug 194203: fix permissions on /var/run/avahi-daemon
263faa
263faa
* Tue May 30 2006 Jason Vas Dias <jvdias@redhat.com> - 0.6.10-1.FC6
263faa
- Upgrade to upstream version 0.6.10
263faa
- fix bug 192080: split avahi-compat-libdns_sd into separate package
263faa
                  (same goes for avahi-compat-howl)
263faa
263faa
* Tue May 02 2006 Jason Vas Dias <jvdias@redhat.com> - 0.6.9-9.FC6
263faa
- fix avahi-sharp issues for banshee - patches from caillon@redhat.com
263faa
263faa
* Thu Apr 20 2006 Jason Vas Dias <jvdias@redhat.com> - 0.6.9-9.FC6
263faa
- fix bug 189427: correct avahi-resolve --help typo
263faa
263faa
* Mon Mar 20 2006 Jason Vas Dias <jvdias@redhat.com> - 0.6.9-8.FC6
263faa
- fix bug 185972: remove ellipses in initscript
263faa
- fix bug 185965: make chkconfigs unconditional
263faa
263faa
* Thu Mar 16 2006 Jason Vas Dias <jvdias@redhat.com> - 0.6.9-6
263faa
- Fix bug 185692: install avahi-sharp into %{_prefix}/lib, not %{_libdir}
263faa
263faa
* Thu Mar 09 2006 Jason Vas Dias <jvdias@redhat.com> - 0.6.9-4
263faa
- fix scriptlet error introduced by last fix:
263faa
  if user has disabled avahi-daemon, do not enable it during post
263faa
263faa
* Wed Mar 08 2006 Bill Nottingham <notting@redhat.com> - 0.6.9-2
263faa
- fix scriplet error during installer
263faa
- move service-types* to the tools package (avoids multilib conflicts)
263faa
263faa
* Tue Mar 07 2006 Jason Vas Dias <jvdias@redhat.com> - 0.6.9-1
263faa
- Upgrade to upstream version 0.6.9
263faa
263faa
* Thu Feb 23 2006 Jason Vas Dias <jvdias@redhat.com> - 0.6.8-1
263faa
- Upgrade to upstream version 0.6.8
263faa
- fix bug 182462: +Requires(post): initscripts, chkconfig, ldconfig
263faa
263faa
* Fri Feb 17 2006 Jason Vas Dias <jvdias@redhat.com> - 0.6.7-1
263faa
- Upgrade to upstream version 0.6.7
263faa
263faa
* Fri Feb 17 2006 Karsten Hopp <karsten@redhat.de> - 0.6.6-4
263faa
- BuildRequires pygtk2
263faa
263faa
* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.6.6-3.1
263faa
- bump again for double-long bug on ppc(64)
263faa
263faa
* Fri Feb 10 2006 Jason Vas Dias <jvdias@redhat.com> - 0.6.6-3
263faa
- rebuild for new gcc (again)
263faa
- further fix for bug 178746: fix avahi-dnsconfd initscript
263faa
263faa
* Tue Feb 07 2006 Jason Vas Dias <jvdias@redhat.com> - 0.6.6-2
263faa
- rebuild for new gcc, glibc, glibc-kernheaders
263faa
263faa
* Wed Feb 01 2006 Jason Vas Dias <jvdias@redhat.com> - 0.6.6-1
263faa
- fix bug 179448: mis-alignment of input cmsghdr msg->msg_control buffer on ia64
263faa
- Upgrade to 0.6.6
263faa
263faa
* Thu Jan 26 2006 Jason Vas Dias <jvdias@redhat.com> - 0.6.5-1
263faa
- Upgrade to upstream version 0.6.5
263faa
- Make /etc/avahi/etc and /etc/avahi/etc/localtime owned by avahi
263faa
  package; copy system localtime into chroot in post
263faa
263faa
* Mon Jan 23 2006 Jason Vas Dias <jvdias@redhat.com> - 0.6.4-4
263faa
- fix bug 178689: copy localtime to chroot
263faa
- fix bug 178784: fix avahi-dnsconfd initscript
263faa
263faa
* Fri Jan 20 2006 Peter Jones <pjones@redhat.com> - 0.6.4-3
263faa
- fix subsystem locking in the initscript
263faa
263faa
* Thu Jan 19 2006 Jason Vas Dias <jvdias@redhat.com> - 0.6.4-2
263faa
- fix bug 178127: fully localize the initscript
263faa
263faa
* Mon Jan 16 2006 Jason Vas Dias <jvdias@redhat.com> - 0.6.4-1
263faa
- Upgrade to upstream version 0.6.4
263faa
263faa
* Thu Jan 12 2006 Jason Vas Dias <jvdias@redhat.com> - 0.6.3-2
263faa
- fix bug 177610: Enable mono support with new avahi-sharp package
263faa
- fix bug 177609: add gdbm / gdbm-devel Requires for avahi-browse
263faa
263faa
* Mon Jan 09 2006 Jason Vas Dias <jvdias@redhat.com> - 0.6.3-1
263faa
- Upgrade to upstream version 0.6.3
263faa
- fix bug 177148: initscript start should not fail if avahi-daemon running
263faa
263faa
* Thu Dec 22 2005 Jason Vas Dias <jvdias@redhat.com> - 0.6.1-3
263faa
- move initscripts from /etc/init.d to /etc/rc.d/init.d
263faa
263faa
* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
263faa
- rebuilt
263faa
263faa
* Fri Dec 09 2005 Jason Vas Dias<jvdias@redhat.com> - 0.6.1-2
263faa
- fix bug 175352: Do not chkconfig --add avahi-daemon
263faa
  if user has already configured it
263faa
263faa
* Wed Dec 07 2005 Jason Vas Dias<jvdias@redhat.com> - 0.6.1-1
263faa
- Upgrade to 0.6.1
263faa
263faa
* Mon Dec 05 2005 Jason Vas Dias<jvdias@redhat.com> - 0.6-6
263faa
- fix bug 174799 - fix .spec file files permissions
263faa
263faa
* Fri Dec 02 2005 Jason Vas Dias<jvdias@redhat.com> - 0.6-5
263faa
- python-twisted has been removed from the FC-5 distribution - disable its use
263faa
263faa
* Thu Dec 01 2005 Jason Vas Dias<jvdias@redhat.com> - 0.6-4
263faa
- Rebuild for dbus-0.6 - remove use of DBUS_NAME_FLAG_PROHIBIT_REPLACEMENT
263faa
263faa
* Wed Nov 30 2005 Jason Vas Dias<jvdias@redhat.com> - 0.6-3
263faa
- fix bug 172047 - tools should require python-twisted
263faa
- fix bug 173985 - docs directory permissions
263faa
263faa
* Mon Nov 21 2005 Jason Vas Dias<jvdias@redhat.com> - 0.6-1
263faa
- Upgrade to upstream version 0.6 - now provides 'avahi-howl-compat'
263faa
  libraries / includes.
263faa
263faa
* Mon Nov 14 2005 Jason Vas Dias<jvdias@redhat.com> - 0.5.2-7
263faa
- fix bug 172034: fix ownership of /var/run/avahi-daemon/
263faa
- fix bug 172772: .spec file improvements from matthias@rpmforge.net
263faa
263faa
* Mon Oct 31 2005 Jason Vas Dias<jvdias@redhat.com> - 0.5.2-6
263faa
- put back avahi-devel Obsoletes: howl-devel
263faa
263faa
* Mon Oct 31 2005 Alexander Larsson <alexl@redhat.com> - 0.5.2-5
263faa
- Obsoletes howl, howl-libs, as we want to get rid of them on updates
263faa
- No provides yet, as the howl compat library is in Avahi 0.6.0.
263faa
263faa
* Sun Oct 30 2005 Florian La Roche <laroche@redhat.com>
263faa
- disable the Obsoletes: howl until the transition is complete
263faa
263faa
* Fri Oct 28 2005 Jason Vas Dias<jvdias@redhat.com> - 0.5.2-3
263faa
- change initscript to start avahi-daemon AFTER messagebus
263faa
263faa
* Wed Oct 26 2005 Karsten Hopp <karsten@redhat.de> 0.5.2-2
263faa
- add buildrequires dbus-python
263faa
263faa
* Fri Oct 21 2005 Alexander Larsson <alexl@redhat.com> - 0.5.2-1
263faa
- Initial package