Blob Blame Raw
From b0bb46370f5ddf8e6273cd80d0047ea0b413a9c6 Mon Sep 17 00:00:00 2001
From: Mike Gorse <mgorse@linux-megc.site>
Date: Wed, 23 Oct 2013 15:47:17 -0500
Subject: [PATCH] Fix atspi_component_contains

Per the spec, org.a11y.Atspi.Component.Contains takes a uint32 for the coord
type, not an int16

https://bugzilla.gnome.org/show_bug.cgi?id=710730
---
 atspi/atspi-component.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/atspi/atspi-component.c b/atspi/atspi-component.c
index 24d74d4..9cdd896 100644
--- a/atspi/atspi-component.c
+++ b/atspi/atspi-component.c
@@ -84,7 +84,7 @@ atspi_component_contains (AtspiComponent *obj,
 
   g_return_val_if_fail (obj != NULL, FALSE);
 
-  _atspi_dbus_call (obj, atspi_interface_component, "Contains", error, "iin=>b", d_x, d_y, d_ctype, &retval);
+  _atspi_dbus_call (obj, atspi_interface_component, "Contains", error, "iiu=>b", d_x, d_y, d_ctype, &retval);
 
   return retval;
 }
-- 
1.8.3.1