#1 Remove `Provides: ansible`
Closed 4 months ago by gotmax23. Opened 5 months ago by gotmax23.
rpms/ gotmax23/ansible-core c8s  into  c8s

file modified
-4
@@ -56,10 +56,6 @@ 

  Obsoletes: ansible < 2.10.0

  Obsoletes: ansible-base

  

- # ... and provide 'ansible' so that old packages still work without updated

- # spec files.

- Provides: ansible

- 

  # Bundled provides that are sprinkled throughout the codebase.

  Provides: bundled(python-backports-ssl_match_hostname) = 3.7.0.1

  Provides: bundled(python-distro) = 1.5.0

I am a co-maintainer of ansible on Fedora/EPEL. @kevin is the main maintainer.

Can you please remove this Provides:? Down the line, we are considering adding the Ansible 5.0 collections bundle to EPEL, which this provides prevents us from doing.

Also, it is important to note that ansible 2.9 and the stripped down ansible-core are not equivalent. Ansible 2.9 will be EOL'd later this year, so the change is kind of inevitable, but I'm sure the replacement of ansible 2.9 with ansible-core will cause breakage for some existing users of the EPEL package.

Signed-off-by: Maxwell G gotmax@e.email

Pull-Request has been closed by gotmax23

4 months ago
Metadata