8e5039 import ansible-core-2.14.2-3.el8

Authored and Committed by centosrcm 2 years ago
    import ansible-core-2.14.2-3.el8
    
        
file modified
+6 -7
.ansible-core.metadata CHANGED
@@ -1,7 +1,6 @@
1
- 56057bba4714e59b0f28bbb778bdb8321a198dd7 SOURCES/ansible-c1bb0c6ab89a344bdcc07ef66887c310e661e3a6.tar.gz
2
- 6a9e1e0eec23c0f3091fa53f91eb8701ad7caaeb SOURCES/jinja2-b08cd4bc64bb980df86ed2876978ae5735572280.tar.gz
3
- 72c5fe7f8145d4cff66426c444c33104a9ae3d53 SOURCES/markupsafe-b5a517506d6cb8091e215a4a89e47db5eee6a68f.tar.gz
4
- d5b06047a8a5937c9433c8e0e88bcf2ccb6a4f84 SOURCES/packaging-ded06cedf6e20680eea0363fac894cb4a09e7831.tar.gz
5
- f20e820c8fa08ff162ace90735a2a89c599f7166 SOURCES/pyparsing-6a844ee35ca5125490a28dbd6dd2d15b6498e605.tar.gz
6
- 2203e09b2add3d1edceb28e20b2a091e5e6c0344 SOURCES/resolvelib-d935f9fd07246d9641436c7a8e6ae39423374e28.tar.gz
1
+ 560f248ccb0b98256c5b50c86a002c2c1e57edb6 SOURCES/Jinja2-3.1.2.tar.gz
2
+ acb6dca5cbec84f4c707225a8b6b2505fae28c90 SOURCES/MarkupSafe-2.1.0.tar.gz
3
+ b7e3b3c247a445c1986e5ec350b13bb1984a7207 SOURCES/ansible-core-2.14.2.tar.gz
4
+ b99fa7af153646722b2d1817bb09906cc5a94bc6 SOURCES/packaging-20.4.tar.gz
5
+ ca8d892c93fe2d54ea5e6f31c5798e40c58e8667 SOURCES/pyparsing-2.4.7.tar.gz
6
+ ae564e766fc147e87d7f009d42b5204b7ae3a832 SOURCES/resolvelib-0.5.4.tar.gz
7
- c17fd6000af4ccf32930c41e928fea1e38cb5d0a SOURCES/straightplugin-6634ea8e1e89d5bb23804f50e676f196c52c46ed.tar.gz
file modified
+6 -7
.gitignore CHANGED
@@ -1,7 +1,6 @@
1
- SOURCES/ansible-c1bb0c6ab89a344bdcc07ef66887c310e661e3a6.tar.gz
2
- SOURCES/jinja2-b08cd4bc64bb980df86ed2876978ae5735572280.tar.gz
3
- SOURCES/markupsafe-b5a517506d6cb8091e215a4a89e47db5eee6a68f.tar.gz
4
- SOURCES/packaging-ded06cedf6e20680eea0363fac894cb4a09e7831.tar.gz
5
- SOURCES/pyparsing-6a844ee35ca5125490a28dbd6dd2d15b6498e605.tar.gz
6
- SOURCES/resolvelib-d935f9fd07246d9641436c7a8e6ae39423374e28.tar.gz
1
+ SOURCES/Jinja2-3.1.2.tar.gz
2
+ SOURCES/MarkupSafe-2.1.0.tar.gz
3
+ SOURCES/ansible-core-2.14.2.tar.gz
4
+ SOURCES/packaging-20.4.tar.gz
5
+ SOURCES/pyparsing-2.4.7.tar.gz
6
+ SOURCES/resolvelib-0.5.4.tar.gz
7
- SOURCES/straightplugin-6634ea8e1e89d5bb23804f50e676f196c52c46ed.tar.gz
SOURCES/remove-bundled-deps-from-requirements.patch ADDED
@@ -0,0 +1,18 @@
1
+ diff --git a/requirements.txt b/requirements.txt
2
+ index 20562c3e0f..792daa209a 100644
3
+ --- a/requirements.txt
4
+ +++ b/requirements.txt
5
+ @@ -3,13 +3,5 @@
6
+ # packages. Thus, this should be the loosest set possible (only required
7
+ # packages, not optional ones, and with the widest range of versions that could
8
+ # be suitable)
9
+ -jinja2 >= 3.0.0
10
+ PyYAML >= 5.1 # PyYAML 5.1 is required for Python 3.8+ support
11
+ cryptography
12
+ -packaging
13
+ -# NOTE: resolvelib 0.x version bumps should be considered major/breaking
14
+ -# NOTE: and we should update the upper cap with care, at least until 1.0
15
+ -# NOTE: Ref: https://github.com/sarugaku/resolvelib/issues/69
16
+ -# NOTE: When updating the upper bound, also update the latest version used
17
+ -# NOTE: in the ansible-galaxy-collection test suite.
18
+ -resolvelib >= 0.5.3, < 0.9.0 # dependency resolver used by ansible-galaxy
file modified
+69 -60
SPECS/ansible-core.spec CHANGED
@@ -1,3 +1,6 @@
1
+ %global __python3 /usr/bin/python3.11
2
+ %global python3_pkgversion 3.11
3
+
1
4
# We need this because we are no longer noarch, since our bundled deps might
2
5
# conceivably need to compile arch-specific things. But we currently have no
3
6
# useful debuginfo stuff.
@@ -7,9 +10,6 @@
7
10
# ansible-test munges the shebangs itself.
8
11
%global __brp_mangle_shebangs_exclude_from_file %{SOURCE1}
9
12
10
- %global commitId c1bb0c6ab89a344bdcc07ef66887c310e661e3a6
11
- %global python39_sitelib /usr/lib/python3.9/site-packages/
12
-
13
13
# NOTE(pabelanger): Don't auto add pwsh as Requires for ansible-test. We do
14
14
# not wish to package it.
15
15
%global __requires_exclude ^/usr/bin/pwsh$
@@ -23,8 +23,8 @@
23
23
%define py2_shbang_opts %{nil}
24
24
%define py3_shbang_opts %{nil}
25
25
26
- %define vendor_path %{buildroot}%{python39_sitelib}/ansible/_vendor/
27
- %define vendor_pip /usr/bin/python3.9 -m pip install --no-deps -v --no-use-pep517 --no-binary :all: -t %{vendor_path}
26
+ %define vendor_path %{buildroot}%{python3_sitelib}/ansible/_vendor/
27
+ %define vendor_pip %{__python3} -m pip install --no-deps -v --no-build-isolation --no-binary :all: -t %{vendor_path}
28
28
29
29
# These control which bundled dep versions we pin against
30
30
%global jinja2_version 3.1.2
@@ -32,29 +32,27 @@
32
32
%global packaging_version 20.4
33
33
%global pyparsing_version 2.4.7
34
34
%global resolvelib_version 0.5.4
35
- %global straightplugin_version 1.4.1
36
35
37
36
38
37
Name: ansible-core
39
38
Summary: SSH-based configuration management, deployment, and task execution system
40
- Version: 2.13.3
41
- Release: 1%{?dist}
39
+ Version: 2.14.2
40
+ Release: 3%{?dist}
42
41
ExcludeArch: i686
43
42
44
43
Group: Development/Libraries
45
44
License: GPLv3+
46
- Source0: ansible-%{commitId}.tar.gz
45
+ Source0: https://files.pythonhosted.org/packages/source/a/ansible-core/ansible-core-%{version}.tar.gz
47
46
Source1: ansible-test-data-files.txt
48
47
49
48
# And bundled deps
50
- Source2: jinja2-b08cd4bc64bb980df86ed2876978ae5735572280.tar.gz
51
- Source3: markupsafe-b5a517506d6cb8091e215a4a89e47db5eee6a68f.tar.gz
52
- Source4: packaging-ded06cedf6e20680eea0363fac894cb4a09e7831.tar.gz
53
- Source5: pyparsing-6a844ee35ca5125490a28dbd6dd2d15b6498e605.tar.gz
54
- Source6: resolvelib-d935f9fd07246d9641436c7a8e6ae39423374e28.tar.gz
49
+ Source2: https://files.pythonhosted.org/packages/source/J/Jinja2/Jinja2-%{jinja2_version}.tar.gz
50
+ Source3: https://files.pythonhosted.org/packages/source/M/MarkupSafe/MarkupSafe-%{markupsafe_version}.tar.gz
51
+ Source4: https://files.pythonhosted.org/packages/source/p/packaging/packaging-%{packaging_version}.tar.gz
52
+ Source5: https://files.pythonhosted.org/packages/source/p/pyparsing/pyparsing-%{pyparsing_version}.tar.gz
53
+ Source6: https://files.pythonhosted.org/packages/source/r/resolvelib/resolvelib-%{resolvelib_version}.tar.gz
55
54
56
- # Deps to build man pages
55
+ Patch0: remove-bundled-deps-from-requirements.patch
57
- Source7: straightplugin-6634ea8e1e89d5bb23804f50e676f196c52c46ed.tar.gz
58
56
59
57
URL: http://ansible.com
60
58
@@ -78,22 +76,19 @@ Provides: bundled(python-markupsafe) = %{markupsafe_version}
78
76
Provides: bundled(python-packaging) = %{packaging_version}
79
77
Provides: bundled(python-pyparsing) = %{pyparsing_version}
80
78
Provides: bundled(python-resolvelib) = %{resolvelib_version}
81
- Provides: bundled(python-straightplugin) = %{straightplugin_version}
82
-
83
- BuildRequires: python3-docutils
84
- BuildRequires: python39-devel
85
- BuildRequires: python39-pip
86
- BuildRequires: python39-pyyaml
87
- BuildRequires: python39-rpm-macros
79
+
80
+ BuildRequires: python%{python3_pkgversion}-devel
81
+ BuildRequires: python%{python3_pkgversion}-pip
82
+ BuildRequires: python%{python3_pkgversion}-pyyaml
83
+ BuildRequires: python%{python3_pkgversion}-rpm-macros
84
+ BuildRequires: python%{python3_pkgversion}-setuptools
85
+ BuildRequires: python%{python3_pkgversion}-wheel
88
- BuildRequires: python39-setuptools
89
- BuildRequires: python39-wheel
90
86
BuildRequires: make git-core gcc
91
87
92
88
Requires: git-core
93
- Requires: python39
94
- Requires: python39-PyYAML >= 5.1
95
- Requires: python39-cryptography
89
+ Requires: python%{python3_pkgversion}-PyYAML >= 5.1
90
+ Requires: python%{python3_pkgversion}-cryptography
91
+ Requires: python%{python3_pkgversion}-six
96
- Requires: python39-six
97
92
Requires: sshpass
98
93
99
94
%description
@@ -118,33 +113,25 @@ This package installs the ansible-test command for testing modules and plugins
118
113
developed for ansible.
119
114
120
115
%prep
121
- %setup -q -T -b 2 -n jinja2-b08cd4bc64bb980df86ed2876978ae5735572280
122
- %setup -q -T -b 3 -n markupsafe-b5a517506d6cb8091e215a4a89e47db5eee6a68f
116
+ %setup -q -b2 -b3 -b4 -b5 -b6 -n ansible-core-%{version}
117
+ %patch0 -p1
123
- %setup -q -T -b 4 -n packaging-ded06cedf6e20680eea0363fac894cb4a09e7831
124
- %setup -q -T -b 5 -n pyparsing-6a844ee35ca5125490a28dbd6dd2d15b6498e605
125
- %setup -q -T -b 6 -n resolvelib-d935f9fd07246d9641436c7a8e6ae39423374e28
126
- %setup -q -T -b 7 -n straightplugin-6634ea8e1e89d5bb23804f50e676f196c52c46ed
127
- %setup -q -n ansible-%{commitId}
128
118
129
119
# Fix all Python shebangs recursively in ansible-test
130
- # -p preserves timestamps
120
+ %{py3_shebang_fix} test/lib/ansible_test
131
- # -n prevents creating ~backup files
132
- # -i specifies the interpreter for the shebang
133
- pathfix3.9.py -pni "%{__python3} %{py3_shbang_opts}" test/lib/ansible_test
134
121
135
122
%build
136
- /usr/bin/python3.9 setup.py build
123
+ %{py3_build}
137
124
138
125
%install
139
- /usr/bin/python3.9 setup.py install --root %{buildroot}
126
+ %{py3_install}
140
127
141
128
# Handle bundled deps:
142
129
%{vendor_pip} \
143
- ../jinja2-b08cd4bc64bb980df86ed2876978ae5735572280/ \
144
- ../markupsafe-b5a517506d6cb8091e215a4a89e47db5eee6a68f/ \
145
- ../packaging-ded06cedf6e20680eea0363fac894cb4a09e7831/ \
146
- ../pyparsing-6a844ee35ca5125490a28dbd6dd2d15b6498e605/ \
147
- ../resolvelib-d935f9fd07246d9641436c7a8e6ae39423374e28
130
+ ../Jinja2-%{jinja2_version}/ \
131
+ ../MarkupSafe-%{markupsafe_version}/ \
132
+ ../packaging-%{packaging_version}/ \
133
+ ../pyparsing-%{pyparsing_version}/ \
134
+ ../resolvelib-%{resolvelib_version}
148
135
149
136
# Create system directories that Ansible defines as default locations in
150
137
# ansible/config/base.yml
@@ -186,20 +173,14 @@ mkdir -p %{buildroot}%{_sysconfdir}/ansible/roles/
186
173
cp examples/hosts %{buildroot}%{_sysconfdir}/ansible/
187
174
cp examples/ansible.cfg %{buildroot}%{_sysconfdir}/ansible/
188
175
mkdir -p %{buildroot}/%{_mandir}/man1/
189
- ## Build man pages
190
-
191
- mkdir /tmp/_vendor
192
- /usr/bin/python3.9 -m pip install ../straightplugin-6634ea8e1e89d5bb23804f50e676f196c52c46ed -t /tmp/_vendor --no-build-isolation
193
176
194
- # Remove plugins not needed, they bring in more dependencies
195
- find hacking/build_library/build_ansible/command_plugins ! -name 'generate_man.py' -type f -exec rm -f {} +
196
-
197
- PYTHON=python3.9 PYTHONPATH=%{vendor_path}:/tmp/_vendor make docs
198
177
cp -v docs/man/man1/*.1 %{buildroot}/%{_mandir}/man1/
199
178
200
179
cp -pr docs/docsite/rst .
201
180
cp -p lib/ansible_core.egg-info/PKG-INFO .
202
181
182
+ strip --strip-unneeded %{vendor_path}/markupsafe/_speedups%{python3_ext_suffix}
183
+
203
184
%files
204
185
%defattr(-,root,root)
205
186
%{_bindir}/ansible*
@@ -209,16 +190,44 @@ cp -p lib/ansible_core.egg-info/PKG-INFO .
209
190
%doc changelogs/CHANGELOG-v2.*.rst
210
191
%doc %{_mandir}/man1/ansible*
211
192
%{_datadir}/ansible/
212
- %{python39_sitelib}/ansible*
213
- %exclude %{python39_sitelib}/ansible_test
214
- %exclude %{python39_sitelib}/ansible/_vendor/markupsafe/_speedups.c
193
+ %{python3_sitelib}/ansible*
194
+ %exclude %{python3_sitelib}/ansible_test
195
+ %exclude %{python3_sitelib}/ansible/_vendor/markupsafe/_speedups.c
215
196
216
197
%files -n ansible-test
217
198
%{_bindir}/ansible-test
218
- %{python39_sitelib}/ansible_test
199
+ %{python3_sitelib}/ansible_test
219
200
220
201
%changelog
221
- * Wed Aug 15 2022 James Marshall <jamarsha@redhat.com> - 2.13.3-1
202
+ * Tue Feb 14 2023 Dimitri Savineau <dsavinea@redhat.com> - 2.14.2-3
203
+ - rebuild with python 3.11 (rhbz#2169524)
204
+ - remove bundled dependencies from requirements file (rhbz#2143974)
205
+ - use PyPi sources (rhbz#2160277)
206
+ - remove straightplugin
207
+
208
+ * Thu Feb 02 2023 Christian Adams <chadams@redhat.com> - 2.14.2-2
209
+ - fix debuginfo symbols from markupsafe dependency (rhbz#2166414)
210
+
211
+ * Wed Feb 01 2023 Christian Adams <chadams@redhat.com> - 2.14.2-1
212
+ - ansible-core 2.14.2 release (rhbz#2166414)
213
+
214
+ * Wed Dec 07 2022 Dimitri Savineau <dsavinea@redhat.com> - 2.14.1-1
215
+ - ansible-core 2.14.1 release (rhbz#2151594)
216
+
217
+ * Tue Nov 08 2022 Dimitri Savineau <dsavinea@redhat.com> - 2.14.0-1
218
+ - ansible-core 2.14.0 release (rhbz#2141386)
219
+
220
+ * Mon Nov 07 2022 Dimitri Savineau <dsavinea@redhat.com> - 2.13.6-1
221
+ - ansible-core 2.13.6 release (rhbz#2141109)
222
+ - fix service_facts module parsing (rhbz#2141111)
223
+
224
+ * Wed Oct 12 2022 James Marshall <jamarsha@redhat.com> - 2.13.5-1
225
+ - ansible-core 2.13.5 release (rhbz#2134116)
226
+
227
+ * Fri Oct 07 2022 Dimitri Savineau <dsavinea@redhat.com> - 2.13.4-1
228
+ - ansible-core 2.13.4 release (rhbz#2133024)
229
+
230
+ * Mon Aug 15 2022 James Marshall <jamarsha@redhat.com> - 2.13.3-1
222
231
- ansible-core 2.13.3 release (rhbz#2118475)
223
232
224
233
* Wed Jul 20 2022 James Marshall <jamarsha@redhat.com> - 2.13.2-1