b23843
import ansible-core-2.13.1-1.el8
@@ -1,4 +1,7 @@
|
|
1
|
-
|
1
|
+
f8c73e16f07ba1d1206a9c766362e9bab801f5d9 SOURCES/ansible-e9f633ec720fbd4367d2f694574dec101e22d3b9.tar.gz
|
2
|
+
6a9e1e0eec23c0f3091fa53f91eb8701ad7caaeb SOURCES/jinja2-b08cd4bc64bb980df86ed2876978ae5735572280.tar.gz
|
3
|
+
72c5fe7f8145d4cff66426c444c33104a9ae3d53 SOURCES/markupsafe-b5a517506d6cb8091e215a4a89e47db5eee6a68f.tar.gz
|
2
4
|
d5b06047a8a5937c9433c8e0e88bcf2ccb6a4f84 SOURCES/packaging-ded06cedf6e20680eea0363fac894cb4a09e7831.tar.gz
|
3
5
|
f20e820c8fa08ff162ace90735a2a89c599f7166 SOURCES/pyparsing-6a844ee35ca5125490a28dbd6dd2d15b6498e605.tar.gz
|
6
|
+
2203e09b2add3d1edceb28e20b2a091e5e6c0344 SOURCES/resolvelib-d935f9fd07246d9641436c7a8e6ae39423374e28.tar.gz
|
4
7
|
c17fd6000af4ccf32930c41e928fea1e38cb5d0a SOURCES/straightplugin-6634ea8e1e89d5bb23804f50e676f196c52c46ed.tar.gz
|
@@ -1,4 +1,7 @@
|
|
1
|
-
SOURCES/ansible-
|
1
|
+
SOURCES/ansible-e9f633ec720fbd4367d2f694574dec101e22d3b9.tar.gz
|
2
|
+
SOURCES/jinja2-b08cd4bc64bb980df86ed2876978ae5735572280.tar.gz
|
3
|
+
SOURCES/markupsafe-b5a517506d6cb8091e215a4a89e47db5eee6a68f.tar.gz
|
2
4
|
SOURCES/packaging-ded06cedf6e20680eea0363fac894cb4a09e7831.tar.gz
|
3
5
|
SOURCES/pyparsing-6a844ee35ca5125490a28dbd6dd2d15b6498e605.tar.gz
|
6
|
+
SOURCES/resolvelib-d935f9fd07246d9641436c7a8e6ae39423374e28.tar.gz
|
4
7
|
SOURCES/straightplugin-6634ea8e1e89d5bb23804f50e676f196c52c46ed.tar.gz
|
@@ -7,8 +7,8 @@
|
|
7
7
|
# ansible-test munges the shebangs itself.
|
8
8
|
%global __brp_mangle_shebangs_exclude_from_file %{SOURCE1}
|
9
9
|
|
10
|
-
%global commitId
|
11
|
-
%global
|
10
|
+
%global commitId e9f633ec720fbd4367d2f694574dec101e22d3b9
|
11
|
+
%global python39_sitelib /usr/lib/python3.9/site-packages/
|
12
12
|
|
13
13
|
# NOTE(pabelanger): Don't auto add pwsh as Requires for ansible-test. We do
|
14
14
|
# not wish to package it.
|
@@ -23,18 +23,21 @@
|
|
23
23
|
%define py2_shbang_opts %{nil}
|
24
24
|
%define py3_shbang_opts %{nil}
|
25
25
|
|
26
|
-
%define vendor_path %{buildroot}%{
|
27
|
-
%define vendor_pip /usr/bin/python3.
|
26
|
+
%define vendor_path %{buildroot}%{python39_sitelib}/ansible/_vendor/
|
27
|
+
%define vendor_pip /usr/bin/python3.9 -m pip install --no-deps -v --no-use-pep517 --no-binary :all: -t %{vendor_path}
|
28
28
|
|
29
29
|
# These control which bundled dep versions we pin against
|
30
|
+
%global jinja2_version 3.1.2
|
31
|
+
%global markupsafe_version 2.1.0
|
30
32
|
%global packaging_version 20.4
|
31
33
|
%global pyparsing_version 2.4.7
|
34
|
+
%global resolvelib_version 0.5.4
|
32
35
|
%global straightplugin_version 1.4.1
|
33
36
|
|
34
37
|
|
35
38
|
Name: ansible-core
|
36
39
|
Summary: SSH-based configuration management, deployment, and task execution system
|
37
|
-
Version: 2.
|
40
|
+
Version: 2.13.1
|
38
41
|
Release: 1%{?dist}
|
39
42
|
ExcludeArch: i686
|
40
43
|
|
@@ -44,11 +47,14 @@ Source0: ansible-%{commitId}.tar.gz
|
|
44
47
|
Source1: ansible-test-data-files.txt
|
45
48
|
|
46
49
|
# And bundled deps
|
47
|
-
Source2:
|
48
|
-
Source3:
|
50
|
+
Source2: jinja2-b08cd4bc64bb980df86ed2876978ae5735572280.tar.gz
|
51
|
+
Source3: markupsafe-b5a517506d6cb8091e215a4a89e47db5eee6a68f.tar.gz
|
52
|
+
Source4: packaging-ded06cedf6e20680eea0363fac894cb4a09e7831.tar.gz
|
53
|
+
Source5: pyparsing-6a844ee35ca5125490a28dbd6dd2d15b6498e605.tar.gz
|
54
|
+
Source6: resolvelib-d935f9fd07246d9641436c7a8e6ae39423374e28.tar.gz
|
49
55
|
|
50
56
|
# Deps to build man pages
|
51
|
-
|
57
|
+
Source7: straightplugin-6634ea8e1e89d5bb23804f50e676f196c52c46ed.tar.gz
|
52
58
|
|
53
59
|
URL: http://ansible.com
|
54
60
|
|
@@ -62,33 +68,32 @@ Conflicts: ansible-base
|
|
62
68
|
|
63
69
|
# Bundled provides that are sprinkled throughout the codebase.
|
64
70
|
Provides: bundled(python-backports-ssl_match_hostname) = 3.7.0.1
|
65
|
-
Provides: bundled(python-distro) = 1.
|
71
|
+
Provides: bundled(python-distro) = 1.6.0
|
66
72
|
Provides: bundled(python-selectors2) = 1.1.1
|
67
|
-
Provides: bundled(python-six) = 1.
|
73
|
+
Provides: bundled(python-six) = 1.16.0
|
68
74
|
|
69
75
|
# Things we explicitly bundle via src rpm, and put in ansible._vendor
|
76
|
+
Provides: bundled(python-jinja2) = %{jinja2_version}
|
77
|
+
Provides: bundled(python-markupsafe) = %{markupsafe_version}
|
70
78
|
Provides: bundled(python-packaging) = %{packaging_version}
|
71
79
|
Provides: bundled(python-pyparsing) = %{pyparsing_version}
|
80
|
+
Provides: bundled(python-resolvelib) = %{resolvelib_version}
|
72
81
|
Provides: bundled(python-straightplugin) = %{straightplugin_version}
|
73
82
|
|
74
83
|
BuildRequires: python3-docutils
|
75
|
-
BuildRequires:
|
76
|
-
BuildRequires:
|
77
|
-
BuildRequires:
|
78
|
-
BuildRequires:
|
79
|
-
BuildRequires:
|
80
|
-
BuildRequires:
|
81
|
-
BuildRequires:
|
84
|
+
BuildRequires: python39-devel
|
85
|
+
BuildRequires: python39-pip
|
86
|
+
BuildRequires: python39-pyyaml
|
87
|
+
BuildRequires: python39-rpm-macros
|
88
|
+
BuildRequires: python39-setuptools
|
89
|
+
BuildRequires: python39-wheel
|
90
|
+
BuildRequires: make git-core gcc
|
82
|
-
BuildRequires: python38-wheel
|
83
|
-
BuildRequires: make git-core
|
84
91
|
|
85
92
|
Requires: git-core
|
86
|
-
Requires:
|
87
|
-
Requires:
|
88
|
-
Requires:
|
89
|
-
Requires:
|
93
|
+
Requires: python39
|
94
|
+
Requires: python39-PyYAML >= 5.1
|
95
|
+
Requires: python39-cryptography
|
96
|
+
Requires: python39-six
|
90
|
-
Requires: python38-resolvelib
|
91
|
-
Requires: python38-six
|
92
97
|
Requires: sshpass
|
93
98
|
|
94
99
|
%description
|
@@ -113,27 +118,33 @@ This package installs the ansible-test command for testing modules and plugins
|
|
113
118
|
developed for ansible.
|
114
119
|
|
115
120
|
%prep
|
116
|
-
%setup -q -T -b 2 -n
|
117
|
-
%setup -q -T -b 3 -n
|
118
|
-
%setup -q -T -b
|
121
|
+
%setup -q -T -b 2 -n jinja2-b08cd4bc64bb980df86ed2876978ae5735572280
|
122
|
+
%setup -q -T -b 3 -n markupsafe-b5a517506d6cb8091e215a4a89e47db5eee6a68f
|
123
|
+
%setup -q -T -b 4 -n packaging-ded06cedf6e20680eea0363fac894cb4a09e7831
|
124
|
+
%setup -q -T -b 5 -n pyparsing-6a844ee35ca5125490a28dbd6dd2d15b6498e605
|
125
|
+
%setup -q -T -b 6 -n resolvelib-d935f9fd07246d9641436c7a8e6ae39423374e28
|
126
|
+
%setup -q -T -b 7 -n straightplugin-6634ea8e1e89d5bb23804f50e676f196c52c46ed
|
119
127
|
%setup -q -n ansible-%{commitId}
|
120
128
|
|
121
129
|
# Fix all Python shebangs recursively in ansible-test
|
122
130
|
# -p preserves timestamps
|
123
131
|
# -n prevents creating ~backup files
|
124
132
|
# -i specifies the interpreter for the shebang
|
125
|
-
pathfix3.
|
133
|
+
pathfix3.9.py -pni "%{__python3} %{py3_shbang_opts}" test/lib/ansible_test
|
126
134
|
|
127
135
|
%build
|
128
|
-
/usr/bin/python3.
|
136
|
+
/usr/bin/python3.9 setup.py build
|
129
137
|
|
130
138
|
%install
|
131
|
-
/usr/bin/python3.
|
139
|
+
/usr/bin/python3.9 setup.py install --root %{buildroot}
|
132
140
|
|
133
141
|
# Handle bundled deps:
|
134
142
|
%{vendor_pip} \
|
143
|
+
../jinja2-b08cd4bc64bb980df86ed2876978ae5735572280/ \
|
144
|
+
../markupsafe-b5a517506d6cb8091e215a4a89e47db5eee6a68f/ \
|
145
|
+
../packaging-ded06cedf6e20680eea0363fac894cb4a09e7831/ \
|
135
146
|
../pyparsing-6a844ee35ca5125490a28dbd6dd2d15b6498e605/ \
|
136
|
-
../
|
147
|
+
../resolvelib-d935f9fd07246d9641436c7a8e6ae39423374e28
|
137
148
|
|
138
149
|
# Create system directories that Ansible defines as default locations in
|
139
150
|
# ansible/config/base.yml
|
@@ -178,12 +189,12 @@ mkdir -p %{buildroot}/%{_mandir}/man1/
|
|
178
189
|
## Build man pages
|
179
190
|
|
180
191
|
mkdir /tmp/_vendor
|
181
|
-
/usr/bin/python3.
|
192
|
+
/usr/bin/python3.9 -m pip install ../straightplugin-6634ea8e1e89d5bb23804f50e676f196c52c46ed -t /tmp/_vendor --no-build-isolation
|
182
193
|
|
183
194
|
# Remove plugins not needed, they bring in more dependencies
|
184
195
|
find hacking/build_library/build_ansible/command_plugins ! -name 'generate_man.py' -type f -exec rm -f {} +
|
185
196
|
|
186
|
-
PYTHON=python3.
|
197
|
+
PYTHON=python3.9 PYTHONPATH=%{vendor_path}:/tmp/_vendor make docs
|
187
198
|
cp -v docs/man/man1/*.1 %{buildroot}/%{_mandir}/man1/
|
188
199
|
|
189
200
|
cp -pr docs/docsite/rst .
|
@@ -198,14 +209,20 @@ cp -p lib/ansible_core.egg-info/PKG-INFO .
|
|
198
209
|
%doc changelogs/CHANGELOG-v2.*.rst
|
199
210
|
%doc %{_mandir}/man1/ansible*
|
200
211
|
%{_datadir}/ansible/
|
201
|
-
%{
|
202
|
-
%exclude %{
|
212
|
+
%{python39_sitelib}/ansible*
|
213
|
+
%exclude %{python39_sitelib}/ansible_test
|
214
|
+
%exclude %{python39_sitelib}/ansible/_vendor/markupsafe/_speedups.c
|
203
215
|
|
204
216
|
%files -n ansible-test
|
205
217
|
%{_bindir}/ansible-test
|
206
|
-
%{
|
218
|
+
%{python39_sitelib}/ansible_test
|
207
219
|
|
208
220
|
%changelog
|
221
|
+
* Mon Jul 04 2022 Dimitri Savineau <dsavinea@redhat.com> - 2.13.1-1
|
222
|
+
- ansible-core 2.13.1 release (rhbz#2103699)
|
223
|
+
- add bundled version of jinja2, markupsafe and resolvelib
|
224
|
+
- rebuild with python 3.9
|
225
|
+
|
209
226
|
* Mon Jun 20 2022 Dimitri Savineau <dsavinea@redhat.com> - 2.12.7-1
|
210
227
|
- ansible-core 2.12.7 release (rhbz#2099323)
|
211
228
|
|