600f6d import anaconda-33.16.4.6-1.el8

Authored and Committed by centosrcm 4 years ago
    import anaconda-33.16.4.6-1.el8
    
        
file modified
+1 -1
.anaconda.metadata CHANGED
@@ -1 +1 @@
1
- 6ba215fc553f2487b1f3ff6e0634515735be06f9 SOURCES/anaconda-33.16.4.4.tar.bz2
1
+ 664342f326bc9c7cf5380395e97525ab2c12a980 SOURCES/anaconda-33.16.4.6.tar.bz2
file modified
+1 -1
.gitignore CHANGED
@@ -1 +1 @@
1
- SOURCES/anaconda-33.16.4.4.tar.bz2
1
+ SOURCES/anaconda-33.16.4.6.tar.bz2
SOURCES/0001-Add-product-data-for-CentOS-Stream.patch DELETED
@@ -1,43 +0,0 @@
1
- From 646ea4b2d75712f83086b9ca7b06bf543158c169 Mon Sep 17 00:00:00 2001
2
- From: Brian Stinson <bstinson@centosproject.org>
3
- Date: Thu, 25 Jun 2020 18:10:13 -0500
4
- Subject: [PATCH] Add product data for CentOS Stream
5
-
6
- ---
7
- data/product.d/centos-stream.conf | 7 +++++++
8
- tests/nosetests/pyanaconda_tests/product_test.py | 5 +++++
9
- 2 files changed, 12 insertions(+)
10
- create mode 100644 data/product.d/centos-stream.conf
11
-
12
- diff --git a/data/product.d/centos-stream.conf b/data/product.d/centos-stream.conf
13
- new file mode 100644
14
- index 0000000000..c65fcbbdf8
15
- --- /dev/null
16
- +++ b/data/product.d/centos-stream.conf
17
- @@ -0,0 +1,7 @@
18
- +# Anaconda configuration file for CentOS Stream.
19
- +
20
- +[Product]
21
- +product_name = CentOS Stream
22
- +
23
- +[Base Product]
24
- +product_name = CentOS Linux
25
- diff --git a/tests/nosetests/pyanaconda_tests/product_test.py b/tests/nosetests/pyanaconda_tests/product_test.py
26
- index 55f3e0dde7..d0c3adb849 100644
27
- --- a/tests/nosetests/pyanaconda_tests/product_test.py
28
- +++ b/tests/nosetests/pyanaconda_tests/product_test.py
29
- @@ -244,6 +244,11 @@ class ProductConfigurationTestCase(unittest.TestCase):
30
- ["rhel.conf", "centos.conf"],
31
- WORKSTATION_PARTITIONING
32
- )
33
- + self._check_default_product(
34
- + "CentOS Stream", "",
35
- + ["rhel.conf", "centos.conf", "centos-stream.conf"],
36
- + WORKSTATION_PARTITIONING
37
- + )
38
- self._check_default_product(
39
- "Red Hat Virtualization", "",
40
- ["rhel.conf", "rhev.conf"],
41
- --
42
- 2.29.2
43
-
SOURCES/0001-Fix-CDN-button-visibility.patch DELETED
@@ -1,53 +0,0 @@
1
- From c29802a2be591a4cdcc91ba86b74fc4d01087b72 Mon Sep 17 00:00:00 2001
2
- From: Martin Kolman <mkolman@redhat.com>
3
- Date: Fri, 11 Sep 2020 15:27:59 +0200
4
- Subject: [PATCH] Fix CDN button visibility
5
-
6
- Only show the Red Hat CDN button if the Subscription
7
- module appears to be running. To achieve that, we do
8
- the same thing as with the HMC button - the CDN
9
- button invisible by default. And enable it only if it
10
- looks like the Subscription module is running.
11
-
12
- (cherry picked from commit: aca297587ab8bdd7342fa056273bfff379bc0a0b)
13
-
14
- Resolves: rhbz#1903178
15
- ---
16
- pyanaconda/ui/gui/spokes/installation_source.glade | 2 +-
17
- pyanaconda/ui/gui/spokes/installation_source.py | 4 ++--
18
- 2 files changed, 3 insertions(+), 3 deletions(-)
19
-
20
- diff --git a/pyanaconda/ui/gui/spokes/installation_source.glade b/pyanaconda/ui/gui/spokes/installation_source.glade
21
- index a23f8be714..e53fa230ca 100644
22
- --- a/pyanaconda/ui/gui/spokes/installation_source.glade
23
- +++ b/pyanaconda/ui/gui/spokes/installation_source.glade
24
- @@ -633,9 +633,9 @@
25
- <child>
26
- <object class="GtkRadioButton" id="cdnRadioButton">
27
- <property name="label" translatable="yes" context="GUI|Software Source">Red Hat _CDN</property>
28
- - <property name="visible">True</property>
29
- <property name="can_focus">True</property>
30
- <property name="receives_default">False</property>
31
- + <property name="no_show_all">True</property>
32
- <property name="margin_left">12</property>
33
- <property name="use_underline">True</property>
34
- <property name="xalign">0</property>
35
- diff --git a/pyanaconda/ui/gui/spokes/installation_source.py b/pyanaconda/ui/gui/spokes/installation_source.py
36
- index 6aab9b387a..d0d4da72b9 100644
37
- --- a/pyanaconda/ui/gui/spokes/installation_source.py
38
- +++ b/pyanaconda/ui/gui/spokes/installation_source.py
39
- @@ -854,9 +854,9 @@ class SourceSpoke(NormalSpoke, GUISpokeInputCheckHandler, SourceSwitchHandler):
40
- def _initialize(self):
41
- threadMgr.wait(constants.THREAD_PAYLOAD)
42
-
43
- - # If there is no Subscriptiopn DBus module, disable the CDN radio button
44
- + # If there is the Subscriptiopn DBus module, make the CDN radio button visible
45
- if is_module_available(SUBSCRIPTION):
46
- - gtk_call_once(self._cdn_button.set_no_show_all, True)
47
- + gtk_call_once(self._cdn_button.set_no_show_all, False)
48
-
49
- # Get the current source.
50
- source_proxy = self.payload.get_source_proxy()
51
- --
52
- 2.29.2
53
-
file modified
+15 -14
SPECS/anaconda.spec CHANGED
@@ -1,6 +1,6 @@
1
1
Summary: Graphical system installer
2
2
Name: anaconda
3
- Version: 33.16.4.4
3
+ Version: 33.16.4.6
4
4
Release: 1%{?dist}
5
5
License: GPLv2+ and MIT
6
6
URL: http://fedoraproject.org/wiki/Anaconda
@@ -12,12 +12,6 @@ URL: http://fedoraproject.org/wiki/Anaconda
12
12
# make dist
13
13
Source0: %{name}-%{version}.tar.bz2
14
14
15
- # https://github.com/rhinstaller/anaconda/pull/2689
16
- Patch104: 0001-Add-product-data-for-CentOS-Stream.patch
17
-
18
- # https://github.com/rhinstaller/anaconda/pull/3020
19
- Patch105: 0001-Fix-CDN-button-visibility.patch
20
-
21
15
# Versions of required components (done so we make sure the buildrequires
22
16
# match the requires versions of things).
23
17
@@ -271,9 +265,6 @@ runtime on NFS/HTTP/FTP servers or local disks.
271
265
%prep
272
266
%autosetup -p 1
273
267
274
- # debranding
275
- sed -e 's/RHEL/CentOS/' -i po/*.po
276
-
277
268
%build
278
269
# use actual build-time release number, not tarball creation time release number
279
270
%configure ANACONDA_RELEASE=%{release}
@@ -376,6 +367,20 @@ desktop-file-install --dir=%{buildroot}%{_datadir}/applications %{buildroot}%{_d
376
367
%{_prefix}/libexec/anaconda/dd_*
377
368
378
369
%changelog
370
+ * Mon Jan 11 2021 Martin Kolman <mkolman@redhat.com> - 33.16.4.6-1
371
+ - Initialize librepo logger (pkratoch)
372
+ Resolves: rhbz#1908286
373
+ - Add RPM tests support for owners on rhel-8 (jkonecny)
374
+ Related: rhbz#1885635
375
+ - Use latests RHEL-8 buildroot in containers (jkonecny)
376
+ Related: rhbz#1885635
377
+ - Implement rpm-tests execution in the container (jkonecny)
378
+ Related: rhbz#1885635
379
+
380
+ * Tue Jan 05 2021 Radek Vykydal <rvykydal@redhat.com> - 33.16.4.5-1
381
+ - network: fix double-free using libnm function filter_connections() (rvykydal)
382
+ Resolves: rhbz#1873561
383
+
379
384
* Tue Dec 08 2020 Radek Vykydal <rvykydal@redhat.com> - 33.16.4.4-1
380
385
- network: rename Gtk cell renderer to prevent name collision (rvykydal)
381
386
Related: rhbz#1847681
@@ -622,10 +627,6 @@ desktop-file-install --dir=%{buildroot}%{_datadir}/applications %{buildroot}%{_d
622
627
- Wait for payload initialization to finish in Subscription spoke (mkolman)
623
628
Related: rhbz#1823578
624
629
625
- * Wed Jul 22 2020 Martin Kolman <mkolman@redhat.com> - 33.16.3.13-2
626
- - Boot over HTTP via UEFI blocker fixes (vponcova)(jkonecny)
627
- Resolves: rhbz#1856264
628
-
629
630
* Thu Jul 09 2020 Radek Vykydal <rvykydal@redhat.com> - 33.16.3.13-1
630
631
- Fix the position of the info bar in standalone spokes (vponcova)
631
632
Resolves: rhbz#1847423