7cc02f import accel-config-2.8-1.el8

Merged and Committed by centosrcm 4 years ago
    import accel-config-2.8-1.el8
    
        
.accel-config.metadata ADDED
@@ -0,0 +1 @@
1
+ b13c1239eafdca1ce46250cf1fe0880c0177b078 SOURCES/accel-config-v2.8.tar.gz
file added
+1
.gitignore ADDED
@@ -0,0 +1 @@
1
+ SOURCES/accel-config-v2.8.tar.gz
SOURCES/01-accel-config-2.8-test-fix.patch ADDED
@@ -0,0 +1,21 @@
1
+ Common subdirectories: idxd-config-accel-config-v2.8/accfg and idxd-config-accel-config-v2.8-new/accfg
2
+ Common subdirectories: idxd-config-accel-config-v2.8/ccan and idxd-config-accel-config-v2.8-new/ccan
3
+ Common subdirectories: idxd-config-accel-config-v2.8/contrib and idxd-config-accel-config-v2.8-new/contrib
4
+ Common subdirectories: idxd-config-accel-config-v2.8/Documentation and idxd-config-accel-config-v2.8-new/Documentation
5
+ Common subdirectories: idxd-config-accel-config-v2.8/licenses and idxd-config-accel-config-v2.8-new/licenses
6
+ diff -u idxd-config-accel-config-v2.8/Makefile.am idxd-config-accel-config-v2.8-new/Makefile.am
7
+ --- idxd-config-accel-config-v2.8/Makefile.am 2020-09-18 10:24:01.000000000 -0700
8
+ +++ idxd-config-accel-config-v2.8-new/Makefile.am 2021-01-19 10:12:19.243429399 -0700
9
+ @@ -5,7 +5,9 @@
10
+ if ENABLE_DOCS
11
+ SUBDIRS += Documentation/accfg
12
+ endif
13
+ +if ENABLE_TEST
14
+ SUBDIRS += test
15
+ +endif
16
+
17
+ BUILT_SOURCES = version.m4
18
+ version.m4: FORCE
19
+ Common subdirectories: idxd-config-accel-config-v2.8/sles and idxd-config-accel-config-v2.8-new/sles
20
+ Common subdirectories: idxd-config-accel-config-v2.8/test and idxd-config-accel-config-v2.8-new/test
21
+ Common subdirectories: idxd-config-accel-config-v2.8/util and idxd-config-accel-config-v2.8-new/util
SPECS/accel-config.spec ADDED
@@ -0,0 +1,91 @@
1
+ %global project_name idxd-config
2
+
3
+ Name: accel-config
4
+ Version: 2.8
5
+ Release: 1%{?dist}
6
+ Summary: Configure accelerator subsystem devices
7
+ # The entire source code is under GPLv2 except for accel-config
8
+ # library which is mostly LGPLv2, ccan/list which is BSD-MIT and
9
+ # the rest of ccan which is CC0.
10
+ License: GPLv2 and LGPLv2 and MIT and CC0
11
+ URL: https://github.com/intel/%{project_name}
12
+ Source0: %{URL}/archive/%{name}-v%{version}.tar.gz
13
+ Patch0: 01-accel-config-2.8-test-fix.patch
14
+
15
+ Requires: %{name}-libs%{?_isa} = %{version}-%{release}
16
+ BuildRequires: gcc
17
+ BuildRequires: autoconf
18
+ BuildRequires: asciidoc
19
+ BuildRequires: xmlto
20
+ BuildRequires: automake
21
+ BuildRequires: libtool
22
+ BuildRequires: pkgconfig
23
+ BuildRequires: pkgconfig(libkmod)
24
+ BuildRequires: pkgconfig(uuid)
25
+ BuildRequires: pkgconfig(json-c)
26
+ BuildRequires: pkgconfig(libudev)
27
+ BuildRequires: systemd
28
+
29
+ # accel-config is for configuring Intel DSA (Data-Streaming
30
+ # Accelerator) subsystem in the Linux kernel. It supports x86 only.
31
+ ExclusiveArch: %{ix86} x86_64
32
+
33
+ %description
34
+ Utility library for configuring the accelerator subsystem.
35
+
36
+ %package devel
37
+ Summary: Development files for libaccfg
38
+ License: LGPLv2
39
+ Requires: %{name}-libs%{?_isa} = %{version}-%{release}
40
+
41
+ %description devel
42
+ The %{name}-devel package contains libraries and header files for
43
+ developing applications that use %{name}.
44
+
45
+
46
+ %package libs
47
+ Summary: Configuration library for accelerator subsystem devices
48
+ # All source code of configuration library is LGPLv2, except
49
+ # ccan/list which is BSD-MIT and the rest of ccan/ which is CC0.
50
+ License: LGPLv2 and MIT and CC0
51
+ Requires: %{name}%{?_isa} = %{version}-%{release}
52
+
53
+ %description libs
54
+ Libraries for %{name}.
55
+
56
+ %prep
57
+ %autosetup -p1 -n %{project_name}-%{name}-v%{version}
58
+
59
+ %build
60
+ echo %{version} > version
61
+ ./autogen.sh
62
+ %configure --disable-static --disable-silent-rules
63
+ %make_build
64
+
65
+ %install
66
+ %make_install
67
+ find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
68
+
69
+ %check
70
+ make check
71
+
72
+ %files
73
+ %license Documentation/COPYING licenses/BSD-MIT licenses/CC0
74
+ %{_bindir}/%{name}
75
+ %{_mandir}/man1/%{name}*
76
+ %{_sysconfdir}/%{name}/%{name}.conf.sample
77
+
78
+ %files libs
79
+ %doc README.md
80
+ %license Documentation/COPYING licenses/BSD-MIT licenses/CC0
81
+ %{_libdir}/lib%{name}.so.*
82
+
83
+ %files devel
84
+ %license Documentation/COPYING
85
+ %{_includedir}/%{name}/
86
+ %{_libdir}/lib%{name}.so
87
+ %{_libdir}/pkgconfig/lib%{name}.pc
88
+
89
+ %changelog
90
+ * Fri Nov 6 2020 Yunying Sun <yunying.sun@intel.com> - 2.8-1
91
+ - Initial Packaging