Blob Blame Raw
From b6fd1033881ce21513ba95b533fd35942e5b66f1 Mon Sep 17 00:00:00 2001
From: Noriko Hosoi <nhosoi@redhat.com>
Date: Thu, 14 Jul 2016 10:33:15 -0700
Subject: [PATCH 11/15] Bug 1347760 - CVE-2016-4992 389-ds-base: Information
 disclosure via repeated use of LDAP ADD operation, etc.

Description: Fixing a compiler warning.
(cherry picked from commit 590e2fb86ee2e1d6f169169c83917d18872a95d0)
---
 ldap/servers/slapd/bind.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/ldap/servers/slapd/bind.c b/ldap/servers/slapd/bind.c
index b441615..702d4c2 100644
--- a/ldap/servers/slapd/bind.c
+++ b/ldap/servers/slapd/bind.c
@@ -697,7 +697,7 @@ do_bind( Slapi_PBlock *pb )
                 sdn = pb_sdn;
                 dn = slapi_sdn_get_dn(sdn);
                 if (!dn) {
-                    char *udn = slapi_sdn_get_udn(sdn);
+                    const char *udn = slapi_sdn_get_udn(sdn);
                     slapi_create_errormsg(errorbuf, sizeof(errorbuf), "Pre-bind plug-in set corrupted dn %s\n", udn?udn:"");
                     slapi_pblock_set(pb, SLAPI_PB_RESULT_TEXT, errorbuf);
                     send_ldap_result(pb, LDAP_OPERATIONS_ERROR, NULL, "", 0, NULL);
-- 
2.4.11