From 78b10da3fc88c5ddf46b68d3dd3ac9b62fdf2cb6 Mon Sep 17 00:00:00 2001
From: CentOS Sources <bugs@centos.org>
Date: Thu, 30 Nov 2017 18:48:18 +0000
Subject: [PATCH] debrand docker-1.12.6-68.gitec8512b.el7

---
 SOURCES/docker-common.sh |   20 ++++++++++++++++++++
 1 files changed, 20 insertions(+), 0 deletions(-)

diff --git a/SOURCES/docker-common.sh b/SOURCES/docker-common.sh
new file mode 100644
index 0000000..34b1245
--- /dev/null
+++ b/SOURCES/docker-common.sh
@@ -0,0 +1,20 @@
+#!/bin/sh
+. /etc/sysconfig/docker
+[ -e "${DOCKERBINARY}" ] || DOCKERBINARY=/usr/bin/docker-current
+if [ ! -f /usr/bin/docker-current ]; then
+    if [ ! -f /usr/bin/docker-latest ]; then
+        echo "You don't have either docker-client or \
+docker-client-latest installed. Please install either one and retry."
+        exit
+    else
+        DOCKERBINARY=/usr/bin/docker-latest
+    fi
+fi
+if [[ ${DOCKERBINARY} != "/usr/bin/docker-current" && ${DOCKERBINARY} != /usr/bin/docker-latest ]]; then
+    echo "DOCKERBINARY has been set to an invalid value:" $DOCKERBINARY
+    echo ""
+    echo "Please set DOCKERBINARY to /usr/bin/docker-current or /usr/bin/docker-latest
+by editing /etc/sysconfig/docker"
+else
+    exec ${DOCKERBINARY} "$@"
+fi

--
Gitblit v1.8.0