render / rpms / qemu

Forked from rpms/qemu 10 months ago
Clone

dd16ba Run chrpath on binaries, so qemu can be built using rpmbuild.

Authored and Committed by rjones@redhat.com 11 years ago
1 file changed. 14 lines added. 1 lines removed.
    Run chrpath on binaries, so qemu can be built using rpmbuild.
    
        
file modified
+14 -1
qemu.spec CHANGED
@@ -139,7 +139,7 @@
139
139
Summary: QEMU is a FAST! processor emulator
140
140
Name: qemu
141
141
Version: 1.7.0
142
- Release: 0.1.rc1%{?dist}
142
+ Release: 0.2.rc1%{?dist}
143
143
Epoch: 2
144
144
License: GPLv2+ and LGPLv2+ and BSD
145
145
Group: Development/Tools
@@ -204,6 +204,7 @@ Patch0014: 0014-virtio-pci-add-device_unplugged-callback.patch
204
204
BuildRequires: SDL-devel
205
205
BuildRequires: zlib-devel
206
206
BuildRequires: which
207
+ BuildRequires: chrpath
207
208
BuildRequires: texi2html
208
209
BuildRequires: gnutls-devel
209
210
BuildRequires: cyrus-sasl-devel
@@ -1025,6 +1026,15 @@ rm -f $RPM_BUILD_ROOT%{_libdir}/pkgconfig/libcacard.pc
1025
1026
rm -rf $RPM_BUILD_ROOT%{_includedir}/cacard
1026
1027
%endif
1027
1028
1029
+ # When building using 'rpmbuild' or 'fedpkg local', RPATHs are left in
1030
+ # the binaries and libraries (although this doesn't occur when
1031
+ # building in Koji, for some unknown reason). In any case it should
1032
+ # always be safe to remove RPATHs from the final binaries:
1033
+ for f in $RPM_BUILD_ROOT%{_bindir}/* $RPM_BUILD_ROOT%{_libdir}/* \
1034
+ $RPM_BUILD_ROOT%{_libexecdir}/*; do
1035
+ if file $f | grep -q ELF; then chrpath --delete $f; fi
1036
+ done
1037
+
1028
1038
%check
1029
1039
make check
1030
1040
@@ -1438,6 +1448,9 @@ getent passwd qemu >/dev/null || \
1438
1448
%endif
1439
1449
1440
1450
%changelog
1451
+ * Fri Nov 29 2013 Richard W.M. Jones <rjones@redhat.com> - 2:1.7.0-0.2.rc1
1452
+ - Run chrpath on binaries, so qemu can be built using rpmbuild.
1453
+
1441
1454
* Thu Nov 21 2013 Cole Robinson <crobinso@redhat.com> - 2:1.7.0-0.1.rc1
1442
1455
- Update qemu-1.7.0-rc1
1443
1456