render / rpms / qemu

Forked from rpms/qemu 10 months ago
Clone

cf5f9d Clarify chrpath comment

Authored and Committed by crobinso 11 years ago
1 file changed. 7 lines added. 3 lines removed.
    Clarify chrpath comment
    
        
file modified
+7 -3
qemu.spec CHANGED
@@ -1022,10 +1022,14 @@ rm -f $RPM_BUILD_ROOT%{_libdir}/pkgconfig/libcacard.pc
1022
1022
rm -rf $RPM_BUILD_ROOT%{_includedir}/cacard
1023
1023
%endif
1024
1024
1025
- # When building using 'rpmbuild' or 'fedpkg local', RPATHs are left in
1025
+ # When building using 'rpmbuild' or 'fedpkg local', RPATHs can be left in
1026
1026
# the binaries and libraries (although this doesn't occur when
1027
- # building in Koji, for some unknown reason). In any case it should
1028
- # always be safe to remove RPATHs from the final binaries:
1027
+ # building in Koji, for some unknown reason). Some discussion here:
1028
+ #
1029
+ # https://lists.fedoraproject.org/pipermail/devel/2013-November/192553.html
1030
+ #
1031
+ # In any case it should always be safe to remove RPATHs from
1032
+ # the final binaries:
1029
1033
for f in $RPM_BUILD_ROOT%{_bindir}/* $RPM_BUILD_ROOT%{_libdir}/* \
1030
1034
$RPM_BUILD_ROOT%{_libexecdir}/*; do
1031
1035
if file $f | grep -q ELF; then chrpath --delete $f; fi