pengqianheng / rpms / kernel

Forked from rpms/kernel 2 years ago
Clone

060238 import kernel-3.10.0-327.18.2.el7

Authored and Committed by centosrcm 8 years ago
    import kernel-3.10.0-327.18.2.el7
    
        
file modified
+1 -4
.gitignore CHANGED
@@ -1,7 +1,4 @@
1
1
SOURCES/kernel-abi-whitelists-327.tar.bz2
2
- SOURCES/linux-3.10.0-327.13.1.el7.tar.xz
2
+ SOURCES/linux-3.10.0-327.18.2.el7.tar.xz
3
3
SOURCES/rheldup3.x509
4
4
SOURCES/rhelkpatch1.x509
5
- SOURCES/centos-kpatch.x509
6
- SOURCES/centos-ldup.x509
7
- SOURCES/centos.cer
file modified
+1 -4
.kernel.metadata CHANGED
@@ -1,7 +1,4 @@
1
1
39566b205b3d6870a6224a07b9757807bc2ff407 SOURCES/kernel-abi-whitelists-327.tar.bz2
2
- efaca44434c3c9426149c4dc85b24605cc38dc23 SOURCES/linux-3.10.0-327.13.1.el7.tar.xz
2
+ 55fb67d010de128c721b8b4ef224af02e49e7514 SOURCES/linux-3.10.0-327.18.2.el7.tar.xz
3
3
95b9b811c7b0a6c98b2eafc4e7d6d24f2cb63289 SOURCES/rheldup3.x509
4
4
d90885108d225a234a5a9d054fc80893a5bd54d0 SOURCES/rhelkpatch1.x509
5
- 5a7d05a8298cf38d43689470e8e43230d8add0f9 SOURCES/centos-kpatch.x509
6
- c61172887746663d3bdd9acaa263cbfacf99e8b3 SOURCES/centos-ldup.x509
7
- 6e9105eb51e55a46761838f289a917611cad8091 SOURCES/centos.cer
file modified
+1 -1
SOURCES/Makefile.common CHANGED
@@ -9,7 +9,7 @@ RPMVERSION:=3.10.0
9
9
# marker is git tag which we base off of for exporting patches
10
10
MARKER:=v3.10
11
11
PREBUILD:=
12
- BUILD:=327.13.1
12
+ BUILD:=327.18.2
13
13
DIST:=.el7
14
14
SPECFILE:=kernel.spec
15
15
RPM:=$(REDHAT)/rpm
SOURCES/debrand-rh-i686-cpu.patch DELETED
@@ -1,11 +0,0 @@
1
- --- a/arch/x86/boot/main.c 2014-06-04 10:05:04.000000000 -0700
2
- +++ b/arch/x86/boot/main.c 2014-07-09 12:54:40.000000000 -0700
3
- @@ -146,7 +146,7 @@ void main(void)
4
-
5
- /* Make sure we have all the proper CPU support */
6
- if (validate_cpu()) {
7
- - puts("This processor is unsupported in RHEL7.\n");
8
- + puts("This processor is unsupported in CentOS 7.\n");
9
- die();
10
- }
11
-
SOURCES/debrand-rh_taint.patch DELETED
@@ -1,25 +0,0 @@
1
- From 69c0d42cfa26515196896dea086857c2caccb6eb Mon Sep 17 00:00:00 2001
2
- From: Jim Perrin <jperrin@centos.org>
3
- Date: Thu, 19 Jun 2014 10:05:12 -0500
4
- Subject: [PATCH] branding patch for rh_taint
5
-
6
- ---
7
- kernel/rh_taint.c | 2 +-
8
- 1 file changed, 1 insertion(+), 1 deletion(-)
9
-
10
- diff --git a/kernel/rh_taint.c b/kernel/rh_taint.c
11
- index 59a74b0..0708e15 100644
12
- --- a/kernel/rh_taint.c
13
- +++ b/kernel/rh_taint.c
14
- @@ -8,7 +8,7 @@
15
- void mark_hardware_unsupported(const char *msg)
16
- {
17
- /* Print one single message */
18
- - pr_crit("Warning: %s - this hardware has not undergone testing by Red Hat and might not be certified. Please consult https://hardware.redhat.com for certified hardware.\n", msg);
19
- + pr_crit("Warning: %s - this hardware has not undergone upstream testing. Please consult http://wiki.centos.org/FAQ for more information\n", msg);
20
- }
21
- EXPORT_SYMBOL(mark_hardware_unsupported);
22
-
23
- --
24
- 1.8.3.1
25
-
SOURCES/debrand-single-cpu.patch DELETED
@@ -1,25 +0,0 @@
1
- From 66185f5c6f881847776702e3a7956c504400f4f2 Mon Sep 17 00:00:00 2001
2
- From: Jim Perrin <jperrin@centos.org>
3
- Date: Thu, 19 Jun 2014 09:53:13 -0500
4
- Subject: [PATCH] branding patch for single-cpu systems
5
-
6
- ---
7
- arch/x86/kernel/setup.c | 2 +-
8
- 1 file changed, 1 insertion(+), 1 deletion(-)
9
-
10
- diff --git a/arch/x86/kernel/setup.c b/arch/x86/kernel/setup.c
11
- index b289118..9d25982 100644
12
- --- a/arch/x86/kernel/setup.c
13
- +++ b/arch/x86/kernel/setup.c
14
- @@ -846,7 +846,7 @@ static void rh_check_supported(void)
15
- if (((boot_cpu_data.x86_max_cores * smp_num_siblings) == 1) &&
16
- !x86_hyper && !cpu_has_hypervisor && !is_kdump_kernel()) {
17
- pr_crit("Detected single cpu native boot.\n");
18
- - pr_crit("Important: In Red Hat Enterprise Linux 7, single threaded, single CPU 64-bit physical systems are unsupported by Red Hat. Please contact your Red Hat support representative for a list of certified and supported systems.");
19
- + pr_crit("Important: In CentOS 7, single threaded, single CPU 64-bit physical systems are unsupported. Please see http://wiki.centos.org/FAQ for more information");
20
- }
21
-
22
- /* The RHEL7 kernel does not support this hardware. The kernel will
23
- --
24
- 1.8.3.1
25
-
file modified
+3 -3
SOURCES/x509.genkey CHANGED
@@ -5,9 +5,9 @@ prompt = no
5
5
x509_extensions = myexts
6
6
7
7
[ req_distinguished_name ]
8
- O = CentOS
9
- CN = CentOS Linux kernel signing key
10
- emailAddress = security@centos.org
8
+ O = Red Hat
9
+ CN = Red Hat Enterprise Linux kernel signing key
10
+ emailAddress = secalert@redhat.com
11
11
12
12
[ myexts ]
13
13
basicConstraints=critical,CA:FALSE
file modified
+87 -17
SPECS/kernel.spec CHANGED
@@ -12,7 +12,7 @@ Summary: The Linux kernel
12
12
%global distro_build 327
13
13
14
14
%define rpmversion 3.10.0
15
- %define pkgrelease 327.13.1.el7
15
+ %define pkgrelease 327.18.2.el7
16
16
17
17
%define pkg_release %{pkgrelease}%{?buildid}
18
18
@@ -339,16 +339,16 @@ Source10: sign-modules
339
339
Source11: x509.genkey
340
340
Source12: extra_certificates
341
341
%if %{?released_kernel}
342
- Source13: centos.cer
342
+ Source13: securebootca.cer
343
343
Source14: secureboot.cer
344
344
%define pesign_name redhatsecureboot301
345
345
%else
346
- Source13: centos.cer
347
- Source14: secureboot.cer
346
+ Source13: redhatsecurebootca2.cer
347
+ Source14: redhatsecureboot003.cer
348
348
%define pesign_name redhatsecureboot003
349
349
%endif
350
- Source15: centos-ldup.x509
351
- Source16: centos-kpatch.x509
350
+ Source15: rheldup3.x509
351
+ Source16: rhelkpatch1.x509
352
352
353
353
Source18: check-kabi
354
354
@@ -377,9 +377,6 @@ Source2001: cpupower.config
377
377
378
378
# empty final patch to facilitate testing of kernel patches
379
379
Patch999999: linux-kernel-test.patch
380
- Patch1000: debrand-single-cpu.patch
381
- Patch1001: debrand-rh_taint.patch
382
- Patch1002: debrand-rh-i686-cpu.patch
383
380
384
381
BuildRoot: %{_tmppath}/kernel-%{KVRA}-root
385
382
@@ -541,11 +538,11 @@ kernel-gcov includes the gcov graph and source files for gcov coverage collectio
541
538
%endif
542
539
543
540
%package -n kernel-abi-whitelists
544
- Summary: The CentOS Linux kernel ABI symbol whitelists
541
+ Summary: The Red Hat Enterprise Linux kernel ABI symbol whitelists
545
542
Group: System Environment/Kernel
546
543
AutoReqProv: no
547
544
%description -n kernel-abi-whitelists
548
- The kABI package contains information pertaining to the CentOS
545
+ The kABI package contains information pertaining to the Red Hat Enterprise
549
546
Linux kernel ABI, including lists of kernel symbols that are needed by
550
547
external Linux kernel modules, and a yum plugin to aid enforcement.
551
548
@@ -688,9 +685,6 @@ cd linux-%{KVRA}
688
685
cp $RPM_SOURCE_DIR/kernel-%{version}-*.config .
689
686
690
687
ApplyOptionalPatch linux-kernel-test.patch
691
- ApplyOptionalPatch debrand-single-cpu.patch
692
- ApplyOptionalPatch debrand-rh_taint.patch
693
- ApplyOptionalPatch debrand-rh-i686-cpu.patch
694
688
695
689
# Any further pre-build tree manipulations happen here.
696
690
@@ -849,7 +843,7 @@ BuildKernel() {
849
843
fi
850
844
# EFI SecureBoot signing, x86_64-only
851
845
%ifarch x86_64
852
- %pesign -s -i $KernelImage -o $KernelImage.signed -a %{SOURCE13} -c %{SOURCE13}
846
+ %pesign -s -i $KernelImage -o $KernelImage.signed -a %{SOURCE13} -c %{SOURCE14} -n %{pesign_name}
853
847
mv $KernelImage.signed $KernelImage
854
848
%endif
855
849
$CopyKernel $KernelImage $RPM_BUILD_ROOT/%{image_install_path}/$InstallName-$KernelVer
@@ -1536,8 +1530,84 @@ fi
1536
1530
%kernel_variant_files %{with_kdump} kdump
1537
1531
1538
1532
%changelog
1539
- * Thu Mar 31 2016 CentOS Sources <bugs@centos.org> - 3.10.0-327.13.1.el7
1540
- - Apply debranding changes
1533
+ * Fri Apr 08 2016 Alexander Gordeev <agordeev@redhat.com> [3.10.0-327.18.2.el7]
1534
+ - [lib] keys: Fix ASN.1 indefinite length object parsing (David Howells) [1308814 1308815] {CVE-2016-0758}
1535
+
1536
+ * Mon Apr 04 2016 Alexander Gordeev <agordeev@redhat.com> [3.10.0-327.18.1.el7]
1537
+ - [scsi] bnx2fc: Fix FCP RSP residual parsing (Maurizio Lombardi) [1322279 1306342]
1538
+ - [mm] madvise: fix MADV_WILLNEED on shmem swapouts (Mitsuhiro Tanino) [1319845 1312729]
1539
+ - [scsi] bnx2fc: Remove explicit logouts (Maurizio Lombardi) [1317591 1303027]
1540
+ - [cpufreq] intel_pstate: decrease number of "HWP enabled" messages (David Arcari) [1316821 1310927]
1541
+ - [cpufreq] intel_pstate: enable HWP per CPU (David Arcari) [1316821 1310927]
1542
+ - [scsi] mpt3sas: Fix for Asynchronous completion of timedout IO and task abort of timedout IO (Tomas Henzl) [1316820 1259907]
1543
+ - [scsi] scsi_error: should not get sense for timeout IO in scsi error handler (Tomas Henzl) [1316820 1259907]
1544
+ - [scsi] Revert libiscsi: Reduce locking contention in fast path (Chris Leech) [1316812 1297876]
1545
+ - [powerpc] kvm: book3s_hv: Sanitize special-purpose register values on guest exit (Thomas Huth) [1316636 1313725]
1546
+ - [kernel] sched: Robustify topology setup (Gustavo Duarte) [1316158 1278875]
1547
+ - [kernel] sched: Don't set sd->child to NULL when it is already NULL (Gustavo Duarte) [1316158 1278875]
1548
+ - [ib] mlx5: Fix RC transport send queue overhead computation (Don Dutile) [1313814 1293336]
1549
+ - [block] nvme: default to 4k device page size (David Milburn) [1312399 1245140]
1550
+ - [powerpc] cxl: Fix unbalanced pci_dev_get in cxl_probe (Gustavo Duarte) [1312396 1288112]
1551
+ - [powerpc] eeh: Probe after unbalanced kref check (Gustavo Duarte) [1312396 1288112]
1552
+ - [fs] nfsd: fix clp->cl_revoked list deletion causing softlock in nfsd (J. Bruce Fields) [1311582 1300023]
1553
+ - [kernel] sched/fair: Disable tg load_avg/runnable_avg update for root_task_group (Jiri Olsa) [1306317 1289261]
1554
+ - [kernel] sched/fair: Move hot load_avg/runnable_avg into separate cacheline (Jiri Olsa) [1306317 1289261]
1555
+
1556
+ * Thu Mar 31 2016 Alexander Gordeev <agordeev@redhat.com> [3.10.0-327.17.1.el7]
1557
+ - [fs] ceph: make fsync() wait unsafe requests that created/modified inode (Zheng Yan) [1320033 1291193]
1558
+ - [fs] ceph: add request to i_unsafe_dirops when getting unsafe reply (Zheng Yan) [1320033 1291193]
1559
+ - [fs] ceph: don't invalidate page cache when inode is no longer used (Zheng Yan) [1320033 1291193]
1560
+ - [fs] ceph: fix message length computation (Zheng Yan) [1320033 1291193]
1561
+ - [fs] ceph: improve readahead for file holes (Zheng Yan) [1320033 1291193]
1562
+ - [fs] ceph: get inode size for each append write (Zheng Yan) [1320033 1291193]
1563
+ - [fs] ceph: cleanup use of ceph_msg_get (Zheng Yan) [1320033 1291193]
1564
+ - [fs] ceph: no need to get parent inode in ceph_open (Zheng Yan) [1320033 1291193]
1565
+ - [fs] ceph: remove the useless judgement (Zheng Yan) [1320033 1291193]
1566
+ - [fs] ceph: remove redundant test of head->safe and silence static analysis warnings (Zheng Yan) [1320033 1291193]
1567
+ - [fs] ceph: fix queuing inode to mdsdir's snaprealm (Zheng Yan) [1320033 1291193]
1568
+ - [fs] ceph: invalidate dirty pages after forced umount (Zheng Yan) [1320033 1291193]
1569
+ - [fs] ceph: EIO all operations after forced umount (Zheng Yan) [1320033 1291193]
1570
+ - [fs] ceph: always re-send cap flushes when MDS recovers (Zheng Yan) [1320033 1291193]
1571
+ - [fs] ceph: fix ceph_writepages_start() (Zheng Yan) [1320033 1291193]
1572
+ - [fs] ceph: switch some GFP_NOFS memory allocation to GFP_KERNEL (Zheng Yan) [1320033 1291193]
1573
+ - [fs] ceph: pre-allocate data structure that tracks caps flushing (Zheng Yan) [1320033 1291193]
1574
+ - [fs] ceph: re-send flushing caps (which are revoked) in reconnect stage (Zheng Yan) [1320033 1291193]
1575
+ - [fs] ceph: send TID of the oldest pending caps flush to MDS (Zheng Yan) [1320033 1291193]
1576
+ - [fs] ceph: track pending caps flushing globally (Zheng Yan) [1320033 1291193]
1577
+ - [fs] ceph: track pending caps flushing accurately (Zheng Yan) [1320033 1291193]
1578
+ - [fs] ceph: fix directory fsync (Zheng Yan) [1320033 1291193]
1579
+ - [fs] ceph: fix flushing caps (Zheng Yan) [1320033 1291193]
1580
+ - [fs] ceph: don't include used caps in cap_wanted (Zheng Yan) [1320033 1291193]
1581
+ - [fs] ceph: ratelimit warn messages for MDS closes session (Zheng Yan) [1320033 1291193]
1582
+ - [fs] ceph: simplify two mount_timeout sites (Zheng Yan) [1320033 1291193]
1583
+ - [fs] libceph: store timeouts in jiffies, verify user input (Zheng Yan) [1320033 1291193]
1584
+ - [fs] ceph: exclude setfilelock requests when calculating oldest tid (Zheng Yan) [1320033 1291193]
1585
+ - [fs] ceph: don't pre-allocate space for cap release messages (Zheng Yan) [1320033 1291193]
1586
+ - [fs] ceph: make sure syncfs flushes all cap snaps (Zheng Yan) [1320033 1291193]
1587
+ - [fs] ceph: don't trim auth cap when there are cap snaps (Zheng Yan) [1320033 1291193]
1588
+ - [fs] ceph: take snap_rwsem when accessing snap realm's cached_context (Zheng Yan) [1320033 1291193]
1589
+ - [fs] ceph: avoid sending unnessesary FLUSHSNAP message (Zheng Yan) [1320033 1291193]
1590
+ - [fs] ceph: set i_head_snapc when getting CEPH_CAP_FILE_WR reference (Zheng Yan) [1320033 1291193]
1591
+ - [fs] ceph: use empty snap context for uninline_data and get_pool_perm (Zheng Yan) [1320033 1291193]
1592
+ - [fs] ceph: check OSD caps before read/write (Zheng Yan) [1320033 1291193]
1593
+ - [fs] libceph: allow setting osd_req_op's flags (Zheng Yan) [1320033 1291193]
1594
+
1595
+ * Fri Mar 25 2016 Alexander Gordeev <agordeev@redhat.com> [3.10.0-327.16.1.el7]
1596
+ - [tty] pty: make sure super_block is still valid in final /dev/tty close (Herton R. Krzesinski) [1320297 1291313]
1597
+ - [tty] pty: fix possible use after free of tty->driver_data (Herton R. Krzesinski) [1320297 1291313]
1598
+
1599
+ * Mon Mar 21 2016 Alexander Gordeev <agordeev@redhat.com> [3.10.0-327.15.1.el7]
1600
+ - [netdrv] sfc: push partner queue for skb->xmit_more (Jarod Wilson) [1318323 1267167]
1601
+ - [netdrv] sfc: replace spinlocks with bit ops for busy poll locking (Jarod Wilson) [1318323 1267167]
1602
+
1603
+ * Wed Mar 16 2016 Alexander Gordeev <agordeev@redhat.com> [3.10.0-327.14.1.el7]
1604
+ - [kernel] sched: Move cpu_active() tests from stop_two_cpus() into migrate_swap_stop() (Oleg Nesterov) [1299338 1252281]
1605
+ - [kernel] stop_machine: Change cpu_stop_queue_two_works() to rely on stopper->enabled (Oleg Nesterov) [1299338 1252281]
1606
+ - [kernel] stop_machine: Introduce __cpu_stop_queue_work() and cpu_stop_queue_two_works() (Oleg Nesterov) [1299338 1252281]
1607
+ - [kernel] stop_machine: Ensure that a queued callback will be called before cpu_stop_park() (Oleg Nesterov) [1299338 1252281]
1608
+ - [kernel] stop_machine: Remove cpu_stop_work's from list in cpu_stop_park() (Oleg Nesterov) [1299338 1252281]
1609
+ - [kernel] stop_machine: Don't do for_each_cpu() twice in queue_stop_cpus_work() (Oleg Nesterov) [1299338 1252281]
1610
+ - [kernel] stop_machine: Move 'cpu_stopper_task' and 'stop_cpus_work' into 'struct cpu_stopper' (Oleg Nesterov) [1299338 1252281]
1541
1611
1542
1612
* Mon Feb 29 2016 Alexander Gordeev <agordeev@redhat.com> [3.10.0-327.13.1.el7]
1543
1613
- [net] veth: don't modify ip_summed; doing so treats packets with bad checksums as good (Sabrina Dubroca) [1312430 1307099]