netgod / rpms / anaconda

Forked from rpms/anaconda 2 years ago
Clone

57c021 import anaconda-33.16.4.13-1.el8

Authored and Committed by centosrcm 3 years ago
    import anaconda-33.16.4.13-1.el8
    
        
file modified
+1 -1
.anaconda.metadata CHANGED
@@ -1 +1 @@
1
- 158b8002285c1ee5d92952ae6931592b461873d4 SOURCES/anaconda-33.16.4.12.tar.bz2
1
+ 764de7981ee1f34eee097f4047eda4fcc6d0cde7 SOURCES/anaconda-33.16.4.13.tar.bz2
file modified
+1 -1
.gitignore CHANGED
@@ -1 +1 @@
1
- SOURCES/anaconda-33.16.4.12.tar.bz2
1
+ SOURCES/anaconda-33.16.4.13.tar.bz2
SOURCES/0001-Add-CentOS-Stream-config.patch DELETED
@@ -1,121 +0,0 @@
1
- From 46aef94345d4c3e5a0be103fcf75650c67cbf14f Mon Sep 17 00:00:00 2001
2
- From: Pat Riehecky <riehecky@fnal.gov>
3
- Date: Mon, 23 Nov 2020 13:50:06 -0600
4
- Subject: [PATCH 1/2] Add CentOS Stream config
5
-
6
- https://github.com/rhinstaller/anaconda/pull/3014
7
- https://github.com/rhinstaller/anaconda/commit/150bbc179cf51226d6c1bd46279e076ff683ec03
8
- ---
9
- data/product.d/centos-stream.conf | 33 +++++++++++++++++++
10
- data/product.d/centos.conf | 28 +---------------
11
- .../pyanaconda_tests/product_test.py | 9 +++--
12
- 3 files changed, 41 insertions(+), 29 deletions(-)
13
- create mode 100644 data/product.d/centos-stream.conf
14
-
15
- diff --git a/data/product.d/centos-stream.conf b/data/product.d/centos-stream.conf
16
- new file mode 100644
17
- index 0000000000..79d13392af
18
- --- /dev/null
19
- +++ b/data/product.d/centos-stream.conf
20
- @@ -0,0 +1,33 @@
21
- +# Anaconda configuration file for CentOS Stream.
22
- +
23
- +[Product]
24
- +product_name = CentOS Stream
25
- +
26
- +[Base Product]
27
- +product_name = Red Hat Enterprise Linux
28
- +
29
- +[Anaconda]
30
- +# List of enabled Anaconda DBus modules for RHEL.
31
- +# but without org.fedoraproject.Anaconda.Modules.Subscription
32
- +kickstart_modules =
33
- + org.fedoraproject.Anaconda.Modules.Timezone
34
- + org.fedoraproject.Anaconda.Modules.Network
35
- + org.fedoraproject.Anaconda.Modules.Localization
36
- + org.fedoraproject.Anaconda.Modules.Security
37
- + org.fedoraproject.Anaconda.Modules.Users
38
- + org.fedoraproject.Anaconda.Modules.Payloads
39
- + org.fedoraproject.Anaconda.Modules.Storage
40
- + org.fedoraproject.Anaconda.Modules.Services
41
- +
42
- +[Bootloader]
43
- +efi_dir = centos
44
- +
45
- +[User Interface]
46
- +help_directory = /usr/share/anaconda/help/centos
47
- +default_help_pages =
48
- + centos_help_placeholder.txt
49
- + centos_help_placeholder.xml
50
- + centos_help_placeholder.xml
51
- +
52
- +[Payload]
53
- +default_source = CLOSEST_MIRROR
54
- diff --git a/data/product.d/centos.conf b/data/product.d/centos.conf
55
- index 9490e038a9..dcf22c3f9d 100644
56
- --- a/data/product.d/centos.conf
57
- +++ b/data/product.d/centos.conf
58
- @@ -4,30 +4,4 @@
59
- product_name = CentOS Linux
60
-
61
- [Base Product]
62
- -product_name = Red Hat Enterprise Linux
63
- -
64
- -[Anaconda]
65
- -# List of enabled Anaconda DBus modules for RHEL.
66
- -# but without org.fedoraproject.Anaconda.Modules.Subscription
67
- -kickstart_modules =
68
- - org.fedoraproject.Anaconda.Modules.Timezone
69
- - org.fedoraproject.Anaconda.Modules.Network
70
- - org.fedoraproject.Anaconda.Modules.Localization
71
- - org.fedoraproject.Anaconda.Modules.Security
72
- - org.fedoraproject.Anaconda.Modules.Users
73
- - org.fedoraproject.Anaconda.Modules.Payloads
74
- - org.fedoraproject.Anaconda.Modules.Storage
75
- - org.fedoraproject.Anaconda.Modules.Services
76
- -
77
- -[Bootloader]
78
- -efi_dir = centos
79
- -
80
- -[User Interface]
81
- -help_directory = /usr/share/anaconda/help/centos
82
- -default_help_pages =
83
- - centos_help_placeholder.txt
84
- - centos_help_placeholder.xml
85
- - centos_help_placeholder.xml
86
- -
87
- -[Payload]
88
- -default_source = CLOSEST_MIRROR
89
- +product_name = CentOS Stream
90
- diff --git a/tests/nosetests/pyanaconda_tests/product_test.py b/tests/nosetests/pyanaconda_tests/product_test.py
91
- index 55f3e0dde7..45d532bda1 100644
92
- --- a/tests/nosetests/pyanaconda_tests/product_test.py
93
- +++ b/tests/nosetests/pyanaconda_tests/product_test.py
94
- @@ -239,9 +239,14 @@ class ProductConfigurationTestCase(unittest.TestCase):
95
- ["rhel.conf"],
96
- WORKSTATION_PARTITIONING
97
- )
98
- + self._check_default_product(
99
- + "CentOS Stream", "",
100
- + ["rhel.conf", "centos-stream.conf"],
101
- + WORKSTATION_PARTITIONING
102
- + )
103
- self._check_default_product(
104
- "CentOS Linux", "",
105
- - ["rhel.conf", "centos.conf"],
106
- + ["rhel.conf", "centos-stream.conf", "centos.conf"],
107
- WORKSTATION_PARTITIONING
108
- )
109
- self._check_default_product(
110
- @@ -251,7 +256,7 @@ class ProductConfigurationTestCase(unittest.TestCase):
111
- )
112
- self._check_default_product(
113
- "oVirt Node Next", "",
114
- - ["rhel.conf", "centos.conf", "ovirt.conf"],
115
- + ["rhel.conf", "centos-stream.conf", "centos.conf", "ovirt.conf"],
116
- VIRTUALIZATION_PARTITIONING
117
- )
118
- self._check_default_product(
119
- --
120
- 2.29.2
121
-
SOURCES/0002-Fix-CDN-button-visibility.patch DELETED
@@ -1,56 +0,0 @@
1
- From 9efb90902967e207bdca8ac61ab92de54fbae9fe Mon Sep 17 00:00:00 2001
2
- From: Martin Kolman <mkolman@redhat.com>
3
- Date: Fri, 11 Sep 2020 15:27:59 +0200
4
- Subject: [PATCH 2/2] Fix CDN button visibility
5
-
6
- Only show the Red Hat CDN button if the Subscription
7
- module appears to be running. To achieve that, we do
8
- the same thing as with the HMC button - the CDN
9
- button invisible by default. And enable it only if it
10
- looks like the Subscription module is running.
11
-
12
- (cherry picked from commit: aca297587ab8bdd7342fa056273bfff379bc0a0b)
13
-
14
- Resolves: rhbz#1903178
15
-
16
- https://github.com/rhinstaller/anaconda/pull/3020
17
- https://github.com/M4rtinK/anaconda/commit/c29802a2be591a4cdcc91ba86b74fc4d01087b72
18
- ---
19
- pyanaconda/ui/gui/spokes/installation_source.glade | 2 +-
20
- pyanaconda/ui/gui/spokes/installation_source.py | 4 ++--
21
- 2 files changed, 3 insertions(+), 3 deletions(-)
22
-
23
- diff --git a/pyanaconda/ui/gui/spokes/installation_source.glade b/pyanaconda/ui/gui/spokes/installation_source.glade
24
- index a23f8be714..e53fa230ca 100644
25
- --- a/pyanaconda/ui/gui/spokes/installation_source.glade
26
- +++ b/pyanaconda/ui/gui/spokes/installation_source.glade
27
- @@ -633,9 +633,9 @@
28
- <child>
29
- <object class="GtkRadioButton" id="cdnRadioButton">
30
- <property name="label" translatable="yes" context="GUI|Software Source">Red Hat _CDN</property>
31
- - <property name="visible">True</property>
32
- <property name="can_focus">True</property>
33
- <property name="receives_default">False</property>
34
- + <property name="no_show_all">True</property>
35
- <property name="margin_left">12</property>
36
- <property name="use_underline">True</property>
37
- <property name="xalign">0</property>
38
- diff --git a/pyanaconda/ui/gui/spokes/installation_source.py b/pyanaconda/ui/gui/spokes/installation_source.py
39
- index 6aab9b387a..d0d4da72b9 100644
40
- --- a/pyanaconda/ui/gui/spokes/installation_source.py
41
- +++ b/pyanaconda/ui/gui/spokes/installation_source.py
42
- @@ -854,9 +854,9 @@ class SourceSpoke(NormalSpoke, GUISpokeInputCheckHandler, SourceSwitchHandler):
43
- def _initialize(self):
44
- threadMgr.wait(constants.THREAD_PAYLOAD)
45
-
46
- - # If there is no Subscriptiopn DBus module, disable the CDN radio button
47
- + # If there is the Subscriptiopn DBus module, make the CDN radio button visible
48
- if is_module_available(SUBSCRIPTION):
49
- - gtk_call_once(self._cdn_button.set_no_show_all, True)
50
- + gtk_call_once(self._cdn_button.set_no_show_all, False)
51
-
52
- # Get the current source.
53
- source_proxy = self.payload.get_source_proxy()
54
- --
55
- 2.29.2
56
-
file modified
+5 -11
SPECS/anaconda.spec CHANGED
@@ -1,6 +1,6 @@
1
1
Summary: Graphical system installer
2
2
Name: anaconda
3
- Version: 33.16.4.12
3
+ Version: 33.16.4.13
4
4
Release: 1%{?dist}
5
5
License: GPLv2+ and MIT
6
6
URL: http://fedoraproject.org/wiki/Anaconda
@@ -12,13 +12,6 @@ URL: http://fedoraproject.org/wiki/Anaconda
12
12
# make dist
13
13
Source0: %{name}-%{version}.tar.bz2
14
14
15
- # https://github.com/rhinstaller/anaconda/pull/3014
16
- Patch10001: 0001-Add-CentOS-Stream-config.patch
17
-
18
- # https://github.com/rhinstaller/anaconda/pull/3020
19
- Patch10002: 0002-Fix-CDN-button-visibility.patch
20
-
21
-
22
15
# Versions of required components (done so we make sure the buildrequires
23
16
# match the requires versions of things).
24
17
@@ -272,9 +265,6 @@ runtime on NFS/HTTP/FTP servers or local disks.
272
265
%prep
273
266
%autosetup -p 1
274
267
275
- # debranding
276
- sed -e 's/RHEL/CentOS/' -i po/*.po
277
-
278
268
%build
279
269
# use actual build-time release number, not tarball creation time release number
280
270
%configure ANACONDA_RELEASE=%{release}
@@ -377,6 +367,10 @@ desktop-file-install --dir=%{buildroot}%{_datadir}/applications %{buildroot}%{_d
377
367
%{_prefix}/libexec/anaconda/dd_*
378
368
379
369
%changelog
370
+ * Mon Mar 15 2021 Radek Vykydal <rvykydal@redhat.com> - 33.16.4.13-1
371
+ - ostree: ignore exit code 65 for systemd-tmpfiles (christian)
372
+ Resolves: rhbz#1935648
373
+
380
374
* Fri Mar 05 2021 Radek Vykydal <rvykydal@redhat.com> - 33.16.4.12-1
381
375
- Pull in new translations (rvykydal)
382
376
Related: rhbz#1899672