mrc0mmand / rpms / hivex

Forked from rpms/hivex 3 years ago
Clone

ba2470 import hivex-1.3.15-6.module+el8+2564+79985af8

Merged and Committed by centosrcm 5 years ago
    import hivex-1.3.15-6.module+el8+2564+79985af8
    
        
file added
+2
.gitignore ADDED
@@ -0,0 +1,2 @@
1
+ SOURCES/hivex-1.3.15.tar.gz
2
+ SOURCES/libguestfs.keyring
file added
+2
.hivex.metadata ADDED
@@ -0,0 +1,2 @@
1
+ 0b93f6947223bfa16012cb23d29437b8074fd29f SOURCES/hivex-1.3.15.tar.gz
2
+ 1bbc40f501a7fef9eef2a39b701a71aee2fea7c4 SOURCES/libguestfs.keyring
SOURCES/0001-ocaml-Link-the-C-bindings-with-LDFLAGS-RHBZ-1548536.patch ADDED
@@ -0,0 +1,48 @@
1
+ From be51757920b56a77e2e63247f9a8409ce994d33c Mon Sep 17 00:00:00 2001
2
+ From: "Richard W.M. Jones" <rjones@redhat.com>
3
+ Date: Mon, 26 Feb 2018 12:38:12 +0000
4
+ Subject: [PATCH] ocaml: Link the C bindings with LDFLAGS (RHBZ#1548536).
5
+
6
+ Use the ocamlmklib -ldopt flag to pass the general $(LDFLAGS) when
7
+ calling gcc to link dllmlhivex.so. We were already passing $(CFLAGS)
8
+ when building the object file.
9
+
10
+ When building using Fedora's standard hardening flags this gives:
11
+
12
+ ocamlmklib -o mlhivex hivex_c.o hivex.cmo \
13
+ -verbose -ldopt '-Wl,-z,relro -specs=/usr/lib/rpm/redhat/redhat-hardened-ld' \
14
+ -L../lib/.libs -lhivex
15
+ + gcc -shared -o ./dllmlhivex.so hivex_c.o -Wl,-z,relro -specs=/usr/lib/rpm/redhat/redhat-hardened-ld -L../lib/.libs -lhivex
16
+ + ar rc ./libmlhivex.a hivex_c.o; ranlib ./libmlhivex.a
17
+ + /usr/bin/ocamlc -a -o mlhivex.cma hivex.cmo -dllib -lmlhivex -cclib -lmlhivex -cclib -L../lib/.libs -cclib -lhivex
18
+
19
+ This also works if $(LDFLAGS) is empty, because ocamlmklib ignores
20
+ -ldopt ''.
21
+ ---
22
+ ocaml/Makefile.am | 8 ++++++--
23
+ 1 file changed, 6 insertions(+), 2 deletions(-)
24
+
25
+ diff --git a/ocaml/Makefile.am b/ocaml/Makefile.am
26
+ index 61db095..85655b6 100644
27
+ --- a/ocaml/Makefile.am
28
+ +++ b/ocaml/Makefile.am
29
+ @@ -41,10 +41,14 @@ OBJS = hivex_c.o hivex.cmo
30
+ XOBJS = $(OBJS:.cmo=.cmx)
31
+
32
+ mlhivex.cma: $(OBJS)
33
+ - $(OCAMLMKLIB) -o mlhivex $^ -L$(top_builddir)/lib/.libs -lhivex
34
+ + $(OCAMLMKLIB) -o mlhivex $^ \
35
+ + -ldopt '$(LDFLAGS)' \
36
+ + -L$(top_builddir)/lib/.libs -lhivex
37
+
38
+ mlhivex.cmxa: $(XOBJS)
39
+ - $(OCAMLMKLIB) -o mlhivex $^ -L$(top_builddir)/lib/.libs -lhivex
40
+ + $(OCAMLMKLIB) -o mlhivex $^ \
41
+ + -ldopt '$(LDFLAGS)' \
42
+ + -L$(top_builddir)/lib/.libs -lhivex
43
+
44
+ hivex_c.o: hivex_c.c
45
+ $(CC) $(AM_CPPFLAGS) $(CFLAGS) -fPIC -Wall -c $<
46
+ --
47
+ 2.13.2
48
+
SOURCES/hivex-1.3.15.tar.gz.sig ADDED
@@ -0,0 +1,16 @@
1
+ -----BEGIN PGP SIGNATURE-----
2
+
3
+ iQIcBAABAgAGBQJalDSOAAoJEJFzj3Pht2igdNYP/2R2+SkPNutZfQpUZfiKD/vQ
4
+ RRAQjePYncUjNUc2WgX7LXmJN1z9WfKRzUGqQG7sD/B7BnecBtEOP4Dyw5PpjgBQ
5
+ ae4ErdeU6uFv5xSiprnYErfGJrhYSBfDKilDjrdO7J4AlTlVVlgfeb7C5TopER81
6
+ brVJ7iXuF6rbZmQP3c0D3GWdez3Nw719e6MmdM9FFGQQS8hg9vZlNYQPyiFEQx1U
7
+ nNjSMaoft+OWYEQp56arjPOLj4JiIcIH9B/HLu8Tcl4FEogTCVyMsodyEFXzfBUm
8
+ 21UfIn/RNEXjI8DJ/k7kh35uWEwv8hb/0YszGAWNpSt+rrdx9+decjNdNI2DZs65
9
+ XEcuboWN7UOZJf2p+8f78QVcbwNPRjpnfGZaVLYJYNON3y/lyvhrA8je5FOzsyVA
10
+ 4G6BwU3ythoS2NTK3Q76I7UdMDvz6vydgsLAruVVtMX5x1M7fXoplRxi1nkRjCvQ
11
+ Qgmo0L/rwwDUitRmlRyyJqZK7j+lMlltuZAck9XCUtd72VRAUj4f56I8Xo2wwT0Y
12
+ ioFer6o02K18pjhGLikV4ujUUKAkC1lAK1QhsEsp7y2isOe1mA3ptcGrz4rElcaH
13
+ f78Yr7b28Gl9HSGg98uhYEwWVCl5fUwXhDUQVVNutDRPKI479O390uGG7ZNZTghS
14
+ Lv/P/Uz1ijp+m8Hi5WsX
15
+ =gmjv
16
+ -----END PGP SIGNATURE-----
file added
+660
SPECS/hivex.spec ADDED
@@ -0,0 +1,660 @@
1
+ # Conditionalize Ocaml support. This looks ass-backwards, but it's not.
2
+ %ifarch %{ocaml_native_compiler}
3
+ %bcond_without ocaml
4
+ %else
5
+ %bcond_with ocaml
6
+ %endif
7
+
8
+ # Verify tarball signature with GPGv2.
9
+ %global verify_tarball_signature 1
10
+
11
+ Name: hivex
12
+ Version: 1.3.15
13
+ Release: 6%{?dist}
14
+ Summary: Read and write Windows Registry binary hive files
15
+
16
+ License: LGPLv2
17
+ URL: http://libguestfs.org/
18
+
19
+ Source0: http://libguestfs.org/download/hivex/%{name}-%{version}.tar.gz
20
+ %if 0%{verify_tarball_signature}
21
+ Source1: http://libguestfs.org/download/hivex/%{name}-%{version}.tar.gz.sig
22
+ %endif
23
+
24
+ # Keyring used to verify tarball signature.
25
+ %if 0%{verify_tarball_signature}
26
+ Source2: libguestfs.keyring
27
+ %endif
28
+
29
+ # Upstream patch to fix injection of LDFLAGS.
30
+ # https://bugzilla.redhat.com/show_bug.cgi?id=1548536
31
+ Patch1: 0001-ocaml-Link-the-C-bindings-with-LDFLAGS-RHBZ-1548536.patch
32
+ BuildRequires: autoconf, automake, libtool, gettext-devel
33
+
34
+ BuildRequires: perl-interpreter
35
+ BuildRequires: perl-devel
36
+ BuildRequires: perl-generators
37
+ BuildRequires: %{_bindir}/pod2html
38
+ BuildRequires: %{_bindir}/pod2man
39
+ BuildRequires: perl(bytes)
40
+ BuildRequires: perl(Carp)
41
+ BuildRequires: perl(Encode)
42
+ BuildRequires: perl(ExtUtils::MakeMaker)
43
+ BuildRequires: perl(Exporter)
44
+ BuildRequires: perl(IO::Scalar)
45
+ BuildRequires: perl(IO::Stringy)
46
+ BuildRequires: perl(strict)
47
+ BuildRequires: perl(Test::More)
48
+ BuildRequires: perl(utf8)
49
+ BuildRequires: perl(vars)
50
+ BuildRequires: perl(warnings)
51
+ BuildRequires: perl(XSLoader)
52
+ BuildRequires: perl(Test::Pod) >= 1.00
53
+ BuildRequires: perl(Test::Pod::Coverage) >= 1.00
54
+ %if %{with ocaml}
55
+ BuildRequires: ocaml
56
+ BuildRequires: ocaml-findlib-devel
57
+ %endif
58
+ BuildRequires: python3-devel
59
+ BuildRequires: ruby-devel
60
+ BuildRequires: rubygem-rake
61
+ # see also RHBZ#1325022
62
+ BuildRequires: rubygem(json)
63
+ BuildRequires: rubygem(minitest)
64
+ BuildRequires: rubygem(rdoc)
65
+ BuildRequires: readline-devel
66
+ BuildRequires: libxml2-devel
67
+ %if 0%{verify_tarball_signature}
68
+ BuildRequires: gnupg2
69
+ %endif
70
+
71
+ # https://fedoraproject.org/wiki/Packaging:No_Bundled_Libraries#Packages_granted_exceptions
72
+ Provides: bundled(gnulib)
73
+
74
+
75
+ %description
76
+ Hive files are the undocumented binary files that Windows uses to
77
+ store the Windows Registry on disk. Hivex is a library that can read
78
+ and write to these files.
79
+
80
+ 'hivexsh' is a shell you can use to interactively navigate a hive
81
+ binary file.
82
+
83
+ 'hivexregedit' (in perl-hivex) lets you export and merge to the
84
+ textual regedit format.
85
+
86
+ 'hivexml' can be used to convert a hive file to a more useful XML
87
+ format.
88
+
89
+ In order to get access to the hive files themselves, you can copy them
90
+ from a Windows machine. They are usually found in
91
+ %%systemroot%%\system32\config. For virtual machines we recommend
92
+ using libguestfs or guestfish to copy out these files. libguestfs
93
+ also provides a useful high-level tool called 'virt-win-reg' (based on
94
+ hivex technology) which can be used to query specific registry keys in
95
+ an existing Windows VM.
96
+
97
+ For OCaml bindings, see 'ocaml-hivex-devel'.
98
+
99
+ For Perl bindings, see 'perl-hivex'.
100
+
101
+ For Python 3 bindings, see 'python3-hivex'.
102
+
103
+ For Ruby bindings, see 'ruby-hivex'.
104
+
105
+
106
+ %package devel
107
+ Summary: Development tools and libraries for %{name}
108
+ Requires: %{name} = %{version}-%{release}
109
+ Requires: pkgconfig
110
+
111
+
112
+ %description devel
113
+ %{name}-devel contains development tools and libraries
114
+ for %{name}.
115
+
116
+
117
+ %if %{with ocaml}
118
+ %package -n ocaml-%{name}
119
+ Summary: OCaml bindings for %{name}
120
+ Requires: %{name} = %{version}-%{release}
121
+
122
+
123
+ %description -n ocaml-%{name}
124
+ ocaml-%{name} contains OCaml bindings for %{name}.
125
+
126
+ This is for toplevel and scripting access only. To compile OCaml
127
+ programs which use %{name} you will also need ocaml-%{name}-devel.
128
+
129
+
130
+ %package -n ocaml-%{name}-devel
131
+ Summary: OCaml bindings for %{name}
132
+ Requires: ocaml-%{name} = %{version}-%{release}
133
+ Requires: %{name}-devel = %{version}-%{release}
134
+
135
+
136
+ %description -n ocaml-%{name}-devel
137
+ ocaml-%{name}-devel contains development libraries
138
+ required to use the OCaml bindings for %{name}.
139
+ %endif
140
+
141
+
142
+ %package -n perl-%{name}
143
+ Summary: Perl bindings for %{name}
144
+ Requires: %{name} = %{version}-%{release}
145
+ Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
146
+
147
+
148
+ %description -n perl-%{name}
149
+ perl-%{name} contains Perl bindings for %{name}.
150
+
151
+
152
+ %package -n python3-%{name}
153
+ Summary: Python 3 bindings for %{name}
154
+ Requires: %{name} = %{version}-%{release}
155
+
156
+ %description -n python3-%{name}
157
+ python3-%{name} contains Python 3 bindings for %{name}.
158
+
159
+
160
+ %package -n ruby-%{name}
161
+ Summary: Ruby bindings for %{name}
162
+ Requires: %{name} = %{version}-%{release}
163
+ Requires: ruby(release)
164
+ Requires: ruby
165
+ Provides: ruby(hivex) = %{version}
166
+
167
+ %description -n ruby-%{name}
168
+ ruby-%{name} contains Ruby bindings for %{name}.
169
+
170
+
171
+ %prep
172
+ %if 0%{verify_tarball_signature}
173
+ tmphome="$(mktemp -d)"
174
+ gpgv2 --homedir "$tmphome" --keyring %{SOURCE2} %{SOURCE1} %{SOURCE0}
175
+ %endif
176
+ %setup -q
177
+ %autopatch -p1
178
+
179
+ # Because the patch touches Makefile.am, rerun autotools.
180
+ autoreconf -i -f
181
+
182
+
183
+ %build
184
+ %configure \
185
+ PYTHON=/usr/bin/python3 \
186
+ --disable-static \
187
+ %if !%{with ocaml}
188
+ --disable-ocaml \
189
+ %endif
190
+ %{nil}
191
+ make V=1 INSTALLDIRS=vendor %{?_smp_mflags}
192
+
193
+
194
+ %install
195
+ make install DESTDIR=$RPM_BUILD_ROOT INSTALLDIRS=vendor
196
+
197
+ # Remove unwanted libtool *.la file:
198
+ rm $RPM_BUILD_ROOT%{_libdir}/libhivex.la
199
+
200
+ # Remove unwanted Perl files:
201
+ find $RPM_BUILD_ROOT -name perllocal.pod -delete
202
+ find $RPM_BUILD_ROOT -name .packlist -delete
203
+ find $RPM_BUILD_ROOT -name '*.bs' -delete
204
+
205
+ # Remove unwanted Python files:
206
+ rm $RPM_BUILD_ROOT%{python3_sitearch}/libhivexmod.la
207
+
208
+ %find_lang %{name}
209
+
210
+
211
+ %check
212
+ make check
213
+
214
+
215
+ %post -p /sbin/ldconfig
216
+
217
+ %postun -p /sbin/ldconfig
218
+
219
+
220
+ %files -f %{name}.lang
221
+ %doc README LICENSE
222
+ %{_bindir}/hivexget
223
+ %{_bindir}/hivexml
224
+ %{_bindir}/hivexsh
225
+ %{_libdir}/libhivex.so.*
226
+ %{_mandir}/man1/hivexget.1*
227
+ %{_mandir}/man1/hivexml.1*
228
+ %{_mandir}/man1/hivexsh.1*
229
+
230
+
231
+ %files devel
232
+ %doc LICENSE
233
+ %{_libdir}/libhivex.so
234
+ %{_mandir}/man3/hivex.3*
235
+ %{_includedir}/hivex.h
236
+ %{_libdir}/pkgconfig/hivex.pc
237
+
238
+
239
+ %if %{with ocaml}
240
+ %files -n ocaml-%{name}
241
+ %doc README
242
+ %{_libdir}/ocaml/hivex
243
+ %exclude %{_libdir}/ocaml/hivex/*.a
244
+ %exclude %{_libdir}/ocaml/hivex/*.cmxa
245
+ %exclude %{_libdir}/ocaml/hivex/*.cmx
246
+ %exclude %{_libdir}/ocaml/hivex/*.mli
247
+ %{_libdir}/ocaml/stublibs/*.so
248
+ %{_libdir}/ocaml/stublibs/*.so.owner
249
+
250
+
251
+ %files -n ocaml-%{name}-devel
252
+ %{_libdir}/ocaml/hivex/*.a
253
+ %{_libdir}/ocaml/hivex/*.cmxa
254
+ %{_libdir}/ocaml/hivex/*.cmx
255
+ %{_libdir}/ocaml/hivex/*.mli
256
+ %endif
257
+
258
+
259
+ %files -n perl-%{name}
260
+ %{perl_vendorarch}/*
261
+ %{_mandir}/man3/Win::Hivex.3pm*
262
+ %{_mandir}/man3/Win::Hivex::Regedit.3pm*
263
+ %{_bindir}/hivexregedit
264
+ %{_mandir}/man1/hivexregedit.1*
265
+
266
+
267
+ %files -n python3-%{name}
268
+ %{python3_sitearch}/hivex/
269
+ %{python3_sitearch}/*.so
270
+
271
+
272
+ %files -n ruby-%{name}
273
+ %doc ruby/doc/site/*
274
+ %{ruby_vendorlibdir}/hivex.rb
275
+ %{ruby_vendorarchdir}/_hivex.so
276
+
277
+
278
+ %changelog
279
+ * Fri Dec 14 2018 Richard W.M. Jones <rjones@redhat.com> - 1.3.15-6
280
+ - Drop hivex-static subpackage
281
+ resolves: rhbz#1560207
282
+
283
+ * Fri Jul 20 2018 Richard W.M. Jones <rjones@redhat.com> - 1.3.15-5
284
+ - Rebuild for OCaml 4.07.0.
285
+
286
+ * Fri Mar 23 2018 Richard W.M. Jones <rjones@redhat.com> - 1.3.15-4
287
+ - Remove python2 support
288
+ resolves: rhbz#1559086
289
+
290
+ * Mon Mar 19 2018 Richard W.M. Jones <rjones@redhat.com> - 1.3.15-3
291
+ - Add upstream patch to fix injection of LDFLAGS (RHBZ#1548536).
292
+
293
+ * Thu Mar 1 2018 Florian Weimer <fweimer@redhat.com> - 1.3.15-2
294
+ - Rebuild with new redhat-rpm-config/perl build flags
295
+
296
+ * Mon Feb 26 2018 Richard W.M. Jones <rjones@redhat.com> - 1.3.15-1
297
+ - New upstream version 1.3.15.
298
+
299
+ * Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.3.14-15
300
+ - Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
301
+
302
+ * Sat Jan 20 2018 Björn Esser <besser82@fedoraproject.org> - 1.3.14-14
303
+ - Rebuilt for switch to libxcrypt
304
+
305
+ * Fri Jan 05 2018 Mamoru TASAKA <mtasaka@fedoraproject.org> - 1.3.14-13
306
+ - F-28: rebuild for ruby25
307
+
308
+ * Wed Nov 08 2017 Richard W.M. Jones <rjones@redhat.com> - 1.3.14-12
309
+ - Fix string mutability.
310
+
311
+ * Wed Nov 08 2017 Richard W.M. Jones <rjones@redhat.com> - 1.3.14-10
312
+ - OCaml 4.06.0 rebuild.
313
+
314
+ * Mon Sep 18 2017 Richard W.M. Jones <rjones@redhat.com> - 1.3.14-9
315
+ - ocaml-hivex-devel should Require hivex-devel.
316
+
317
+ * Mon Aug 07 2017 Richard W.M. Jones <rjones@redhat.com> - 1.3.14-8
318
+ - OCaml 4.05.0 rebuild.
319
+
320
+ * Wed Aug 02 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.3.14-7
321
+ - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
322
+
323
+ * Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.3.14-6
324
+ - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
325
+
326
+ * Mon Jun 26 2017 Richard W.M. Jones <rjones@redhat.com> - 1.3.14-5
327
+ - OCaml 4.04.2 rebuild.
328
+
329
+ * Sun Jun 04 2017 Jitka Plesnikova <jplesnik@redhat.com> - 1.3.14-4
330
+ - Perl 5.26 rebuild
331
+
332
+ * Mon May 22 2017 Richard W.M. Jones <rjones@redhat.com> - 1.3.14-3
333
+ - Create python2 and python3 subpackages (RHBZ#1453189).
334
+
335
+ * Fri May 12 2017 Richard W.M. Jones <rjones@redhat.com> - 1.3.14-2
336
+ - OCaml 4.04.1 rebuild.
337
+
338
+ * Fri Feb 17 2017 Richard W.M. Jones <rjones@redhat.com> - 1.3.14-1
339
+ - New upstream version 1.3.14.
340
+ - Add GPG signature and mechanics for checking it.
341
+
342
+ * Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.3.13-12
343
+ - Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
344
+
345
+ * Fri Jan 13 2017 Mamoru TASAKA <mtasaka@fedoraproject.org> - 1.3.13-11
346
+ - F-26: rebuild again for ruby24
347
+
348
+ * Thu Jan 12 2017 Igor Gnatenko <ignatenko@redhat.com> - 1.3.13-10
349
+ - Rebuild for readline 7.x
350
+
351
+ * Thu Jan 12 2017 Vít Ondruch <vondruch@redhat.com> - 1.3.13-9
352
+ - Rebuilt for https://fedoraproject.org/wiki/Changes/Ruby_2.4
353
+
354
+ * Sat Nov 05 2016 Richard W.M. Jones <rjones@redhat.com> - 1.3.13-8
355
+ - Rebuild for OCaml 4.04.0.
356
+
357
+ * Tue Jul 19 2016 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.13-7
358
+ - https://fedoraproject.org/wiki/Changes/Automatic_Provides_for_Python_RPM_Packages
359
+
360
+ * Tue May 17 2016 Jitka Plesnikova <jplesnik@redhat.com> - 1.3.13-6
361
+ - Perl 5.24 rebuild
362
+
363
+ * Tue May 10 2016 Richard W.M. Jones <rjones@redhat.com> - 1.3.13-5
364
+ - Explicitly BR rubygem(rdoc) RHBZ#1334753 and rubygem(json) RHBZ#1325022.
365
+
366
+ * Wed Feb 03 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1.3.13-4
367
+ - Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
368
+
369
+ * Tue Jan 12 2016 Vít Ondruch <vondruch@redhat.com> - 1.3.13-3
370
+ - Rebuilt for https://fedoraproject.org/wiki/Changes/Ruby_2.3
371
+
372
+ * Thu Oct 29 2015 Richard W.M. Jones <rjones@redhat.com> - 1.3.13-2
373
+ - New upstream version 1.3.13.
374
+ - Drop ancient 'Conflicts' rule.
375
+ - Drop Perl patch for setting INSTALLDIRS.
376
+ - Depend on pod2html, pod2man binaries explicitly.
377
+
378
+ * Mon Oct 5 2015 Richard W.M. Jones <rjones@redhat.com> - 1.3.12-1
379
+ - New upstream version 1.3.12.
380
+ - Drop patches which are now upstream.
381
+ - Use OCaml macros to test if OCaml native compiler is available.
382
+ - Use autoreconf --force option.
383
+
384
+ * Thu Aug 27 2015 Petr Šabata <contyk@redhat.com> - 1.3.11-13
385
+ - Correcting the perl build time dependency list
386
+ Switching to virtual perl()-style symbols
387
+ Dropping unused dependencies and adding some new to fix the FTBFS
388
+
389
+ * Tue Jul 28 2015 Richard W.M. Jones <rjones@redhat.com> - 1.3.11-12
390
+ - OCaml 4.02.3 rebuild.
391
+
392
+ * Wed Jun 24 2015 Richard W.M. Jones <rjones@redhat.com> - 1.3.11-11
393
+ - ocaml-4.02.2 final rebuild.
394
+
395
+ * Wed Jun 17 2015 Richard W.M. Jones <rjones@redhat.com> - 1.3.11-10
396
+ - ocaml-4.02.2 rebuild.
397
+
398
+ * Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.11-9
399
+ - Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
400
+
401
+ * Fri Jun 05 2015 Jitka Plesnikova <jplesnik@redhat.com> - 1.3.11-8
402
+ - Perl 5.22 rebuild
403
+
404
+ * Mon Mar 2 2015 Richard W.M. Jones <rjones@redhat.com> - 1.3.11-7
405
+ - Move hivexregedit to perl-hivex subpackage, since otherwise hivex
406
+ and hence libguestfs depends on perl (RHBZ#1194158).
407
+
408
+ * Tue Feb 17 2015 Richard W.M. Jones <rjones@redhat.com> - 1.3.11-6
409
+ - ocaml-4.02.1 rebuild.
410
+
411
+ * Sun Jan 18 2015 Mamoru TASAKA <mtasaka@fedoraproject.org> - 1.3.11-5
412
+ - Rebuild for https://fedoraproject.org/wiki/Changes/Ruby_2.2
413
+
414
+ * Thu Nov 20 2014 Richard W.M. Jones <rjones@redhat.com> - 1.3.11-4
415
+ - Increase HIVEX_MAX_SUBKEYS.
416
+ - Don't leak errno E2BIG to callers.
417
+
418
+ * Fri Nov 14 2014 Richard W.M. Jones <rjones@redhat.com> - 1.3.11-2
419
+ - Pull in a couple of upstream fixes:
420
+ * Fix memory leak in _hivex_get_children.
421
+ * Increase HIVEX_MAX_VALUE_LEN.
422
+
423
+ * Thu Oct 30 2014 Richard W.M. Jones <rjones@redhat.com> - 1.3.11-1
424
+ - New upstream version 1.3.11.
425
+ - Python objects are now placed in a hivex/ subdirectory.
426
+
427
+ * Wed Sep 03 2014 Jitka Plesnikova <jplesnik@redhat.com> - 1.3.10-12
428
+ - Perl 5.20 rebuild
429
+
430
+ * Sat Aug 30 2014 Richard W.M. Jones <rjones@redhat.com> - 1.3.10-11
431
+ - ocaml-4.02.0 final rebuild.
432
+
433
+ * Wed Aug 27 2014 Jitka Plesnikova <jplesnik@redhat.com> - 1.3.10-10
434
+ - Perl 5.20 rebuild
435
+
436
+ * Sat Aug 23 2014 Richard W.M. Jones <rjones@redhat.com> - 1.3.10-9
437
+ - ocaml-4.02.0+rc1 rebuild.
438
+
439
+ * Sat Aug 16 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.10-8
440
+ - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
441
+
442
+ * Sat Aug 02 2014 Richard W.M. Jones <rjones@redhat.com> - 1.3.10-7
443
+ - ocaml-4.02.0-0.8.git10e45753.fc22 rebuild.
444
+
445
+ * Tue Jul 22 2014 Richard W.M. Jones <rjones@redhat.com> - 1.3.10-6
446
+ - OCaml 4.02.0 beta rebuild.
447
+
448
+ * Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.10-5
449
+ - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
450
+
451
+ * Fri May 02 2014 Vít Ondruch <vondruch@redhat.com> - 1.3.10-4
452
+ - Remove the ruby(release) version. It is not needed.
453
+
454
+ * Fri May 02 2014 Richard W.M. Jones <rjones@redhat.com> - 1.3.10-3
455
+ - Rebuild to fix Ruby dependencies problem.
456
+
457
+ * Thu Apr 24 2014 Vít Ondruch <vondruch@redhat.com> - 1.3.10-2
458
+ - Rebuilt for https://fedoraproject.org/wiki/Changes/Ruby_2.1
459
+
460
+ * Wed Apr 23 2014 Richard W.M. Jones <rjones@redhat.com> - 1.3.10-1
461
+ - New upstream version 1.3.10.
462
+ - Fix ruby test failures (RHBZ#1090407).
463
+
464
+ * Fri Jan 17 2014 Richard W.M. Jones <rjones@redhat.com> - 1.3.9-2
465
+ - New upstream version 1.3.9.
466
+ - Remove patches which are now upstream.
467
+
468
+ * Thu Sep 19 2013 Richard W.M. Jones <rjones@redhat.com> - 1.3.8-4
469
+ - OCaml 4.01.0 rebuild.
470
+
471
+ * Tue Sep 10 2013 Richard W.M. Jones <rjones@redhat.com> - 1.3.8-3
472
+ - Include various upstream patches to fix endianness problems on ppc64.
473
+
474
+ * Sun Sep 8 2013 Richard W.M. Jones <rjones@redhat.com> - 1.3.8-2
475
+ - Bump and rebuild, since ARM package still appears to depend on Perl 5.16.
476
+
477
+ * Thu Jul 25 2013 Richard W.M. Jones <rjones@redhat.com> - 1.3.8-1
478
+ - New upstream version 1.3.8.
479
+ - Fixes handling of keys which use ri-records, for both reading and
480
+ writing (RHBZ#717583, RHBZ#987463).
481
+ - Remove upstream patch.
482
+ - Rebase dirs patch against new upstream sources.
483
+ - Rebase ruby patch against new upstream sources.
484
+ - Modernize the RPM spec file.
485
+ - Fix .gitignore.
486
+
487
+ * Wed Jul 17 2013 Petr Pisar <ppisar@redhat.com> - 1.3.7-8
488
+ - Perl 5.18 rebuild
489
+
490
+ * Wed Mar 13 2013 Richard W.M. Jones <rjones@redhat.com> - 1.3.7-7
491
+ - Rebuild for Ruby 2.0.0.
492
+ - Change ruby(abi) to ruby(release).
493
+
494
+ * Fri Feb 15 2013 Richard W.M. Jones <rjones@redhat.com> - 1.3.7-6
495
+ - Fix for latest Ruby in Rawhide. Fixes build failure identified
496
+ by mass rebuild yesterday.
497
+ - Do not ignore error from running autoreconf.
498
+
499
+ * Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.7-3
500
+ - Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
501
+
502
+ * Mon Oct 29 2012 Richard W.M. Jones <rjones@redhat.com> - 1.3.7-2
503
+ - Rebuild for OCaml 4.00.1.
504
+
505
+ * Thu Oct 11 2012 Richard W.M. Jones <rjones@redhat.com> - 1:1.3.7-1
506
+ - New upstream version 1.3.7.
507
+
508
+ * Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.6-3
509
+ - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
510
+
511
+ * Wed Jun 27 2012 Petr Pisar <ppisar@redhat.com> - 1.3.6-2
512
+ - Perl 5.16 rebuild
513
+
514
+ * Tue Jun 12 2012 Richard W.M. Jones <rjones@redhat.com> - 1:1.3.6-1
515
+ - New upstream version 1.3.6.
516
+ - Enable Ocaml bindings on ppc64.
517
+
518
+ * Sat Jun 09 2012 Richard W.M. Jones <rjones@redhat.com> - 1.3.5-9
519
+ - Rebuild for OCaml 4.00.0.
520
+
521
+ * Fri Jun 08 2012 Petr Pisar <ppisar@redhat.com> - 1.3.5-8
522
+ - Perl 5.16 rebuild
523
+
524
+ * Fri May 18 2012 Richard W.M. Jones <rjones@redhat.com> - 1:1.3.5-7
525
+ - "blobs" -> "files" in the description.
526
+
527
+ * Tue May 15 2012 Richard W.M. Jones <rjones@redhat.com> - 1:1.3.5-6
528
+ - Bundled gnulib (RHBZ#821763).
529
+
530
+ * Fri Mar 23 2012 Richard W.M. Jones <rjones@redhat.com> - 1:1.3.5-5
531
+ - Don't need to rerun the generator (thanks Dan Horák).
532
+
533
+ * Tue Mar 13 2012 Richard W.M. Jones <rjones@redhat.com> - 1:1.3.5-4
534
+ - New upstream version 1.3.5.
535
+ - Remove upstream patch.
536
+ - Depend on automake etc. for the patch.
537
+
538
+ * Thu Feb 9 2012 Richard W.M. Jones <rjones@redhat.com> - 1.3.3-8
539
+ - ruby(abi) 1.9.1.
540
+
541
+ * Wed Feb 8 2012 Richard W.M. Jones <rjones@redhat.com> - 1.3.3-7
542
+ - Bump and rebuild for Ruby update.
543
+ - Add upstream patch to fix bindings for Ruby 1.9.
544
+ - Add non-upstream patch to pass --vendor flag to extconf.rb
545
+
546
+ * Fri Jan 06 2012 Richard W.M. Jones <rjones@redhat.com> - 1.3.3-3
547
+ - Rebuild for OCaml 3.12.1.
548
+
549
+ * Thu Dec 8 2011 Richard W.M. Jones <rjones@redhat.com> - 1.3.3-2
550
+ - Disable OCaml on ppc64.
551
+ - Ensure OCaml files are deleted when not packaged.
552
+
553
+ * Tue Nov 29 2011 Richard W.M. Jones <rjones@redhat.com> - 1.3.3-1
554
+ - New upstream version 1.3.3.
555
+ - Rebased gnulib to work around RHBZ#756981.
556
+ - Remove patches which are now upstream.
557
+
558
+ * Mon Oct 24 2011 Richard W.M. Jones <rjones@redhat.com> - 1.3.2-3
559
+ - New upstream version 1.3.2.
560
+ - Add upstream patch to fix building of hivexsh, hivexget.
561
+
562
+ * Fri Aug 26 2011 Richard W.M. Jones <rjones@redhat.com> - 1.3.1-2
563
+ - New upstream version 1.3.1.
564
+ - Remove patch, now upstream.
565
+ - Don't need hack for making an unversioned Python module.
566
+
567
+ * Mon Aug 15 2011 Richard W.M. Jones <rjones@redhat.com> - 1.3.0-3
568
+ - New upstream version 1.3.0.
569
+ - This version adds Ruby bindings, so there is a new subpackage 'ruby-hivex'.
570
+ - Add upstream patch to fix Ruby tests.
571
+ - Remove epoch macro in ruby-hivex dependency.
572
+
573
+ * Fri Aug 12 2011 Richard W.M. Jones <rjones@redhat.com> - 1.2.8-1
574
+ - New upstream version 1.2.8.
575
+ - Remove 4 upstream patches.
576
+
577
+ * Fri Jul 22 2011 Richard W.M. Jones <rjones@redhat.com> - 1.2.7-9
578
+ - Add upstream patch to fix Perl CCFLAGS for Perl 5.14 on i686.
579
+ - Enable 'make check'.
580
+
581
+ * Thu Jul 21 2011 Richard W.M. Jones <rjones@redhat.com> - 1.2.7-6
582
+ - i686 package is broken, experimentally rebuild it.
583
+
584
+ * Fri Jun 17 2011 Marcela Mašláňová <mmaslano@redhat.com> - 1.2.7-5
585
+ - Perl mass rebuild
586
+
587
+ * Fri Jun 10 2011 Marcela Mašláňová <mmaslano@redhat.com> - 1.2.7-4
588
+ - Perl 5.14 mass rebuild
589
+
590
+ * Tue May 17 2011 Richard W.M. Jones <rjones@redhat.com> - 1.2.7-3
591
+ - New upstream version 1.2.7.
592
+ - Removed patch which is now upstream.
593
+ - Add upstream patches to fix ocaml install rule.
594
+
595
+ * Thu May 12 2011 Richard W.M. Jones <rjones@redhat.com> - 1.2.6-2
596
+ - New upstream version 1.2.6.
597
+ - Removed patch which is now upstream.
598
+ - Add upstream patch to fix ocaml tests.
599
+
600
+ * Thu Apr 28 2011 Richard W.M. Jones <rjones@redhat.com> - 1.2.5-2
601
+ - Fix Python bindings on 32 bit arch with upstream patch.
602
+
603
+ * Wed Apr 13 2011 Richard W.M. Jones <rjones@redhat.com> - 1.2.5-1
604
+ - New upstream version 1.2.5.
605
+ - This version fixes a number of important memory issues found by
606
+ valgrind and upgrading to this version is recommended for all users.
607
+ - Remove patch now upstream.
608
+
609
+ * Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.4-7
610
+ - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
611
+
612
+ * Fri Jan 14 2011 Richard W.M. Jones <rjones@redhat.com> - 1.2.4-6
613
+ - Fix multilib conflicts in *.pyc and *.pyo files.
614
+ - Only install unversioned *.so file for Python bindings.
615
+
616
+ * Wed Jan 5 2011 Richard W.M. Jones <rjones@redhat.com> - 1.2.4-4
617
+ - Rebuild against OCaml 3.12.0.
618
+
619
+ * Thu Dec 16 2010 Richard W.M. Jones <rjones@redhat.com> - 1.2.4-3
620
+ - Backport upstream patch to fix segfault in Hivex.value_value binding.
621
+
622
+ * Thu Dec 2 2010 Richard W.M. Jones <rjones@redhat.com> - 1.2.4-1
623
+ - New upstream version 1.2.4.
624
+ - This adds Python bindings (python-hivex subpackage).
625
+ - Fix Source0.
626
+
627
+ * Fri Nov 19 2010 Dan Horák <dan[at]danny.cz> - 1.2.3-3
628
+ - fix built with recent perl
629
+
630
+ * Tue Sep 7 2010 Dan Horák <dan[at]danny.cz> - 1.2.3-2
631
+ - conditionalize ocaml support
632
+
633
+ * Fri Aug 27 2010 Richard W.M. Jones <rjones@redhat.com> - 1.2.3-1
634
+ - New upstream version 1.2.3.
635
+
636
+ * Wed Aug 25 2010 Richard W.M. Jones <rjones@redhat.com> - 1.2.2-3
637
+ - Create a hivex-static subpackage.
638
+
639
+ * Thu Apr 29 2010 Marcela Maslanova <mmaslano@redhat.com> - 1.2.2-2
640
+ - Mass rebuild with perl-5.12.0
641
+
642
+ * Wed Apr 28 2010 Richard W.M. Jones <rjones@redhat.com> - 1.2.2-1
643
+ - New upstream version 1.2.2.
644
+
645
+ * Tue Mar 30 2010 Richard W.M. Jones <rjones@redhat.com> - 1.2.1-1
646
+ - New upstream version 1.2.1.
647
+ - Includes new tool for exporting and merging in regedit format.
648
+
649
+ * Mon Mar 1 2010 Richard W.M. Jones <rjones@redhat.com> - 1.2.0-2
650
+ - New upstream version 1.2.0.
651
+ - This includes OCaml and Perl bindings, so add these as subpackages.
652
+
653
+ * Mon Feb 22 2010 Richard W.M. Jones <rjones@redhat.com> - 1.1.2-3
654
+ - Missing Epoch in conflicts version fixed.
655
+
656
+ * Mon Feb 22 2010 Richard W.M. Jones <rjones@redhat.com> - 1.1.2-2
657
+ - Add Conflicts libguestfs <= 1.0.84.
658
+
659
+ * Mon Feb 22 2010 Richard W.M. Jones <rjones@redhat.com> - 1.1.2-1
660
+ - Initial Fedora RPM.