jamesantill / centos / pungi-centos

Forked from centos/pungi-centos 2 years ago
Clone
Blob Blame Raw
filter_packages = [
    ("^Devel$", {
        "*": [
            "glibc*",
            # This is a massive hack... using diff | egrep -v '^[+-]' | perl -pe 's/(.*)-[^-]+-[^-]+[.]rpm/$1/' | sort -u
 "acl-debuginfo",
 "attr-debuginfo",
 "bash",
 "bzip2-debuginfo",
 "bzip2-libs",
 "chkconfig",
 "coreutils",
 "coreutils-common",
 "coreutils-single",
 "e2fsprogs-debuginfo",
 "expat",
 "filesystem",
 "gawk",
 "gdbm",
 "gdbm-libs",
 "gmp",
 "grep",
 "info",
 "keyutils-debuginfo",
 "keyutils-libs",
 "krb5-debuginfo",
 "krb5-libs",
 "libacl",
 "libattr",
 "libcap",
 "libcom_err",
 "libffi",
 "libnsl2",
 "libpkgconf",
 "libselinux",
 "libsepol",
 "libsigsegv",
 "libtasn1",
 "libtirpc",
 "libuv",
 "libverto",
 "libxcrypt",
 "mpfr",
 "ncurses",
 "ncurses-base",
 "ncurses-libs",
 "openssl-debuginfo",
 "openssl-libs",
 "p11-kit",
 "p11-kit-trust",
 "pcre",
 "pcre2",
 "pkgconf",
 "pkgconf-m4",
 "pkgconf-pkg-config",
 "platform-python",
 "platform-python-pip",
 "platform-python-setuptools",
 "popt",
 "popt-devel",
 "python3-libs",
 "python3-pip-wheel",
 "python3-setuptools-wheel",
 "readline",
 "sed",
 "xz-debuginfo",
 "xz-libs",
 "zlib",
        ]
    }),

    ("^(BaseOS|AppStream)$", {
        "*": [
            "python36",
        ]
    }),

    ("^BaseOS$", {
        "*": [
            "compat-openssl10-devel",
            "compat-openssl10-pkcs11-helper",
            "openldap-servers-debuginfo",
            "ongres-scram",
        ]
    }),
]

additional_packages = [
    ("^AppStream$", {
        "*": [
            "langpacks-*",
	    "dotnet-*",
            "ansible-freeipa",
            "fapolicyd",
            "python3-rpmfluff",
            "gcc-toolset-9",
            "gcc-toolset-9-annobin",
            "gcc-toolset-9-binutils",
            "gcc-toolset-9-binutils-devel",
            "gcc-toolset-9-build",
            "gcc-toolset-9-dwz",
            "gcc-toolset-9-dyninst",
            "gcc-toolset-9-elfutils",
            "gcc-toolset-9-elfutils-devel",
            "gcc-toolset-9-elfutils-libelf",
            "gcc-toolset-9-elfutils-libelf-devel",
            "gcc-toolset-9-elfutils-libs",
            "gcc-toolset-9-gcc",
            "gcc-toolset-9-gcc-c++",
            "gcc-toolset-9-gcc-gdb-plugin",
            "gcc-toolset-9-gcc-gfortran",
            "gcc-toolset-9-gdb",
            "gcc-toolset-9-gdb-doc",
            "gcc-toolset-9-gdb-gdbserver",
            "gcc-toolset-9-libitm-devel",
            "gcc-toolset-9-libquadmath-devel",
            "gcc-toolset-9-libstdc++-devel",
            "gcc-toolset-9-libstdc++-docs",
            "gcc-toolset-9-ltrace",
            "gcc-toolset-9-make",
            "gcc-toolset-9-make-devel",
            "gcc-toolset-9-perftools",
            "gcc-toolset-9-runtime",
            "gcc-toolset-9-strace",
            "gcc-toolset-9-systemtap",
            "gcc-toolset-9-systemtap-client",
            "gcc-toolset-9-systemtap-devel",
            "gcc-toolset-9-systemtap-initscript",
            "gcc-toolset-9-systemtap-runtime",
            "gcc-toolset-9-systemtap-sdt-devel",
            "gcc-toolset-9-systemtap-server",
            "gcc-toolset-9-toolchain",
            "gcc-toolset-9-valgrind",
            "gcc-toolset-9-valgrind-devel",
            "libasan5",
            "libubsan1",
            "lttng-ust",
        ]
    }),

    ("^AppStream$", {
        "x86_64": [

            "libreoffice-langpack-*",
            "libreoffice-help-*",
        ],
	"armhfp": [
            "libreoffice-*",
            "libreoffice-help-*",
            "libreoffice-langpack-*",
	    "emacs-*",
	    "autocorr*",
            "fence-agents*",
            "gnome-shell-extension*",
            "google-noto*",
            "hunspell-*",
            "hyphen-*",
	]
    }),

    ("^BaseOS$", {
        "*": [
            "kernel-doc",
	    "centos-obsolete-packages",
        ],
	"armhfp": [
	    "kernel-lpae*",
	    "uboot-tools",
            "uboot-images*",
            "grub2*",
            "grubby-deprecated",
            "efibootmgr",
            "cloud-utils-growpart",
            "bcm283x-firmware",
            "efivar*",
	]
    }),
]