chantra / rpms / rpm

Forked from rpms/rpm 2 years ago
Clone

29244e Merged update from upstream sources

Authored and Committed by DistroBaker 4 years ago
    Merged update from upstream sources
    
    This is an automated DistroBaker update from upstream sources.
    If you do not know what this is about or would like to opt out,
    contact the OSCI team.
    
    Source: https://src.fedoraproject.org/rpms/rpm.git#7b0bfa9fc2de616bf0b0295a0de6b7fdae1d80b4
    
        
0001-Issue-deprecation-warning-when-creating-BDB-database.patch ADDED
@@ -0,0 +1,28 @@
1
+ From 5a80033676f331de2b0979fe7be9557279b6bff3 Mon Sep 17 00:00:00 2001
2
+ Message-Id: <5a80033676f331de2b0979fe7be9557279b6bff3.1603865959.git.pmatilai@redhat.com>
3
+ From: Panu Matilainen <pmatilai@redhat.com>
4
+ Date: Wed, 28 Oct 2020 08:14:55 +0200
5
+ Subject: [PATCH] Issue deprecation warning when creating BDB databases
6
+
7
+ ---
8
+ lib/backend/db3.c | 4 ++++
9
+ 1 file changed, 4 insertions(+)
10
+
11
+ diff --git a/lib/backend/db3.c b/lib/backend/db3.c
12
+ index 68cfa6fb2..cb31676e7 100644
13
+ --- a/lib/backend/db3.c
14
+ +++ b/lib/backend/db3.c
15
+ @@ -874,6 +874,10 @@ static int db3_dbiOpen(rpmdb rdb, rpmDbiTagVal rpmtag, dbiIndex * dbip, int flag
16
+ oflags &= ~DB_RDONLY;
17
+ dbtype = (rpmtag == RPMDBI_PACKAGES) ? DB_HASH : DB_BTREE;
18
+ retry_open--;
19
+ + if (rpmtag == RPMDBI_PACKAGES) {
20
+ + rpmlog(RPMLOG_WARNING,
21
+ + "using deprecated bdb database backend");
22
+ + }
23
+ } else {
24
+ retry_open = 0;
25
+ }
26
+ --
27
+ 2.28.0
28
+
file modified
+7 -2
rpm.spec CHANGED
@@ -1,7 +1,7 @@
1
1
# build against xz?
2
2
%bcond_without xz
3
3
# run internal testsuite?
4
- %bcond_without check
4
+ %bcond_with check
5
5
# build with plugins?
6
6
%bcond_without plugins
7
7
# build with libarchive? (needed for rpm2archive)
@@ -25,7 +25,7 @@
25
25
26
26
%global rpmver 4.16.0
27
27
#global snapver rc1
28
- %global rel 2
28
+ %global rel 3
29
29
30
30
%global srcver %{rpmver}%{?snapver:-%{snapver}}
31
31
%global srcdir %{?snapver:testing}%{!?snapver:rpm-%(echo %{rpmver} | cut -d'.' -f1-2).x}
@@ -57,6 +57,7 @@ Patch3: rpm-4.9.90-no-man-dirs.patch
57
57
Patch5: rpm-4.12.0-rpm2cpio-hack.patch
58
58
# https://github.com/rpm-software-management/rpm/pull/473
59
59
Patch6: 0001-find-debuginfo.sh-decompress-DWARF-compressed-ELF-se.patch
60
+ Patch7: 0001-Issue-deprecation-warning-when-creating-BDB-database.patch
60
61
61
62
# Patches already upstream:
62
63
@@ -552,6 +553,10 @@ fi
552
553
%doc doc/librpm/html/*
553
554
554
555
%changelog
556
+ * Wed Oct 28 2020 Panu Matilainen <pmatilai@redhat.com> - 4.16.0-3
557
+ - Issue deprecation warning when creating BDB databases (#1787311)
558
+ - Temporarily disable test-suite due to massive fakechroot breakage
559
+
555
560
* Mon Oct 05 2020 Panu Matilainen <pmatilai@redhat.com> - 4.16.0-2
556
561
- Clean up after test-suite which leaves a read-only tree behind
557
562