#37 Add changes for CentOS Linux 8.4.2105
Merged 4 months ago by carlwgeorge. Opened 4 months ago by bstinson.
centos/ bstinson/pungi-centos centos-8.4.2105  into  centos-8.4.2105

Add changes for CentOS Linux 8.4.2105
Brian Stinson • 4 months ago  
file modified
+10 -10

@@ -6,14 +6,14 @@ 

  release_name = "CentOS Linux" 

  release_short = "CentOS"

  release_version = "8"

- version = "8.3.2011"

+ version = "8.4.2105"

  

  # GENERAL SETTINGS

  comps_file = {

          'scm': 'git',

          'repo': 'https://git.centos.org/centos/comps.git',

          'branch': 'master',

-         'file': 'comps-centos-8.3.0.2011.xml',

+         'file': 'comps-centos-8.4.0.2105.xml',

  }

  

  link_type = 'hardlink-or-copy'

@@ -21,7 +21,7 @@ 

  module_defaults_dir = {

          'scm': 'git',

          'repo': 'https://git.centos.org/centos/centos-module-defaults.git',

-         'branch': 'c8.3',

+         'branch': 'c8.4',

          'dir': '.',

  }

  

@@ -77,7 +77,7 @@ 

  createrepo_use_xz = True

  createrepo_num_threads = 8

  createrepo_num_workers = 4

- createrepo_extra_args = ['--distro=cpe:/o:centos:centos:8,CentOS 8', '--revision=8.3.2011']

+ createrepo_extra_args = ['--distro=cpe:/o:centos:centos:8,CentOS 8', '--revision=8.4.2105']

  

  # CHECKSUMS

  media_checksums = ['sha256']

@@ -105,12 +105,12 @@ 

  ]

  

  image_name_format = {

-     "^BaseOS$": "{release_short}-8.3.2011-{arch}-{disc_type}{disc_num}{suffix}",

-     "^Minimal$": "{release_short}-8.3.2011-{arch}-minimal{suffix}",

-     ".*": "{release_short}-8.3.2011-{arch}-{disc_type}{disc_num}{suffix}",

+     "^BaseOS$": "{release_short}-8.4.2105-{arch}-{disc_type}{disc_num}{suffix}",

+     "^Minimal$": "{release_short}-8.4.2105-{arch}-minimal{suffix}",

+     ".*": "{release_short}-8.4.2105-{arch}-{disc_type}{disc_num}{suffix}",

  }

  

- image_volid_formats = [ '{release_short}-8.3.2011-{arch}-{disc_type}', ]

+ image_volid_formats = [ '{release_short}-8.4.2105-{arch}-{disc_type}', ]

  

  # CREATEISO

  create_optional_isos = False

@@ -125,12 +125,12 @@ 

  extra_isos = {

      "BaseOS": [{

          "include_variants": ["AppStream"],

-         "filename": "{release_short}-8.3.2011-{arch}-{disc_type}{disc_num}{suffix}",

+         "filename": "{release_short}-8.4.2105-{arch}-{disc_type}{disc_num}{suffix}",

          "skip_src": True,

      }],

      "Minimal": [{

          "include_variants": ["BaseOS"],

-         "filename": "{release_short}-8.3.2011-{arch}-minimal{suffix}",

+         "filename": "{release_short}-8.4.2105-{arch}-minimal{suffix}",

          "skip_src": True,

      }]

  }

file modified
+4 -4

@@ -5,7 +5,7 @@ 

                  "format": [("docker", "tar.gz")],

                  "name": "CentOS-8-Container",

  		"subvariant": "container",

-                 "version": "8.3.2011",

+                 "version": "8.4.2105",

                  "release": "!RELEASE_FROM_DATE_RESPIN"

                  "target": "image-centos-8",

                  "ksurl": "git+https://git.centos.org/centos/kickstarts.git?#HEAD",

@@ -32,7 +32,7 @@ 

                  "format": [("qcow2", "qcow2")],

                  "name": "CentOS-8-GenericCloud",

  		"subvariant": "generic",

-                 "version": "8.3.2011",

+                 "version": "8.4.2105",

                  "release": "!RELEASE_FROM_DATE_RESPIN"

                  "target": "image-centos-8",

                  "ksurl": "git+https://git.centos.org/centos/kickstarts.git?#HEAD",

@@ -56,7 +56,7 @@ 

                  "format": [("qcow2", "qcow2")],

                  "name": "CentOS-8-ec2",

  		"subvariant": "ec2",

-                 "version": "8.3.2011",

+                 "version": "8.4.2105",

                  "release": "!RELEASE_FROM_DATE_RESPIN"

                  "target": "image-centos-8",

                  "ksurl": "git+https://git.centos.org/centos/kickstarts.git?#HEAD",

@@ -80,7 +80,7 @@ 

                  "format": [("vagrant-libvirt", "vagrant-libvirt.box"),('vagrant-virtualbox','vagrant-virtualbox.box')],

                  "name": "CentOS-8-Vagrant",

  		"subvariant": "vagrant",

-                 "version": "8.3.2011",

+                 "version": "8.4.2105",

                  "release": "!RELEASE_FROM_DATE_RESPIN"

                  "target": "image-centos-8",

                  "ksurl": "git+https://git.centos.org/centos/kickstarts.git?#HEAD",

file modified
+87 -148

@@ -4,8 +4,10 @@ 

              "python36",

              "gcc-toolset-9-*-testsuite", 

              "gcc-toolset-9-gcc-plugin-devel", 

-             "java-1.8.0-openjdk-headless-slowdebug",

-             "java-1.8.0-openjdk-slowdebug",

+             "tuned-profiles-sap",       # RCM-53604 - This should be only in SAP

+             "tuned-profiles-sap-hana",  # RCM-53604 - This should be only in SAPHANA

+             "java-*slowdebug*",              # Jira: RHELCMP-1407 Jira: RHELCMP-1512 Jira: RHELCMP-4189

+             "java-*fastdebug*",              # Jira: RHELCMP-1407 Jira: RHELCMP-1512 Jira: RHELCMP-4189

          ]

      }),

  

@@ -50,126 +52,66 @@ 

  additional_packages = [

      ("^AppStream$", {

          "*": [

-             "libasan5", 

+             "libasan5", #RCM-61474

              "libubsan1",

-             "spice-vdagent-win-x64", 

-             "spice-vdagent-win-x86", 

-             "usbguard-selinux",

-             "gcc-toolset-9-libasan-devel",

-             "gcc-toolset-9-libatomic-devel",

-             "gcc-toolset-9-liblsan-devel",

-             "gcc-toolset-9-libubsan-devel",

-             "gcc-toolset-9-libtsan-devel",

-             "gcc-toolset-10",

-             "gcc-toolset-10-binutils", 

-             "gcc-toolset-10-dyninst", 

-             "gcc-toolset-10-dyninst-devel", 

-             "gcc-toolset-10-strace", 

-             "gcc-toolset-10-gcc",

-             "gcc-toolset-10-gcc-gdb-plugin",

-             "gcc-toolset-10-libasan-devel",

-             "gcc-toolset-10-libatomic-devel",

-             "gcc-toolset-10-libitm-devel",

-             "gcc-toolset-10-liblsan-devel",

-             "gcc-toolset-10-libubsan-devel",

-             "gcc-toolset-10-libtsan-devel",

-             "gcc-toolset-10-libstdc++-docs",

-             "gcc-toolset-10-binutils-devel",

-             "gcc-toolset-10-build",

-             "gcc-toolset-10-elfutils-devel",

-             "gcc-toolset-10-elfutils-libelf-devel",

-             "gcc-toolset-10-gdb-doc",

-             "gcc-toolset-10-gdb-gdbserver",

-             "gcc-toolset-10-make-devel",

-             "gcc-toolset-10-systemtap-initscript",

-             "gcc-toolset-10-systemtap-sdt-devel",

-             "gcc-toolset-10-systemtap-server",

-             "gcc-toolset-10-valgrind-devel",

-             "ghostscript-x11", 

-             "python3-libmount", 

-             "itstool", 

-             "js-d3-flame-graph", 

-             "python3-wx-siplib", 

-             "osbuild",

-             "osbuild-composer",

-             "osbuild-ostree",

-             "osbuild-selinux", 

-             "python3-dasbus",

-             "NetworkManager-libreswan-gnome", 

-             "bogofilter",

-             "cmake-gui",

-             "evince",

-             "evince-browser-plugin",

-             "evolution-bogofilter",

-             "evolution-mapi",

-             "evolution-pst",

-             "evolution-spamassassin",

-             "exempi",

-             "exiv2",

-             "gnome-backgrounds-extras",

-             "gnome-getting-started-docs-cs",

-             "gnome-getting-started-docs-de",

-             "gnome-getting-started-docs-es",

-             "gnome-getting-started-docs-fr",

-             "gnome-getting-started-docs-gl",

-             "gnome-getting-started-docs-hu",

-             "gnome-getting-started-docs-it",

-             "gnome-getting-started-docs-pl",

-             "gnome-getting-started-docs-pt_BR",

-             "gnome-getting-started-docs-ru",

-             "gnome-shell-extension-auto-move-windows",

-             "gnome-shell-extension-dash-to-dock",

-             "gnome-shell-extension-drive-menu",

-             "gnome-shell-extension-native-window-placement",

-             "gnome-shell-extension-no-hot-corner",

-             "gnome-shell-extension-panel-favorites",

-             "gnome-shell-extension-screenshot-window-sizer",

-             "gnome-shell-extension-systemMonitor",

-             "gnome-shell-extension-top-icons",

-             "gnome-shell-extension-updates-dialog",

-             "gnome-shell-extension-user-theme",

-             "gnome-shell-extension-windowsNavigator",

-             "gnome-shell-extension-workspace-indicator",

+             "dotnet5.0", # Jira: RHELCMP-1966

+             "gcc-toolset-10-dyninst-devel", # Jira: RHELCMP-2173

              "gnome-software-editor",

-             "gnome-tweaks",

-             "gstreamer1-plugins-good-gtk",

-             "highlight-gui",

-             "hplip-gui",

-             "hwloc-gui",

-             "java-11-openjdk-static-libs", 

-             "libproxy-gnome",

-             "lshw-gui",

-             "mdevctl",

-             "mpg123-plugins-pulseaudio",

-             "pipewire-devel",

              "pipewire-docs",

-             "pipewire-utils",

-             "policycoreutils-gui",

-             "tuned-gtk",

-             "xmlsec1-nss", 

-             "udisks2-lsm",

-             "annobin-annocheck", 

-             "net-snmp-perl", 

-             "pipewire0.2-devel",

-             "pipewire0.2-libs", 

-             "usbguard-notifier", 

-             "rsyslog-omamqp1", 

-             "fapolicyd-selinux", 

-             "thermald",

-             "python3-brotli", 

-             "nmstate-plugin-ovsdb", 

-             "git-lfs", 

-             "tigervnc-server-module", 

-             "greenboot", 

-             "greenboot-grub2", 

-             "greenboot-reboot", 

-             "greenboot-rpm-ostree-grub2", 

-             "greenboot-status", 

-             "python3-libmodulemd", 

-             "dotnet5.0", 

+             "rt-tests", #RhBug 1877587

+             "micropipenv", #RHELCMP-2297 RhBug 1876890

+             "nispor", #RHELCMP-2300 RhBug 1876979

+             "nispor-devel", #RHELCMP-2300 RhBug 1876979

+             "osbuild-composer-core", #RHELCMP-4097

+             "python3-nispor", #RHELCMP-2300 RhBug 1876979

+             "libnumbertext", #RHELCMP-2856 RhBug 1888652

+             "dotnet-sdk-3.0",

+             "perl-IO-String", #RHELCMP-3042

+             "stalld", #RHELCMP-2941, RhBug 1893374

+             "dejavu-lgc-sans-fonts", #RhBug 1857213

+             "xorg-x11-drivers", #RHELCMP-3014

+             "fstrm", # Jira: RHELCMP-3011

+             "fstrm-devel", # Jira: RHELCMP-3752

+             "ucx-cma",

+             "ucx-ib",

+             "ucx-rdmacm"

+             "ucx-devel", #RhBug 1851724

+             "qatengine",

+             "mpich-doc", #RhBug 1732982

+             "mvapich2-devel",

+             "mvapich2-psm2-devel",

+             "mvapich2-doc", #RhBug 1850084

+             "libecpg", #RHBug 1903638, RHELCMP-3431

+             "rsyslog-udpspoof",

+             "mysql-selinux", #RhBug 1909064, RHELCMP-3600

+             "rshim", #RhBug 1915862, RHELCMP-3793

+             "qatlib", #RhBug 1919586, RHELCMP-3871

+             "tracer", #RhBug 1919665, RHELCMP-3872

+             "flatpak-xdg-utils", #RhBug 1925468, RHELCMP-4083

+             "modulemd-tools", #RhBug 1927050, RHELCMP-4123

+             "emoji-picker", # RHELCMP-4254

+             "rhc-worker-playbook", # RHBug 1931663, RHELCMP-4287

          ]

      }),

  

+     ("^BaseOS", {

+         "*": [

+             "python3-debuginfo", # RCM-73713

+             "kmod-redhat-oracleasm",

+             "python3-pyverbs", #RhBug 1856076

+             "syslinux-tftpboot", #RhBug 1870276 1745205

+             "samba-winexe", # Jira: RHELCMP-3276

+             "accel-config", # RhBug 1917945, RHELCMP-3828

+             "ima-evm-utils0", #RhBug 1925370

+         ]

+     }),

+ 

+     ("^BaseOS$", {

+         "x86_64": [

+             "alsa-sof-firmware-debug", # Jira: RHELCMP-1838

+         ],

+     }),

+ 

      ("^Devel$", {

          "*": [

              "argparse-manpage",

@@ -194,48 +136,45 @@ 

  

      ("^PowerTools", {

          "*": [

-             "opencv",

+             "libdnf-devel",

+             "librepo-devel",

+             "librhsm-devel",

+             "libsolv-devel",

+             "libsolv-tools",

+             "ibus-typing-booster-tests", # RHELCMP-4254

          ]

      }),

- 

- 

-     ("^AppStream$", {

+     ("PowerTools", {

+         "aarch64": [

+             "java-1.8.0-openjdk-*slowdebug*", # Jira: RHELCMP-4189

+             "java-11-openjdk-*slowdebug*", # Jira: RHELCMP-4189

+         ],

+         "ppc64le": [

+             "java-1.8.0-openjdk-*slowdebug*", # Jira: RHELCMP-4189

+             "java-11-openjdk-*slowdebug*", # Jira: RHELCMP-4189

+         ],

          "x86_64": [

- 

-             "libreoffice-langpack-*",

-             "libreoffice-help-*",

+             "java-1.8.0-openjdk-*slowdebug*", # Jira: RHELCMP-4189

+             "java-11-openjdk-*slowdebug*", # Jira: RHELCMP-4189

          ],

-         "aarch64": [

-             "vulkan-loader",

-             "vulkan-loader-devel", 

-             "vulkan-headers",

-             "vulkan-validation-layers",

-             "vulkan-tools",

+         "s390x": [

+             # Slowdebug is only for Java 11 on s390x,

+             # according to RHELCMP-4189

+             "java-11-openjdk-*slowdebug*", # Jira: RHELCMP-4189

          ],

- 	"armhfp": [

-             "libreoffice-*",

-             "libreoffice-help-*",

-             "libreoffice-langpack-*",

- 	    "emacs-*",

- 	    "autocorr*",

-             "fence-agents*",

-             "gnome-shell-extension*",

-             "google-noto*",

-             "hunspell-*",

-             "hyphen-*",

- 	]

      }),

+     ("PowerTools", {

+         "x86_64": [

+             "java-1.8.0-openjdk-*fastdebug*", # Jira: RHELCMP-4189

+             "java-11-openjdk-*fastdebug*", # Jira: RHELCMP-4189

+         ]

+     }),

+ 

+ 

  

      ("^BaseOS$", {

          "*": [

  	    "centos-obsolete-packages",

-             "sssd-polkit-rules", 

-             "python3-debuginfo", 

-             "python3-dnf-plugin-post-transaction-actions", 

-             "python3-solv", 

-             "libxmlb", 

-             "crypto-policies-scripts", 

-             "memstrack",

          ],

  	"armhfp": [

  	    "kernel-lpae*",

file modified
+8

@@ -171,6 +171,7 @@ 

        <module>llvm-toolset:rhel8</module>

        <module>mailman:2.1</module>

        <module>mariadb:10.3</module>

+       <module>mariadb:10.5</module>

        <module>maven:3.5</module>

        <module>maven:3.6</module>

        <module>mercurial:4.8</module>

@@ -192,13 +193,17 @@ 

        <module>php:7.4</module>

        <module>pki-core:10.6</module>

        <module>pki-deps:10.6</module>

+       <module>pmdk:1-fileformat-v6</module>

        <module>postgresql:10</module>

        <module>postgresql:9.6</module>

        <module>postgresql:12</module>

+       <module>postgresql:13</module>

        <module>python27:2.7</module>

        <module>python36:3.6</module>

        <module>python38:3.8</module>

+       <module>python39:3.9</module>

        <module>redis:5</module>

+       <module>redis:6</module>

        <module>rhn-tools:1.0</module>

        <module>ruby:2.5</module>

        <module>ruby:2.6</module>

@@ -208,7 +213,9 @@ 

        <module>scala:2.10</module>

        <module>squid:4</module>

        <module>subversion:1.10</module>

+       <module>subversion:1.14</module>

        <module>swig:3.0</module>

+       <module>swig:4.0</module>

        <module>varnish:6</module>

        <module>virt:rhel</module>

        <module>perl-YAML:1.24</module>

@@ -251,6 +258,7 @@ 

        <module>mariadb-devel:10.3</module>

        <module>virt-devel:rhel</module>

        <module>python38-devel:3.8</module>

+       <module>python39-devel:3.9</module>

      </modules>

    </variant>