Blob Blame Raw
filter_packages = [
    ("^(BaseOS|AppStream)$", {
        "*": [
            "python36",
            "gcc-toolset-9-*-testsuite", 
            "gcc-toolset-9-gcc-plugin-devel", 
        ]
    }),

    ("^BaseOS$", {
        "*": [
            "compat-openssl10-devel",
            "compat-openssl10-pkcs11-helper",
            "openldap-servers-debuginfo",
            "ongres-scram",
        ]
    }),
    ("^Devel$", {
        "*": [
            "dlm",
            "cmirror",
            "gfbgraph",
        ]
    }),
]

additional_packages = [
    ("^AppStream$", {
        "*": [
            "spice-qxl-xddm",
            "langpacks-*",
            "appstream-data",
            "ansible-freeipa",
            "fapolicyd",
            "python3-rpmfluff",
            "gcc-toolset-9", 
            "gcc-toolset-9-annobin", 
            "gcc-toolset-9-binutils", 
            "gcc-toolset-9-binutils-devel",
            "gcc-toolset-9-build",
            "gcc-toolset-9-dwz",
            "gcc-toolset-9-dyninst",
            "gcc-toolset-9-elfutils",
            "gcc-toolset-9-elfutils-devel",
            "gcc-toolset-9-elfutils-libelf",
            "gcc-toolset-9-elfutils-libelf-devel",
            "gcc-toolset-9-elfutils-libs",
            "gcc-toolset-9-gcc",
            "gcc-toolset-9-gcc-c++",
            "gcc-toolset-9-gcc-gdb-plugin",
            "gcc-toolset-9-gcc-gfortran",
            "gcc-toolset-9-gdb",
            "gcc-toolset-9-gdb-doc",
            "gcc-toolset-9-gdb-gdbserver",
            "gcc-toolset-9-libitm-devel",
            "gcc-toolset-9-libquadmath-devel",
            "gcc-toolset-9-libstdc++-devel",
            "gcc-toolset-9-libstdc++-docs",
            "gcc-toolset-9-ltrace",
            "gcc-toolset-9-make",
            "gcc-toolset-9-make-devel",
            "gcc-toolset-9-perftools",
            "gcc-toolset-9-runtime",
            "gcc-toolset-9-strace",
            "gcc-toolset-9-systemtap",
            "gcc-toolset-9-systemtap-client",
            "gcc-toolset-9-systemtap-devel",
            "gcc-toolset-9-systemtap-initscript",
            "gcc-toolset-9-systemtap-runtime",
            "gcc-toolset-9-systemtap-sdt-devel",
            "gcc-toolset-9-systemtap-server",
            "gcc-toolset-9-toolchain",
            "gcc-toolset-9-valgrind",
            "gcc-toolset-9-valgrind-devel",
            "gcc-toolset-9-libasan-devel",
            "gcc-toolset-9-libatomic-devel",
            "gcc-toolset-9-liblsan-devel",
            "gcc-toolset-9-libubsan-devel",
            "gcc-toolset-9-libtsan-devel",
            "libasan5", 
            "libubsan1",
            "perl-Convert-ASN1", 
            "lttng-ust", 
            "whois", 
            "librsvg2-tools",  
            "compat-exiv2-026",  
            "prometheus-jmx-exporter",  
            "jolokia-jvm-agent", 
            "perl-LDAP", 
            "python3-networkx", 
            "liburing", 
            "setools-console-analyses", 
            "setools-gui", 
            "virt-p2v-maker", 
            "python3-protobuf", 
            "NetworkManager-cloud-setup", 
            "spice-client-win-x64", 
            "spice-client-win-x86", 
            "qt5-qtbase-private-devel", 
            "spice-vdagent-win-x64", 
            "spice-vdagent-win-x86", 
        ]
    }),

    ("^Devel$", {
        "*": [
            "argparse-manpage",
            "autogen-libopts-devel",
            "gfbgraph-devel",
            "jbig2dec-devel",
            "liba52-devel",
            "libavc1394-devel",
            "libdvdnav-devel",
            "libnml-devel",
            "libss-devel",
            "libssh2-devel",
            "libuv-devel",
            "mobile-broadband-provider-info-devel",
            "openslp-devel",
            "protobuf-lite-devel",
            "quota-devel",
            "rest-devel",
            "tracker-devel",
        ]
    }),

    ("^PowerTools", {
        "*": [
            "opencv",
        ]
    }),


    ("^AppStream$", {
        "x86_64": [

            "libreoffice-langpack-*",
            "libreoffice-help-*",
        ],
        "aarch64": [
            "vulkan-loader",
            "vulkan-loader-devel", 
            "vulkan-headers",
            "vulkan-validation-layers",
            "vulkan-tools",
        ],
	"armhfp": [
            "libreoffice-*",
            "libreoffice-help-*",
            "libreoffice-langpack-*",
	    "emacs-*",
	    "autocorr*",
            "fence-agents*",
            "gnome-shell-extension*",
            "google-noto*",
            "hunspell-*",
            "hyphen-*",
	]
    }),

    ("^BaseOS$", {
        "*": [
            "kernel-doc",
	    "centos-obsolete-packages",
            "python3-nftables",  
            "python3-dnf-plugin-post-transaction-actions", 
            "elfutils-debuginfod", 
            "elfutils-debuginfod-client", 
            "elfutils-debuginfod-client-devel", 
            "libbpf", 
	    "python3-debuginfo", 
        ],
	"armhfp": [
	    "kernel-lpae*",
	    "uboot-tools",
            "uboot-images*",
            "grub2*",
            "grubby-deprecated",
            "efibootmgr",
            "cloud-utils-growpart",
            "bcm283x-firmware",
            "efivar*",
	]
    }),
]